aboutsummaryrefslogtreecommitdiff
path: root/print/pdfbox
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2011-07-03 08:29:09 +0000
committerWen Heping <wen@FreeBSD.org>2011-07-03 08:29:09 +0000
commiteb0687485a63fff9e04ef4da09660d108f1e2e37 (patch)
treed1346699efce6802bb8de3ab807b91323a7cd774 /print/pdfbox
parent06b97b4ce50a325da44f10255d738f1b32353b09 (diff)
downloadports-eb0687485a63fff9e04ef4da09660d108f1e2e37.tar.gz
ports-eb0687485a63fff9e04ef4da09660d108f1e2e37.zip
Notes
Diffstat (limited to 'print/pdfbox')
-rw-r--r--print/pdfbox/Makefile42
-rw-r--r--print/pdfbox/distinfo6
-rw-r--r--print/pdfbox/pkg-descr19
3 files changed, 67 insertions, 0 deletions
diff --git a/print/pdfbox/Makefile b/print/pdfbox/Makefile
new file mode 100644
index 000000000000..fbb1fdbedae6
--- /dev/null
+++ b/print/pdfbox/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: pdfbox
+# Date created: 03 July, 2011
+# Whom: Pedro Giffuni <giffunip@tutopia.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pdfbox
+PORTVERSION= 1.6.0
+CATEGORIES= print textproc java
+MASTER_SITES= ${MASTER_SITE_APACHE:S,%SUBDIR%,pdfbox/${PORTVERSION},}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTFILES= ${PORTNAME}-app-${PORTVERSION}.jar \
+ fontbox-${PORTVERSION}.jar jempbox-${PORTVERSION}.jar
+
+MAINTAINER= giffunip@tutopia.com
+COMMENT= Java PDF Library
+
+RUN_DEPENDS= ${JAVAJARDIR}/bcmail.jar:${PORTSDIR}/java/bouncycastle \
+ ${JAVALIBDIR}/commons-logging.jar:${PORTSDIR}/java/jakarta-commons-logging
+
+LICENSE= ASL
+
+USE_JAVA= yes
+JAVA_VERSION= 1.5+
+
+DIST_SUBDIR= ${PORTNAME}
+NO_EXTRACT= yes
+NO_BUILD= yes
+
+PLIST_FILES= %%JAVAJARDIR%%/fontbox-${PORTVERSION}.jar \
+ %%JAVAJARDIR%%/jempbox-${PORTVERSION}.jar \
+ %%JAVAJARDIR%%/${PORTNAME}-app-${PORTVERSION}.jar
+
+do-install:
+ @${ECHO_MSG} -n ">> Installing JAR files in ${JAVAJARDIR}..."
+ @${MKDIR} ${JAVAJARDIR}
+ @${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/*-${PORTVERSION}.jar \
+ ${JAVAJARDIR}
+ @${ECHO_MSG} " [ DONE ]"
+
+.include <bsd.port.mk>
diff --git a/print/pdfbox/distinfo b/print/pdfbox/distinfo
new file mode 100644
index 000000000000..2f9e7999b26c
--- /dev/null
+++ b/print/pdfbox/distinfo
@@ -0,0 +1,6 @@
+SHA256 (pdfbox/pdfbox-app-1.6.0.jar) = d02d4ed9e67230e49f692e28a3a9b66e3a804146ef84270876b4f570467c87e2
+SIZE (pdfbox/pdfbox-app-1.6.0.jar) = 10308868
+SHA256 (pdfbox/fontbox-1.6.0.jar) = 068b3d515c7e75db03c88d1c079f17d9aa8022a36769db2c03a61d316f14a0d7
+SIZE (pdfbox/fontbox-1.6.0.jar) = 174824
+SHA256 (pdfbox/jempbox-1.6.0.jar) = c12bd94ee35a3d3d9c0dcf125f52e4e33657cd30d8c184911b24c71f0ff691b6
+SIZE (pdfbox/jempbox-1.6.0.jar) = 51360
diff --git a/print/pdfbox/pkg-descr b/print/pdfbox/pkg-descr
new file mode 100644
index 000000000000..b83a7df8df85
--- /dev/null
+++ b/print/pdfbox/pkg-descr
@@ -0,0 +1,19 @@
+Apache PDFBox - Java PDF Library
+
+Apache PDFBox is an open source Java PDF library for working with PDF
+documents. This project allows creation of new PDF documents, manipulation of
+existing documents and the ability to extract content from documents. Apache
+PDFBox also includes a command line utility.
+
+Features
+
+ * PDF to text extraction
+ * Merge PDF Documents
+ * PDF Document Encryption/Decryption
+ * Lucene Search Engine Integration
+ * Fill in form data FDF and XFDF
+ * Create a PDF from a text file
+ * Create images from PDF pages
+ * Print a PDF
+
+WWW: http://pdfbox.apache.org/