aboutsummaryrefslogtreecommitdiff
path: root/print/pdflib
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2005-08-28 07:59:26 +0000
committerAlex Dupre <ale@FreeBSD.org>2005-08-28 07:59:26 +0000
commitb2f90dc533f458ac66a24efdb5c1bae88e2765cf (patch)
tree8263e7c243943c74c0617c876c1db911058601a8 /print/pdflib
parent0083ef4403a5409b575af728a51b7caf9603b374 (diff)
downloadports-b2f90dc533f458ac66a24efdb5c1bae88e2765cf.tar.gz
ports-b2f90dc533f458ac66a24efdb5c1bae88e2765cf.zip
Notes
Diffstat (limited to 'print/pdflib')
-rw-r--r--print/pdflib/Makefile5
-rw-r--r--print/pdflib/distinfo4
-rw-r--r--print/pdflib/files/patch-libs::tiff::tif_dirread.c51
-rw-r--r--print/pdflib/files/patch-libs::tiff::tif_fax3.c11
4 files changed, 4 insertions, 67 deletions
diff --git a/print/pdflib/Makefile b/print/pdflib/Makefile
index b886a3fce7e2..33052857bfdf 100644
--- a/print/pdflib/Makefile
+++ b/print/pdflib/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= pdflib
-PORTVERSION= 6.0.1
-PORTREVISION= 2
+PORTVERSION= 6.0.2
CATEGORIES= print
-MASTER_SITES= http://voodoo.oberon.net/download/
+MASTER_SITES= http://pdflib.com/products/pdflib/download/${PORTVERSION:S/.//g}src/
DISTNAME= PDFlib-Lite-${PORTVERSION}
MAINTAINER= ale@FreeBSD.org
diff --git a/print/pdflib/distinfo b/print/pdflib/distinfo
index 7e412552c5a2..d446701223e9 100644
--- a/print/pdflib/distinfo
+++ b/print/pdflib/distinfo
@@ -1,2 +1,2 @@
-MD5 (PDFlib-Lite-6.0.1.tar.gz) = 6a4f3c0c8407e0ed1d5c9d5233b1b62b
-SIZE (PDFlib-Lite-6.0.1.tar.gz) = 3642803
+MD5 (PDFlib-Lite-6.0.2.tar.gz) = eaeb8d8f000af50e6057eb2378ab6a94
+SIZE (PDFlib-Lite-6.0.2.tar.gz) = 3682148
diff --git a/print/pdflib/files/patch-libs::tiff::tif_dirread.c b/print/pdflib/files/patch-libs::tiff::tif_dirread.c
deleted file mode 100644
index b59744f1beca..000000000000
--- a/print/pdflib/files/patch-libs::tiff::tif_dirread.c
+++ /dev/null
@@ -1,51 +0,0 @@
---- libs/tiff/tif_dirread.c.orig Fri Nov 26 21:39:06 2004
-+++ libs/tiff/tif_dirread.c Mon Aug 1 01:06:34 2005
-@@ -69,7 +69,7 @@
- char *cp = NULL;
- tsize_t bytes = nmemb * elem_size;
-
-- if (elem_size && bytes / elem_size == nmemb)
-+ if (nmemb && elem_size && bytes / elem_size == nmemb)
- cp = (char*)_TIFFmalloc(tif, bytes);
-
- if (cp == NULL)
-@@ -1267,12 +1267,16 @@
- uint16 buf[10];
- uint16* v = buf;
-
-- if (samples > (int)NITEMS(buf))
-- v = (uint16*) CheckMalloc(tif, samples, sizeof (uint16),
-+ if (dir->tdir_count > (int)NITEMS(buf))
-+ v = (uint16*) CheckMalloc(tif, dir->tdir_count, sizeof (uint16),
- "to fetch per-sample values");
- if (v && TIFFFetchShortArray(tif, dir, v)) {
- int i;
-- for (i = 1; i < samples; i++)
-+ int check_count = dir->tdir_count;
-+ if( samples < check_count )
-+ check_count = samples;
-+
-+ for (i = 1; i < check_count; i++)
- if (v[i] != v[0]) {
- TIFFError(tif->tif_name,
- "Cannot handle different per-sample values for field \"%s\"",
-@@ -1304,12 +1308,16 @@
- double buf[10];
- double* v = buf;
-
-- if (samples > (int)NITEMS(buf))
-- v = (double*) CheckMalloc(tif, samples, sizeof (double),
-+ if (dir->tdir_count > (int)NITEMS(buf))
-+ v = (double*) CheckMalloc(tif, dir->tdir_count, sizeof (double),
- "to fetch per-sample values");
- if (v && TIFFFetchAnyArray(tif, dir, v)) {
- int i;
-- for (i = 1; i < samples; i++)
-+ int check_count = dir->tdir_count;
-+ if( samples < check_count )
-+ check_count = samples;
-+
-+ for (i = 1; i < check_count; i++)
- if (v[i] != v[0]) {
- TIFFError(tif->tif_name,
- "Cannot handle different per-sample values for field \"%s\"",
diff --git a/print/pdflib/files/patch-libs::tiff::tif_fax3.c b/print/pdflib/files/patch-libs::tiff::tif_fax3.c
deleted file mode 100644
index 7e4b3723335b..000000000000
--- a/print/pdflib/files/patch-libs::tiff::tif_fax3.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- libs/tiff/tif_fax3.c.orig Sun Jan 23 12:05:49 2005
-+++ libs/tiff/tif_fax3.c Sun Jan 23 12:06:35 2005
-@@ -445,7 +445,7 @@
- char *cp = NULL;
- tsize_t bytes = nmemb * elem_size;
-
-- if (elem_size && bytes / elem_size == nmemb)
-+ if (nmemb && elem_size && bytes / elem_size == nmemb)
- cp = (char*) _TIFFmalloc(tif, bytes);
-
- if (cp == NULL)