aboutsummaryrefslogtreecommitdiff
path: root/print/pfaedit
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-02-22 06:52:23 +0000
committerPatrick Li <pat@FreeBSD.org>2002-02-22 06:52:23 +0000
commit826f36f5dcb1c4d37a6a1f590a3439ed50d60ebe (patch)
treee975d343245f2d370929588a3ed009610f206fa0 /print/pfaedit
parent6ef33717a5bb44e03f6c0609040ecb4a37888253 (diff)
downloadports-826f36f5dcb1c4d37a6a1f590a3439ed50d60ebe.tar.gz
ports-826f36f5dcb1c4d37a6a1f590a3439ed50d60ebe.zip
Notes
Diffstat (limited to 'print/pfaedit')
-rw-r--r--print/pfaedit/Makefile60
-rw-r--r--print/pfaedit/distinfo3
-rw-r--r--print/pfaedit/pkg-plist160
3 files changed, 216 insertions, 7 deletions
diff --git a/print/pfaedit/Makefile b/print/pfaedit/Makefile
index 1ea1a4368d8f..30b2b87ec629 100644
--- a/print/pfaedit/Makefile
+++ b/print/pfaedit/Makefile
@@ -10,13 +10,17 @@ PORTVERSION= 20${DIST_VER}
CATEGORIES= print
MASTER_SITES= http://pfaedit.sourceforge.net/
DISTFILES= ${PORTNAME}_full-${DIST_VER}.tgz cidmaps.tgz
+.if !defined(NOPORTDOCS)
+DISTFILES+= ${PORTNAME}_htdocs-${DOC_VER}.tgz
+.endif
MAINTAINER= kanou@mil.allnet.ne.jp
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
- ungif.5:${PORTSDIR}/graphics/libungif
+ ungif.5:${PORTSDIR}/graphics/libungif \
+ freetype.8:${PORTSDIR}/print/freetype2
USE_GMAKE= yes
USE_XLIB= yes
@@ -28,9 +32,58 @@ ALL_TARGET= pfaedit
MAN1= pfaedit.1
-DIST_VER= 020122
+DIST_VER= 020220
+
+.if !defined(NOPORTDOCS)
+DOC_VER= 020214
+DOCFILES= AA-Comparison.html HotKeys.html MetaFont.html \
+ Problems-MacOSX.html accented.html bezier.html bitmapview.html \
+ charview.html cidmenu.html cliargs.html corpchar.html \
+ diffs.html editexample.html editmenu.html elementmenu.html \
+ errrecovery.html faq.html faqFS.html faqFrame.html \
+ filemenu.html fontinfo.html fontview.html future.html \
+ getinfo.html helpmenu.html hinting.html hintsmenu.html \
+ index.html license.html locale.html macformats.html \
+ metricsmenu.html metricsview.html oldchangelog.html \
+ otherlinks.html overview.html pcf-format.html pointmenu.html \
+ print.html problems.html scripting.html sfd.html \
+ sfdformat.html splinefont.html src.html transform.html \
+ viewmenu.html views.html windowmenu.html xres.html \
+ corpchar.txt AmbrosiaFV-bm.png AmbrosiaFV.png BitmapView.png \
+ C1.png C10.png C2.png C3.png C4.png C5.png C6.png C7.png \
+ C8.png C9.png CaslonOriginality.png CharPrint.png \
+ CharView.png Constrain1_1.png Constrain1_2.png \
+ Constrain2_1.png Constrain2_2.png CyrilItalicComp.png \
+ Eback.png EbackTtf.png Efore.png EforeTtf.png \
+ Ehinted.png EhintedTtf.png FontDisplay.png FontSample.png \
+ GridFitM.png H-bm.png H-gm.png HI.hints.png HI.nohints.png \
+ HebrewMetrics.png Hints.png ItalicCompCaslon.png \
+ ItalicCompGalliard.png MetricsView.png NoPointHint.png \
+ PageSetup.png Print.png ReviewHints.png Spacem_1.png Spacem_2.png \
+ aacutebase.png aacutemid.png acenter.png ahighest.png autokern.png \
+ autowidth.png bitmapchar.png bitmapsavail.png bvlayers.png \
+ bvtools.png charinfo.png charview-vert.png charview2.png cpodd.png \
+ expandedlines.png expandstroke.png findprobs.png fontinfo-cid.png \
+ fontinfo-comment.png fontinfo-encoding.png fontinfo-panose.png \
+ fontinfo-private.png fontinfo-ps.png fontinfo-ttfname.png \
+ fontinfo-ttfvals.png fontinfo.png fontview-cid.png \
+ fontview.fr.png fontview.ru.png hexley.png kanjichar.png \
+ kanjifont.png layers.png newfont.png outlinechar.png \
+ overlappedlines.png phi-hints-filled.png phi-hints-outline.png \
+ phi-nohints-filled.png phi-nohints-outline.png pointinfo.png \
+ privatekey.png privatekeymenu.png serif.png serif2.png \
+ setwidth.png splash.png strokechar.png tools.png transform.png \
+ twolines.png bezier.gif pnts.gif splines.gif Encodings.ps.gz \
+ document.nvd
+.endif
post-patch:
+ ${PERL} -pi.orig -e \
+ 's,/usr/include/freetype2,${PREFIX}/include/freetype2 -I${PREFIX}/include,g' \
+ ${WRKSRC}/configure ${WRKSRC}/configure.in \
+ ${WRKSRC}/configure.pfaedit ${WRKSRC}/configure.pfaedit.in \
+ ${WRKSRC}/configure.static ${WRKSRC}/configure.static.in \
+ ${WRKSRC}/configure.ttfmod ${WRKSRC}/configure.ttfmod.in
${PERL} -pi.orig -e 's,/usr/share/,${PREFIX}/share/,g' \
${WRKSRC}/pfaedit/pfaedit.1
${PERL} -pi.orig -e 's,/usr/pkg/,${PREFIX}/,g' \
@@ -43,5 +96,8 @@ do-install:
${MKDIR} ${PREFIX}/share/doc/pfaedit
${INSTALL_DATA} ${WRKSRC}/LICENSE ${PREFIX}/share/doc/pfaedit
${INSTALL_MAN} ${WRKSRC}/pfaedit/pfaedit.1 ${PREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ (cd ${WRKDIR}; ${INSTALL_DATA} ${DOCFILES} ${PREFIX}/share/doc/pfaedit)
+.endif
.include <bsd.port.mk>
diff --git a/print/pfaedit/distinfo b/print/pfaedit/distinfo
index c285936337aa..78f3b9f35943 100644
--- a/print/pfaedit/distinfo
+++ b/print/pfaedit/distinfo
@@ -1,2 +1,3 @@
-MD5 (pfaedit_full-020122.tgz) = b51fa4d720d29952f70736bda1368490
+MD5 (pfaedit_full-020220.tgz) = 2d7056b930e3de3b9163e629a5b0c671
MD5 (cidmaps.tgz) = 6bc25e216e9fe8b0c3b226cab3886f83
+MD5 (pfaedit_htdocs-020214.tgz) = 4d05e14c3ad4a25edb3a5da93dcbbf83
diff --git a/print/pfaedit/pkg-plist b/print/pfaedit/pkg-plist
index 10fac2161827..10474a3e3c79 100644
--- a/print/pfaedit/pkg-plist
+++ b/print/pfaedit/pkg-plist
@@ -1,10 +1,162 @@
bin/pfaedit
+%%PORTDOCS%%share/doc/pfaedit/AA-Comparison.html
+%%PORTDOCS%%share/doc/pfaedit/AmbrosiaFV-bm.png
+%%PORTDOCS%%share/doc/pfaedit/AmbrosiaFV.png
+%%PORTDOCS%%share/doc/pfaedit/BitmapView.png
+%%PORTDOCS%%share/doc/pfaedit/C1.png
+%%PORTDOCS%%share/doc/pfaedit/C10.png
+%%PORTDOCS%%share/doc/pfaedit/C2.png
+%%PORTDOCS%%share/doc/pfaedit/C3.png
+%%PORTDOCS%%share/doc/pfaedit/C4.png
+%%PORTDOCS%%share/doc/pfaedit/C5.png
+%%PORTDOCS%%share/doc/pfaedit/C6.png
+%%PORTDOCS%%share/doc/pfaedit/C7.png
+%%PORTDOCS%%share/doc/pfaedit/C8.png
+%%PORTDOCS%%share/doc/pfaedit/C9.png
+%%PORTDOCS%%share/doc/pfaedit/CaslonOriginality.png
+%%PORTDOCS%%share/doc/pfaedit/CharPrint.png
+%%PORTDOCS%%share/doc/pfaedit/CharView.png
+%%PORTDOCS%%share/doc/pfaedit/Constrain1_1.png
+%%PORTDOCS%%share/doc/pfaedit/Constrain1_2.png
+%%PORTDOCS%%share/doc/pfaedit/Constrain2_1.png
+%%PORTDOCS%%share/doc/pfaedit/Constrain2_2.png
+%%PORTDOCS%%share/doc/pfaedit/CyrilItalicComp.png
+%%PORTDOCS%%share/doc/pfaedit/Eback.png
+%%PORTDOCS%%share/doc/pfaedit/EbackTtf.png
+%%PORTDOCS%%share/doc/pfaedit/Efore.png
+%%PORTDOCS%%share/doc/pfaedit/EforeTtf.png
+%%PORTDOCS%%share/doc/pfaedit/Ehinted.png
+%%PORTDOCS%%share/doc/pfaedit/EhintedTtf.png
+%%PORTDOCS%%share/doc/pfaedit/Encodings.ps.gz
+%%PORTDOCS%%share/doc/pfaedit/FontDisplay.png
+%%PORTDOCS%%share/doc/pfaedit/FontSample.png
+%%PORTDOCS%%share/doc/pfaedit/GridFitM.png
+%%PORTDOCS%%share/doc/pfaedit/H-bm.png
+%%PORTDOCS%%share/doc/pfaedit/H-gm.png
+%%PORTDOCS%%share/doc/pfaedit/HI.hints.png
+%%PORTDOCS%%share/doc/pfaedit/HI.nohints.png
+%%PORTDOCS%%share/doc/pfaedit/HebrewMetrics.png
+%%PORTDOCS%%share/doc/pfaedit/Hints.png
+%%PORTDOCS%%share/doc/pfaedit/HotKeys.html
+%%PORTDOCS%%share/doc/pfaedit/ItalicCompCaslon.png
+%%PORTDOCS%%share/doc/pfaedit/ItalicCompGalliard.png
+%%PORTDOCS%%share/doc/pfaedit/LICENSE
+%%PORTDOCS%%share/doc/pfaedit/MetaFont.html
+%%PORTDOCS%%share/doc/pfaedit/MetricsView.png
+%%PORTDOCS%%share/doc/pfaedit/NoPointHint.png
+%%PORTDOCS%%share/doc/pfaedit/PageSetup.png
+%%PORTDOCS%%share/doc/pfaedit/Print.png
+%%PORTDOCS%%share/doc/pfaedit/Problems-MacOSX.html
+%%PORTDOCS%%share/doc/pfaedit/ReviewHints.png
+%%PORTDOCS%%share/doc/pfaedit/Spacem_1.png
+%%PORTDOCS%%share/doc/pfaedit/Spacem_2.png
+%%PORTDOCS%%share/doc/pfaedit/aacutebase.png
+%%PORTDOCS%%share/doc/pfaedit/aacutemid.png
+%%PORTDOCS%%share/doc/pfaedit/accented.html
+%%PORTDOCS%%share/doc/pfaedit/acenter.png
+%%PORTDOCS%%share/doc/pfaedit/ahighest.png
+%%PORTDOCS%%share/doc/pfaedit/autokern.png
+%%PORTDOCS%%share/doc/pfaedit/autowidth.png
+%%PORTDOCS%%share/doc/pfaedit/bezier.gif
+%%PORTDOCS%%share/doc/pfaedit/bezier.html
+%%PORTDOCS%%share/doc/pfaedit/bitmapchar.png
+%%PORTDOCS%%share/doc/pfaedit/bitmapsavail.png
+%%PORTDOCS%%share/doc/pfaedit/bitmapview.html
+%%PORTDOCS%%share/doc/pfaedit/bvlayers.png
+%%PORTDOCS%%share/doc/pfaedit/bvtools.png
+%%PORTDOCS%%share/doc/pfaedit/charinfo.png
+%%PORTDOCS%%share/doc/pfaedit/charview-vert.png
+%%PORTDOCS%%share/doc/pfaedit/charview.html
+%%PORTDOCS%%share/doc/pfaedit/charview2.png
+%%PORTDOCS%%share/doc/pfaedit/cidmenu.html
+%%PORTDOCS%%share/doc/pfaedit/cliargs.html
+%%PORTDOCS%%share/doc/pfaedit/corpchar.html
+%%PORTDOCS%%share/doc/pfaedit/corpchar.txt
+%%PORTDOCS%%share/doc/pfaedit/cpodd.png
+%%PORTDOCS%%share/doc/pfaedit/diffs.html
+%%PORTDOCS%%share/doc/pfaedit/document.nvd
+%%PORTDOCS%%share/doc/pfaedit/editexample.html
+%%PORTDOCS%%share/doc/pfaedit/editmenu.html
+%%PORTDOCS%%share/doc/pfaedit/elementmenu.html
+%%PORTDOCS%%share/doc/pfaedit/errrecovery.html
+%%PORTDOCS%%share/doc/pfaedit/expandedlines.png
+%%PORTDOCS%%share/doc/pfaedit/expandstroke.png
+%%PORTDOCS%%share/doc/pfaedit/faq.html
+%%PORTDOCS%%share/doc/pfaedit/faqFS.html
+%%PORTDOCS%%share/doc/pfaedit/faqFrame.html
+%%PORTDOCS%%share/doc/pfaedit/filemenu.html
+%%PORTDOCS%%share/doc/pfaedit/findprobs.png
+%%PORTDOCS%%share/doc/pfaedit/fontinfo-cid.png
+%%PORTDOCS%%share/doc/pfaedit/fontinfo-comment.png
+%%PORTDOCS%%share/doc/pfaedit/fontinfo-encoding.png
+%%PORTDOCS%%share/doc/pfaedit/fontinfo-panose.png
+%%PORTDOCS%%share/doc/pfaedit/fontinfo-private.png
+%%PORTDOCS%%share/doc/pfaedit/fontinfo-ps.png
+%%PORTDOCS%%share/doc/pfaedit/fontinfo-ttfname.png
+%%PORTDOCS%%share/doc/pfaedit/fontinfo-ttfvals.png
+%%PORTDOCS%%share/doc/pfaedit/fontinfo.html
+%%PORTDOCS%%share/doc/pfaedit/fontinfo.png
+%%PORTDOCS%%share/doc/pfaedit/fontview-cid.png
+%%PORTDOCS%%share/doc/pfaedit/fontview.fr.png
+%%PORTDOCS%%share/doc/pfaedit/fontview.html
+%%PORTDOCS%%share/doc/pfaedit/fontview.ru.png
+%%PORTDOCS%%share/doc/pfaedit/future.html
+%%PORTDOCS%%share/doc/pfaedit/getinfo.html
+%%PORTDOCS%%share/doc/pfaedit/helpmenu.html
+%%PORTDOCS%%share/doc/pfaedit/hexley.png
+%%PORTDOCS%%share/doc/pfaedit/hinting.html
+%%PORTDOCS%%share/doc/pfaedit/hintsmenu.html
+%%PORTDOCS%%share/doc/pfaedit/index.html
+%%PORTDOCS%%share/doc/pfaedit/kanjichar.png
+%%PORTDOCS%%share/doc/pfaedit/kanjifont.png
+%%PORTDOCS%%share/doc/pfaedit/layers.png
+%%PORTDOCS%%share/doc/pfaedit/license.html
+%%PORTDOCS%%share/doc/pfaedit/locale.html
+%%PORTDOCS%%share/doc/pfaedit/macformats.html
+%%PORTDOCS%%share/doc/pfaedit/metricsmenu.html
+%%PORTDOCS%%share/doc/pfaedit/metricsview.html
+%%PORTDOCS%%share/doc/pfaedit/newfont.png
+%%PORTDOCS%%share/doc/pfaedit/oldchangelog.html
+%%PORTDOCS%%share/doc/pfaedit/otherlinks.html
+%%PORTDOCS%%share/doc/pfaedit/outlinechar.png
+%%PORTDOCS%%share/doc/pfaedit/overlappedlines.png
+%%PORTDOCS%%share/doc/pfaedit/overview.html
+%%PORTDOCS%%share/doc/pfaedit/pcf-format.html
+%%PORTDOCS%%share/doc/pfaedit/phi-hints-filled.png
+%%PORTDOCS%%share/doc/pfaedit/phi-hints-outline.png
+%%PORTDOCS%%share/doc/pfaedit/phi-nohints-filled.png
+%%PORTDOCS%%share/doc/pfaedit/phi-nohints-outline.png
+%%PORTDOCS%%share/doc/pfaedit/pnts.gif
+%%PORTDOCS%%share/doc/pfaedit/pointinfo.png
+%%PORTDOCS%%share/doc/pfaedit/pointmenu.html
+%%PORTDOCS%%share/doc/pfaedit/print.html
+%%PORTDOCS%%share/doc/pfaedit/privatekey.png
+%%PORTDOCS%%share/doc/pfaedit/privatekeymenu.png
+%%PORTDOCS%%share/doc/pfaedit/problems.html
+%%PORTDOCS%%share/doc/pfaedit/scripting.html
+%%PORTDOCS%%share/doc/pfaedit/serif.png
+%%PORTDOCS%%share/doc/pfaedit/serif2.png
+%%PORTDOCS%%share/doc/pfaedit/setwidth.png
+%%PORTDOCS%%share/doc/pfaedit/sfd.html
+%%PORTDOCS%%share/doc/pfaedit/sfdformat.html
+%%PORTDOCS%%share/doc/pfaedit/splash.png
+%%PORTDOCS%%share/doc/pfaedit/splinefont.html
+%%PORTDOCS%%share/doc/pfaedit/splines.gif
+%%PORTDOCS%%share/doc/pfaedit/src.html
+%%PORTDOCS%%share/doc/pfaedit/strokechar.png
+%%PORTDOCS%%share/doc/pfaedit/tools.png
+%%PORTDOCS%%share/doc/pfaedit/transform.html
+%%PORTDOCS%%share/doc/pfaedit/transform.png
+%%PORTDOCS%%share/doc/pfaedit/twolines.png
+%%PORTDOCS%%share/doc/pfaedit/viewmenu.html
+%%PORTDOCS%%share/doc/pfaedit/views.html
+%%PORTDOCS%%share/doc/pfaedit/windowmenu.html
+%%PORTDOCS%%share/doc/pfaedit/xres.html
share/pfaedit/Adobe-CNS1-4.cidmap
-share/pfaedit/Adobe-Identity-0.cidmap
-share/pfaedit/Adobe-Japan2-0.cidmap
share/pfaedit/Adobe-GB1-4.cidmap
+share/pfaedit/Adobe-Identity-0.cidmap
share/pfaedit/Adobe-Japan1-4.cidmap
+share/pfaedit/Adobe-Japan2-0.cidmap
share/pfaedit/Adobe-Korea1-2.cidmap
@dirrm share/pfaedit
-share/doc/pfaedit/LICENSE
-@dirrm share/doc/pfaedit
+%%PORTDOCS%%@dirrm share/doc/pfaedit