aboutsummaryrefslogtreecommitdiff
path: root/print/pnm2ppa
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-08-31 01:14:24 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-08-31 01:14:24 +0000
commit224ab15da1317b933e2087f959278c8f755f5d48 (patch)
treea5a587a1ad236a43a3d400302fd8ca2cc44ffb50 /print/pnm2ppa
parentfa197747eb3babaeda8976d9bbbe6aedc5e7ea35 (diff)
downloadports-224ab15da1317b933e2087f959278c8f755f5d48.tar.gz
ports-224ab15da1317b933e2087f959278c8f755f5d48.zip
[PATCH] print/pnm2ppa: enable choose of ghostscript interpreter
This patch allows the admin of the machine to choose either print/ghostscript-gnu or print/ghostscript-afp1 PR: ports/54946 Submitted by: Jens Rehsack <rehsack@liwing.de>
Notes
Notes: svn path=/head/; revision=88142
Diffstat (limited to 'print/pnm2ppa')
-rw-r--r--print/pnm2ppa/Makefile18
1 files changed, 16 insertions, 2 deletions
diff --git a/print/pnm2ppa/Makefile b/print/pnm2ppa/Makefile
index 87935e27bfdd..8c5fc1229571 100644
--- a/print/pnm2ppa/Makefile
+++ b/print/pnm2ppa/Makefile
@@ -14,15 +14,29 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Convert PNM images to PPA for some HP printers
-RUN_DEPENDS= gs:${PORTSDIR}/print/ghostscript-gnu \
+.if defined(WITH_GHOSTSCRIPT_AFPL) && ${WITH_GHOSTSCRIPT_AFPL} == yes
+GSPORT?= print/ghostscript-afpl
+.else
+GSPORT?= print/ghostscript-gnu
+.endif
+
+RUN_DEPENDS= gs:${PORTSDIR}/${GSPORT} \
enscript:${PORTSDIR}/print/enscript-letter
USE_GETOPT_LONG= yes
-MAKE_ENV= LDFLAGS="${LDFLAGS}"
+MAKE_ENV= LDFLAGS="${LDFLAGS}"
CFLAGS+= ${CPPFLAGS}
MAN1= pnm2ppa.1
+pre-fetch:
+.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes
+ @${ECHO} ""
+ @${ECHO} " Define WITH_GHOSTSCRIPT_AFPL=yes to use"
+ @${ECHO} " AFPL Postscript interpreter instead of GNU one"
+ @${ECHO} ""
+.endif
+
post-patch:
@${SED} -e "s:%%PREFIX%%:${PREFIX}:g" \
${WRKSRC}/pnm2ppa.conf > ${WRKSRC}/pnm2ppa.conf.sample