aboutsummaryrefslogtreecommitdiff
path: root/print/poster
diff options
context:
space:
mode:
authorSatoshi Taoka <taoka@FreeBSD.org>2000-02-07 14:57:59 +0000
committerSatoshi Taoka <taoka@FreeBSD.org>2000-02-07 14:57:59 +0000
commit759f70b39c28067c08ce023967d628fa1dd326a1 (patch)
tree28ebd5520327e44f96b2e968fffa824ad30eac8d /print/poster
parent6754b57e9cffcb6f388095ee4b860a2095a273d4 (diff)
downloadports-759f70b39c28067c08ce023967d628fa1dd326a1.tar.gz
ports-759f70b39c28067c08ce023967d628fa1dd326a1.zip
Notes
Diffstat (limited to 'print/poster')
-rw-r--r--print/poster/Makefile25
-rw-r--r--print/poster/distinfo1
-rw-r--r--print/poster/files/patch-aa11
-rw-r--r--print/poster/pkg-comment1
-rw-r--r--print/poster/pkg-descr8
-rw-r--r--print/poster/pkg-plist1
6 files changed, 47 insertions, 0 deletions
diff --git a/print/poster/Makefile b/print/poster/Makefile
new file mode 100644
index 000000000000..ee65b6a01e8a
--- /dev/null
+++ b/print/poster/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: poster
+# Version required: 1.0
+# Date created: 15 January 2000
+# Whom: Yoshiro MIHIRA <sanpei@sanpei.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= poster
+PKGNAME= poster-1.0
+CATEGORIES= print
+MASTER_SITES= ftp://ftp.ics.ele.tue.nl/pub/users/jos/poster/
+
+MAINTAINER= sanpei@sanpei.org
+
+ALL_TARGET= poster
+NO_WRKSUBDIR= yes
+
+MAN1= poster.1
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${DISTNAME} ${PREFIX}/bin
+ @${INSTALL_DATA} ${WRKSRC}/${DISTNAME}.1 ${PREFIX}/man/man1/
+
+.include <bsd.port.mk>
diff --git a/print/poster/distinfo b/print/poster/distinfo
new file mode 100644
index 000000000000..73cbee6f2611
--- /dev/null
+++ b/print/poster/distinfo
@@ -0,0 +1 @@
+MD5 (poster.tar.gz) = d00b3b1c7c239b2eb205637f8a5a0868
diff --git a/print/poster/files/patch-aa b/print/poster/files/patch-aa
new file mode 100644
index 000000000000..8c14e4a52760
--- /dev/null
+++ b/print/poster/files/patch-aa
@@ -0,0 +1,11 @@
+--- poster.c.org Thu Apr 29 00:22:46 1999
++++ poster.c Sun Jan 30 00:48:11 2000
+@@ -570,7 +570,7 @@
+
+ got_bb = 0;
+ dsc_cont = inbody = gotall = level = atend = 0;
+- while (!gotall && (gets(buf) != NULL))
++ while (!gotall && (fgets(buf, BUFSIZE, stdin) != NULL))
+ {
+ if (buf[0] != '%')
+ { dsc_cont = 0;
diff --git a/print/poster/pkg-comment b/print/poster/pkg-comment
new file mode 100644
index 000000000000..e885c1120dd5
--- /dev/null
+++ b/print/poster/pkg-comment
@@ -0,0 +1 @@
+resize a postscript image to print on larger media and/or multiple sheets
diff --git a/print/poster/pkg-descr b/print/poster/pkg-descr
new file mode 100644
index 000000000000..3737d7a1312b
--- /dev/null
+++ b/print/poster/pkg-descr
@@ -0,0 +1,8 @@
+Here you have the new release of `poster', to scale postscript
+images to a larger size, and print them on larger media and/or
+tile them to print on multiple sheets.
+With respect to the earlier release:
+- support is added for foreign (Non European A*) media sizes.
+- options for scaling became more flexible
+- original restrictions on white margins in your drawing are removed.
+For a complete explanation see the accompanying manual.
diff --git a/print/poster/pkg-plist b/print/poster/pkg-plist
new file mode 100644
index 000000000000..b2baa64197da
--- /dev/null
+++ b/print/poster/pkg-plist
@@ -0,0 +1 @@
+bin/poster