aboutsummaryrefslogtreecommitdiff
path: root/print/pslib
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2006-06-12 01:43:27 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2006-06-12 01:43:27 +0000
commit0c3f54a6764d40452fef2a2eec934469f16a6466 (patch)
tree90dc0c44b56bebe4a1d4a72f1d6f74edc8a5d07f /print/pslib
parentd0c12a0e3ad08a5798520fd56886e6282b8e99b1 (diff)
downloadports-0c3f54a6764d40452fef2a2eec934469f16a6466.tar.gz
ports-0c3f54a6764d40452fef2a2eec934469f16a6466.zip
Notes
Diffstat (limited to 'print/pslib')
-rw-r--r--print/pslib/Makefile15
-rw-r--r--print/pslib/distinfo6
-rw-r--r--print/pslib/files/patch-src__bmp.c31
3 files changed, 45 insertions, 7 deletions
diff --git a/print/pslib/Makefile b/print/pslib/Makefile
index b21a4286a3f9..005124f9e78c 100644
--- a/print/pslib/Makefile
+++ b/print/pslib/Makefile
@@ -7,8 +7,8 @@
#
PORTNAME= pslib
-PORTVERSION= 0.2.6
-PORTREVISION= 1
+PORTVERSION= 0.2.7
+PORTREVISION= 0
CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -17,10 +17,12 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A C-library for generating multi page PostScript documents
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
- png.5:${PORTSDIR}/graphics/png
+ png.5:${PORTSDIR}/graphics/png \
+ tiff.4:${PORTSDIR}/graphics/tiff
USE_GNOME= gnomehack gnometarget intlhack pkgconfig
-GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
ac_cv_prog_DOC_TO_MAN=""
@@ -34,4 +36,9 @@ USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.endif
+post-patch:
+.if defined(WITHOUT_NLS)
+ @${REINPLACE_CMD} -e 's|@USE_NLS@|no|g' ${WRKSRC}/po/Makefile.in.in
+.endif
+
.include <bsd.port.mk>
diff --git a/print/pslib/distinfo b/print/pslib/distinfo
index cde96dbb0b10..967a6c93f915 100644
--- a/print/pslib/distinfo
+++ b/print/pslib/distinfo
@@ -1,3 +1,3 @@
-MD5 (pslib-0.2.6.tar.gz) = 6727e5086c7e6795e7b0db6f49442a2e
-SHA256 (pslib-0.2.6.tar.gz) = 48a61dd1f22fa6e2175e32560039ea9875121281f437377f60d74bc4aa92f334
-SIZE (pslib-0.2.6.tar.gz) = 486812
+MD5 (pslib-0.2.7.tar.gz) = 17a6a461276fd4eb3fd12ced926aeee1
+SHA256 (pslib-0.2.7.tar.gz) = 653ec4b1685500d3eb86dc89093854e1928f040b457556365bd52a31dda9a84d
+SIZE (pslib-0.2.7.tar.gz) = 510671
diff --git a/print/pslib/files/patch-src__bmp.c b/print/pslib/files/patch-src__bmp.c
new file mode 100644
index 000000000000..981e8d46e949
--- /dev/null
+++ b/print/pslib/files/patch-src__bmp.c
@@ -0,0 +1,31 @@
+--- src/bmp.c.orig Mon Apr 24 23:25:31 2006
++++ src/bmp.c Thu Jun 8 18:59:00 2006
+@@ -41,10 +41,28 @@
+ #include <fcntl.h>
+ #include <unistd.h>
+
++#if (defined(__unix__) || defined(unix)) && !defined(USG)
++#include <sys/param.h>
++#endif
++
++#if defined(__FreeBSD__) && __FreeBSD_version >= 470000
++#include <sys/endian.h>
++
++#if __FreeBSD_version >= 500000
++#define BMPSwabShort(x) bswap16(x)
++#define BMPSwabLong(x) bswap32(x)
++#else
++#define BMPSwabShort(x) (be16toh(x))
++#define BMPSwabLong(x) (be32toh(x))
++#endif
++#endif
++
++#ifdef linux
+ #include <byteswap.h>
+
+ #define BMPSwabShort(x) *x = bswap_16 (*x)
+ #define BMPSwabLong(x) *x = bswap_32 (*x)
++#endif
+
+ #include <inttypes.h>
+