aboutsummaryrefslogtreecommitdiff
path: root/print/pslib
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-09-09 12:42:00 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-09-09 12:42:00 +0000
commit754c56e7f206706b1db7102c4413f2669ab7b74c (patch)
tree97c5a9c51a203cc09051f6d6f9f4664b1a03bbf7 /print/pslib
parent79b3cac70ac4de2f880966923e144bf819b3ac77 (diff)
downloadports-754c56e7f206706b1db7102c4413f2669ab7b74c.tar.gz
ports-754c56e7f206706b1db7102c4413f2669ab7b74c.zip
- Add OPTIONS, allow users to decide if they want examples and manpages.
Bump PORTREVISION for content changes - Pet portlint(1) - Pass maintainership to submitter PR: ports/102991 Submitted by: Marcus von Appen <mva at sysfault.org>
Notes
Notes: svn path=/head/; revision=172635
Diffstat (limited to 'print/pslib')
-rw-r--r--print/pslib/Makefile37
-rw-r--r--print/pslib/distinfo3
-rw-r--r--print/pslib/files/man393
-rw-r--r--print/pslib/pkg-plist36
4 files changed, 164 insertions, 5 deletions
diff --git a/print/pslib/Makefile b/print/pslib/Makefile
index df46f80d88d7..8b72a93a4dcc 100644
--- a/print/pslib/Makefile
+++ b/print/pslib/Makefile
@@ -8,12 +8,12 @@
PORTNAME= pslib
PORTVERSION= 0.2.7
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= mva@sysfault.org
COMMENT= A C-library for generating multi page PostScript documents
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
@@ -24,12 +24,34 @@ USE_GNOME= gnomehack gnometarget intlhack pkgconfig
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib" \
- ac_cv_prog_DOC_TO_MAN=""
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --mandir=${MANPREFIX}/man
USE_LDCONFIG= yes
+OPTIONS= EXAMPLES "Install additional examples" On \
+ MAN "Install manual pages" On \
+ NLS "Native language support" On
+
.include <bsd.port.pre.mk>
+.if !defined(WITHOUT_EXAMPLES)
+EX_NAME= pslib-examples-0.0.8
+EX_WRKSRC= ${WRKDIR}/${EX_NAME}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${EX_NAME}${EXTRACT_SUFX}
+PLIST_SUB+= EXAMPLES=""
+.else
+PLIST_SUB+= EXAMPLES="@comment "
+.endif
+
+.if !defined(WITHOUT_MAN)
+BUILD_DEPENDS+= ${LOCALBASE}/bin/docbook-to-man:${PORTSDIR}/textproc/docbook-to-man \
+ ${LOCALBASE}/bin/docbook2man:${PORTSDIR}/textproc/docbook-utils
+MAN3!= ${CAT} ${FILESDIR}/man3
+.else
+# Avoid building the manpages.
+CONFIGURE_ENV+= ac_cv_prog_DOC_TO_MAN=""
+.endif
+
.if defined(WITHOUT_NLS)
CONFIGURE_ENV+= ac_cv_header_libintl_h=no
PLIST_SUB+= NLS="@comment "
@@ -43,4 +65,11 @@ post-patch:
@${REINPLACE_CMD} -e 's|@USE_NLS@|no|g' ${WRKSRC}/po/Makefile.in.in
.endif
+post-install:
+.if !defined(WITHOUT_EXAMPLES)
+ ${MKDIR} -m 0755 ${EXAMPLESDIR}
+ @${RM} -f ${EX_WRKSRC}/Makefile ${EX_WRKSRC}/ChangeLog
+ cd ${EX_WRKSRC} && ${PAX} -rw * ${EXAMPLESDIR}
+.endif
+
.include <bsd.port.post.mk>
diff --git a/print/pslib/distinfo b/print/pslib/distinfo
index 967a6c93f915..906791223ccc 100644
--- a/print/pslib/distinfo
+++ b/print/pslib/distinfo
@@ -1,3 +1,6 @@
MD5 (pslib-0.2.7.tar.gz) = 17a6a461276fd4eb3fd12ced926aeee1
SHA256 (pslib-0.2.7.tar.gz) = 653ec4b1685500d3eb86dc89093854e1928f040b457556365bd52a31dda9a84d
SIZE (pslib-0.2.7.tar.gz) = 510671
+MD5 (pslib-examples-0.0.8.tar.gz) = ef7ea1c869047b9510fb1ea55cfa9e76
+SHA256 (pslib-examples-0.0.8.tar.gz) = cfab81f3639e2863e92c226ba6b6a06b0c482afc524d041bcb1df4cbe74f8ebd
+SIZE (pslib-examples-0.0.8.tar.gz) = 175792
diff --git a/print/pslib/files/man3 b/print/pslib/files/man3
new file mode 100644
index 000000000000..e542ba69e793
--- /dev/null
+++ b/print/pslib/files/man3
@@ -0,0 +1,93 @@
+PS_add_bookmark.3
+PS_add_launchlink.3
+PS_add_locallink.3
+PS_add_note.3
+PS_add_pdflink.3
+PS_add_weblink.3
+PS_arc.3
+PS_arcn.3
+PS_begin_page.3
+PS_begin_pattern.3
+PS_begin_template.3
+PS_boot.3
+PS_circle.3
+PS_clip.3
+PS_close.3
+PS_close_image.3
+PS_closepath.3
+PS_closepath_stroke.3
+PS_continue_text.3
+PS_continue_text2.3
+PS_create_gstate.3
+PS_curveto.3
+PS_delete.3
+PS_end_page.3
+PS_end_pattern.3
+PS_end_template.3
+PS_fill.3
+PS_fill_stroke.3
+PS_findfont.3
+PS_get_buffer.3
+PS_get_majorversion.3
+PS_get_minorversion.3
+PS_get_opaque.3
+PS_get_parameter.3
+PS_get_subminorversion.3
+PS_get_value.3
+PS_hyphenate.3
+PS_include_file.3
+PS_lineto.3
+PS_list_parameters.3
+PS_list_resources.3
+PS_list_values.3
+PS_makespotcolor.3
+PS_moveto.3
+PS_new.3
+PS_new2.3
+PS_open_file.3
+PS_open_fp.3
+PS_open_image.3
+PS_open_image_file.3
+PS_open_mem.3
+PS_place_image.3
+PS_rect.3
+PS_restore.3
+PS_rotate.3
+PS_save.3
+PS_scale.3
+PS_set_border_color.3
+PS_set_border_dash.3
+PS_set_border_style.3
+PS_set_gstate.3
+PS_set_info.3
+PS_set_parameter.3
+PS_set_text_pos.3
+PS_set_value.3
+PS_setcolor.3
+PS_setdash.3
+PS_setflat.3
+PS_setfont.3
+PS_setgray.3
+PS_setlinecap.3
+PS_setlinejoin.3
+PS_setlinewidth.3
+PS_setmiterlimit.3
+PS_setpolydash.3
+PS_shading.3
+PS_shading_pattern.3
+PS_shfill.3
+PS_show.3
+PS_show2.3
+PS_show_boxed.3
+PS_show_xy.3
+PS_show_xy2.3
+PS_shutdown.3
+PS_string_geometry.3
+PS_stringwidth.3
+PS_stringwidth2.3
+PS_stroke.3
+PS_symbol.3
+PS_symbol_name.3
+PS_symbol_width.3
+PS_translate.3
+pslib.3
diff --git a/print/pslib/pkg-plist b/print/pslib/pkg-plist
index 90b9200600a3..355981e8b654 100644
--- a/print/pslib/pkg-plist
+++ b/print/pslib/pkg-plist
@@ -1,4 +1,3 @@
-@comment $FreeBSD$
include/libps/pslib-mp.h
include/libps/pslib.h
include/libps/psversion.h
@@ -11,5 +10,40 @@ libdata/pkgconfig/libps.pc
%%DATADIR%%/draft.ps
%%DATADIR%%/exectime.ps
%%DATADIR%%/grid.ps
+%%EXAMPLES%%%%EXAMPLESDIR%%/AlteSchwabacher.afm
+%%EXAMPLES%%%%EXAMPLESDIR%%/AlteSchwabacher.enc
+%%EXAMPLES%%%%EXAMPLESDIR%%/AlteSchwabacher.pfb
+%%EXAMPLES%%%%EXAMPLESDIR%%/Courier.afm
+%%EXAMPLES%%%%EXAMPLESDIR%%/Helvetica.afm
+%%EXAMPLES%%%%EXAMPLESDIR%%/Helvetica.pro
+%%EXAMPLES%%%%EXAMPLESDIR%%/README
+%%EXAMPLES%%%%EXAMPLESDIR%%/cork.enc
+%%EXAMPLES%%%%EXAMPLESDIR%%/debian.png
+%%EXAMPLES%%%%EXAMPLESDIR%%/dice.afm
+%%EXAMPLES%%%%EXAMPLESDIR%%/dice.pfb
+%%EXAMPLES%%%%EXAMPLESDIR%%/draw.c
+%%EXAMPLES%%%%EXAMPLESDIR%%/einstein.c
+%%EXAMPLES%%%%EXAMPLESDIR%%/einstein.txt
+%%EXAMPLES%%%%EXAMPLESDIR%%/fontsample.c
+%%EXAMPLES%%%%EXAMPLESDIR%%/hyperlinks.c
+%%EXAMPLES%%%%EXAMPLESDIR%%/hyph_de.dic
+%%EXAMPLES%%%%EXAMPLESDIR%%/hyph_en.dic
+%%EXAMPLES%%%%EXAMPLESDIR%%/hyphenate.c
+%%EXAMPLES%%%%EXAMPLESDIR%%/image.c
+%%EXAMPLES%%%%EXAMPLESDIR%%/indexed-alpha.png
+%%EXAMPLES%%%%EXAMPLESDIR%%/indexed.png
+%%EXAMPLES%%%%EXAMPLESDIR%%/ligatures.c
+%%EXAMPLES%%%%EXAMPLESDIR%%/memory.c
+%%EXAMPLES%%%%EXAMPLESDIR%%/mmk.c
+%%EXAMPLES%%%%EXAMPLESDIR%%/overprint.c
+%%EXAMPLES%%%%EXAMPLESDIR%%/pagehook.c
+%%EXAMPLES%%%%EXAMPLESDIR%%/picture.eps
+%%EXAMPLES%%%%EXAMPLESDIR%%/psclock.c
+%%EXAMPLES%%%%EXAMPLESDIR%%/rgb-alpha.png
+%%EXAMPLES%%%%EXAMPLESDIR%%/rgb.png
+%%EXAMPLES%%%%EXAMPLESDIR%%/shading.c
+%%EXAMPLES%%%%EXAMPLESDIR%%/spotcolor.c
+%%EXAMPLES%%%%EXAMPLESDIR%%/txt2ps.c
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%
@dirrm %%DATADIR%%
@dirrm include/libps