aboutsummaryrefslogtreecommitdiff
path: root/print/pstotext/Makefile
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2014-06-15 14:03:26 +0000
committerJason E. Hale <jhale@FreeBSD.org>2014-06-15 14:03:26 +0000
commitac44c6a7372b9c2cf7872baace45c8df14e6d979 (patch)
tree2b65f632014214e9bfb363e4679403c26f66a0a1 /print/pstotext/Makefile
parentceba983ef66b08992dbada636adc6d92804e8063 (diff)
downloadports-ac44c6a7372b9c2cf7872baace45c8df14e6d979.tar.gz
ports-ac44c6a7372b9c2cf7872baace45c8df14e6d979.zip
- Support staging
- Rename generic-named patches to specific file names - Define LICENSE using file previously installed with the DOCS option - Remove DOCS option as it only installed aforementioned license file - Bump PORTREVISION since OPTIONS changed
Notes
Notes: svn path=/head/; revision=357884
Diffstat (limited to 'print/pstotext/Makefile')
-rw-r--r--print/pstotext/Makefile32
1 files changed, 15 insertions, 17 deletions
diff --git a/print/pstotext/Makefile b/print/pstotext/Makefile
index afa0d58c12b5..4b6816123cc4 100644
--- a/print/pstotext/Makefile
+++ b/print/pstotext/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pstotext
PORTVERSION= 1.9
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= print
MASTER_SITES= http://ftp.gwdg.de/pub/%SUBDIR%/ \
http://ftp.sunet.se/pub/text-processing/postscript/interpreters/%SUBDIR%/ \
@@ -14,28 +14,26 @@ MASTER_SITE_SUBDIR= ghostscript/contrib
MAINTAINER= ports@FreeBSD.org
COMMENT= PostScript to Text converter
-USE_GHOSTSCRIPT_RUN= yes
-
-MAN1= pstotext.1
-PLIST_FILES= bin/pstotext
-PORTDOCS= copyright
+LICENSE= EULA
+LICENSE_NAME= End User License Agreement
+LICENSE_FILE= ${WRKSRC}/pstotext.txt
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-NO_STAGE= yes
+USE_GHOSTSCRIPT_RUN= yes
-OPTIONS_DEFINE= DOCS
+SUB_LIST= LICENSE=${LICENSE} \
+ LICENSE_DIR=${_LICENSE_DIR}
-.include <bsd.port.options.mk>
+PLIST_FILES= bin/pstotext \
+ man/man1/pstotext.1.gz
post-patch:
- ${REINPLACE_CMD} -e 's;%%LOCALBASE%%;${LOCALBASE};g' ${WRKSRC}/main.c
- ${REINPLACE_CMD} -e 's;%%PREFIX%%;${PREFIX};g' ${WRKSRC}/pstotext.1
+ @${REINPLACE_CMD} ${SUB_LIST:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+ ${WRKSRC}/main.c \
+ ${WRKSRC}/pstotext.1
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/pstotext ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/pstotext.1 ${MAN1PREFIX}/man/man1
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/pstotext.txt ${DOCSDIR}/copyright
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/pstotext ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/pstotext.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
.include <bsd.port.mk>