aboutsummaryrefslogtreecommitdiff
path: root/print/py-pycups
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-12-11 10:02:18 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-12-11 10:02:18 +0000
commit90dcc9ae9e54a1f8e44f658110771a54d5fde937 (patch)
tree665d733c3e4a5aa8037af1481f454af5759805ba /print/py-pycups
parent6713c94829d3ae27ce63f67511b0253945477bb1 (diff)
downloadports-90dcc9ae9e54a1f8e44f658110771a54d5fde937.tar.gz
ports-90dcc9ae9e54a1f8e44f658110771a54d5fde937.zip
- Move print/py-cups to print/py-pycups
- Bump PORTREVISION for dependent ports
Notes
Notes: svn path=/head/; revision=403510
Diffstat (limited to 'print/py-pycups')
-rw-r--r--print/py-pycups/Makefile36
-rw-r--r--print/py-pycups/distinfo2
-rw-r--r--print/py-pycups/pkg-descr4
3 files changed, 42 insertions, 0 deletions
diff --git a/print/py-pycups/Makefile b/print/py-pycups/Makefile
new file mode 100644
index 000000000000..3e4e55978c2d
--- /dev/null
+++ b/print/py-pycups/Makefile
@@ -0,0 +1,36 @@
+# Created by: Michael Johnson <ahze@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pycups
+PORTVERSION= 1.9.73
+CATEGORIES= print python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= CUPS bindings for Python
+
+LICENSE= GPLv2 GPLv3
+LICENSE_COMB= dual
+
+LIB_DEPENDS= libcups.so:${PORTSDIR}/print/cups-client
+
+USE_PYTHON= autoplist concurrent distutils
+USES= iconv localbase python tar:bzip2
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^\(VERSION=\).*$$|\1${PORTVERSION}|' ${WRKSRC}/Makefile
+.if empty(ICONV_LIB)
+ @${REINPLACE_CMD} -e 's| or sys.platform.startswith("freebsd"):|:|' ${WRKSRC}/setup.py
+.endif
+
+pre-configure:
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' ${WRKSRC}/cupsconnection.c
+ @${REINPLACE_CMD} -e 's|#ifdef __SVR4|#ifdef __FreeBSD__|' ${WRKSRC}/cupsppd.c
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/cups.so
+
+.include <bsd.port.post.mk>
diff --git a/print/py-pycups/distinfo b/print/py-pycups/distinfo
new file mode 100644
index 000000000000..6b7832ee525e
--- /dev/null
+++ b/print/py-pycups/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pycups-1.9.73.tar.bz2) = c381be011889ca6f728598578c89c8ac9f7ab1e95b614474df9f2fa831ae5335
+SIZE (pycups-1.9.73.tar.bz2) = 52732
diff --git a/print/py-pycups/pkg-descr b/print/py-pycups/pkg-descr
new file mode 100644
index 000000000000..a40edfb59895
--- /dev/null
+++ b/print/py-pycups/pkg-descr
@@ -0,0 +1,4 @@
+CUPS bindings for Python
+
+WWW: https://pypi.python.org/pypi/pycups
+WWW: http://cyberelk.net/tim/software/pycups/