aboutsummaryrefslogtreecommitdiff
path: root/print/py-python-ly
diff options
context:
space:
mode:
authorMartin Neubauer <m.ne@gmx.net>2023-06-25 21:44:43 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2023-06-25 21:51:52 +0000
commite856d49bfdc6feec242092ae753e87765a86d2ea (patch)
treee82112f91727b1619b18222fc494d143a3cbc474 /print/py-python-ly
parent933da8110cd9e5a95c26c77f6059097ae138e71d (diff)
downloadports-e856d49bfdc6feec242092ae753e87765a86d2ea.tar.gz
ports-e856d49bfdc6feec242092ae753e87765a86d2ea.zip
print/py-python-ly: update to 0.9.8
Switch to pep517 build. Changes: https://github.com/frescobaldi/python-ly/compare/v0.9.6...v0.9.8 Changes: https://github.com/frescobaldi/python-ly/blob/v0.9.8/CHANGELOG.md Approved by: martin.dieringer (maintainer) PR: 271687
Diffstat (limited to 'print/py-python-ly')
-rw-r--r--print/py-python-ly/Makefile15
-rw-r--r--print/py-python-ly/distinfo6
-rw-r--r--print/py-python-ly/files/patch-pyproject.toml9
3 files changed, 22 insertions, 8 deletions
diff --git a/print/py-python-ly/Makefile b/print/py-python-ly/Makefile
index ae12a6012960..c3038de7a112 100644
--- a/print/py-python-ly/Makefile
+++ b/print/py-python-ly/Makefile
@@ -1,20 +1,25 @@
PORTNAME= python-ly
-PORTVERSION= 0.9.6
+PORTVERSION= 0.9.8
DISTVERSIONPREFIX= v
CATEGORIES= print python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= martin.dieringer@gmx.de
COMMENT= Python package to manipulate LilyPond files
-WWW= https://github.com/wbsoft/python-ly
+WWW= https://github.com/frescobaldi/python-ly
LICENSE= GPLv3
-USES= python:3.6+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
+
+USES= python:3.8+
USE_GITHUB= yes
-GH_ACCOUNT= wbsoft
+GH_ACCOUNT= frescobaldi
+
+USE_PYTHON= autoplist concurrent pep517
-USE_PYTHON= distutils autoplist
+NO_ARCH= yes
.include <bsd.port.mk>
diff --git a/print/py-python-ly/distinfo b/print/py-python-ly/distinfo
index 944e4fd678db..97ed224050be 100644
--- a/print/py-python-ly/distinfo
+++ b/print/py-python-ly/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1579687717
-SHA256 (wbsoft-python-ly-v0.9.6_GH0.tar.gz) = f1e7a2386c50460c2bf6e0876216f5101f3ee4aa956c6eb2348d901e005d1a07
-SIZE (wbsoft-python-ly-v0.9.6_GH0.tar.gz) = 239625
+TIMESTAMP = 1687123539
+SHA256 (frescobaldi-python-ly-v0.9.8_GH0.tar.gz) = bdd64fb947e8804cd7d1eedbd57552a0f1cd3411a7a063ad5ec39db78e8303ad
+SIZE (frescobaldi-python-ly-v0.9.8_GH0.tar.gz) = 250615
diff --git a/print/py-python-ly/files/patch-pyproject.toml b/print/py-python-ly/files/patch-pyproject.toml
new file mode 100644
index 000000000000..5a5df8d89eaf
--- /dev/null
+++ b/print/py-python-ly/files/patch-pyproject.toml
@@ -0,0 +1,9 @@
+--- pyproject.toml.orig 2023-06-16 13:33:13 UTC
++++ pyproject.toml
+@@ -1,5 +1,5 @@
+ [build-system]
+-requires = ["setuptools >= 64"]
++requires = ["setuptools >= 63"]
+ build-backend = "setuptools.build_meta"
+
+ [project]