aboutsummaryrefslogtreecommitdiff
path: root/print/py-reportlab
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2015-06-10 14:04:06 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2015-06-10 14:04:06 +0000
commit5fff0c00f68ae07785c3fe85c4c6042db08e066e (patch)
tree988b4c625059a672a0d2b2ac5da5076ec1d4eee9 /print/py-reportlab
parent56309c5cae5eed5f1e2c08ebf5bef93fc48eb927 (diff)
downloadports-5fff0c00f68ae07785c3fe85c4c6042db08e066e.tar.gz
ports-5fff0c00f68ae07785c3fe85c4c6042db08e066e.zip
print/py-reportlab: Fix PORTDOCS
- Strip Libraries - Fix patch files to reflect 'make makepatch' PR: 200602 Submitted by: amdmi3@FreeBSD.org
Notes
Notes: svn path=/head/; revision=389034
Diffstat (limited to 'print/py-reportlab')
-rw-r--r--print/py-reportlab/Makefile7
-rw-r--r--print/py-reportlab/files/patch-docs-genAll.py4
-rw-r--r--print/py-reportlab/files/patch-docs-userguide-genuserguide.py6
-rw-r--r--print/py-reportlab/files/patch-setup.py8
4 files changed, 13 insertions, 12 deletions
diff --git a/print/py-reportlab/Makefile b/print/py-reportlab/Makefile
index e59983017256..32f558035a02 100644
--- a/print/py-reportlab/Makefile
+++ b/print/py-reportlab/Makefile
@@ -3,7 +3,7 @@
PORTNAME= reportlab
PORTVERSION= 3.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= print python
MASTER_SITES= CHEESESHOP \
http://www.reportlab.com/ftp/
@@ -34,7 +34,7 @@ MAKE_ENV= PACKAGE_PATH="${REPORTLABDIR}"
REPORTLABDIR= ${PYTHONPREFIX_SITELIBDIR}/reportlab
DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
-DOCS= reportlab-userguide.pdf
+PORTDOCS= reportlab-userguide.pdf
OPTIONS_DEFINE= CJK FREETYPE DOCS
OPTIONS_DEFAULT= CJK FREETYPE
@@ -65,10 +65,11 @@ post-patch:
.endif
post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/reportlab/*/*.so
.if ${PORT_OPTIONS:MDOCS}
@cd ${WRKSRC}/docs && ${PYTHON_CMD} genAll.py
@${MKDIR} ${STAGEDIR}${DOCSDIR}
-.for i in ${DOCS}
+.for i in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/docs/${i} ${STAGEDIR}${DOCSDIR}
.endfor
.endif
diff --git a/print/py-reportlab/files/patch-docs-genAll.py b/print/py-reportlab/files/patch-docs-genAll.py
index 4dd9f403f40c..834777a879c8 100644
--- a/print/py-reportlab/files/patch-docs-genAll.py
+++ b/print/py-reportlab/files/patch-docs-genAll.py
@@ -1,5 +1,5 @@
---- docs/genAll.py.orig 2014-02-14 23:22:37.000000000 +0900
-+++ docs/genAll.py 2014-02-16 16:20:21.000000000 +0900
+--- docs/genAll.py.orig 2014-02-14 14:22:37 UTC
++++ docs/genAll.py
@@ -1,6 +1,7 @@
#!/bin/env python
-import os, sys, traceback
diff --git a/print/py-reportlab/files/patch-docs-userguide-genuserguide.py b/print/py-reportlab/files/patch-docs-userguide-genuserguide.py
index 8df153f3786f..9a19f6af7b8d 100644
--- a/print/py-reportlab/files/patch-docs-userguide-genuserguide.py
+++ b/print/py-reportlab/files/patch-docs-userguide-genuserguide.py
@@ -1,6 +1,6 @@
---- docs/userguide/genuserguide.py.orig 2014-02-14 23:22:37.000000000 +0900
-+++ docs/userguide/genuserguide.py 2014-02-16 16:15:05.000000000 +0900
-@@ -8,7 +8,8 @@
+--- docs/userguide/genuserguide.py.orig 2014-02-14 14:22:37 UTC
++++ docs/userguide/genuserguide.py
+@@ -8,7 +8,8 @@ This module contains the script for buil
"""
def run(pagesize=None, verbose=0, outDir=None):
diff --git a/print/py-reportlab/files/patch-setup.py b/print/py-reportlab/files/patch-setup.py
index fc7be0d9bf57..b2ec0ad02507 100644
--- a/print/py-reportlab/files/patch-setup.py
+++ b/print/py-reportlab/files/patch-setup.py
@@ -1,6 +1,6 @@
---- setup.py.orig 2014-02-14 23:22:37.000000000 +0900
-+++ setup.py 2014-02-16 00:48:02.000000000 +0900
-@@ -241,11 +241,7 @@
+--- setup.py.orig 2014-02-14 14:22:37 UTC
++++ setup.py
+@@ -241,11 +241,7 @@ reportlab_files= [
]
def get_fonts(PACKAGE_DIR, reportlab_files):
@@ -13,7 +13,7 @@
rl_dir = PACKAGE_DIR['reportlab']
if not [x for x in reportlab_files if not os.path.isfile(pjoin(rl_dir,x))]:
infoline("Standard T1 font curves already downloaded")
-@@ -254,12 +250,7 @@
+@@ -254,12 +250,7 @@ def get_fonts(PACKAGE_DIR, reportlab_fil
infoline('not downloading T1 font curve files')
return
try: