aboutsummaryrefslogtreecommitdiff
path: root/print/py-reportlab
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2020-02-24 11:36:15 +0000
committerKai Knoblich <kai@FreeBSD.org>2020-02-24 11:36:15 +0000
commit74174b26616baa21c285c0515b591e7d738c5c0f (patch)
tree1c10419849a595f8ebfa59836f2e676bb7ec3469 /print/py-reportlab
parent45b08b671d6459dc7e71950a89cac654920ec089 (diff)
downloadports-74174b26616baa21c285c0515b591e7d738c5c0f.tar.gz
ports-74174b26616baa21c285c0515b591e7d738c5c0f.zip
graphics/py-pillow: Update to 7.0.0
* Repo-Copy the Pillow 6.2.2 release to graphics/py-pillow6 to retain backwards compatibility for Python 2 consumers as the Pillow 7.0.0 release dropped the support for Python 2. * Apply conditional statements to use either Pillow 7.x or Pillow 6.x for consumers that can be built for Python 2 or newer. * Exceptions are ports that can be built only for either Python 2 or Python 3. For the first case, consumers are just assigned to the repo-copied graphics/py-pillow6. * Also remove Pillow from BUILD_DEPENDS of math/py-PyWavelets as it is not listed in setup.py as a build dependency [1] and relax the version requirements of Pillow for www/py-wagtail. Release Notes: * https://pillow.readthedocs.io/en/latest/releasenotes/index.html Backward Incompatible Changes (7.0.0): * https://pillow.readthedocs.io/en/latest/releasenotes/7.0.0.html#backwards-incompatible-changes Detailed Changelog: * https://github.com/python-pillow/Pillow/blob/7.0.0/CHANGES.rst PR: 243665 Submitted by: sunpoet (patch for 7.0.0 and repo-copied version) Reviewed by: koobs [1], sunpoet Approved by: koobs (maintainer) Differential Revision: https://reviews.freebsd.org/D23713
Notes
Notes: svn path=/head/; revision=526962
Diffstat (limited to 'print/py-reportlab')
-rw-r--r--print/py-reportlab/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/print/py-reportlab/Makefile b/print/py-reportlab/Makefile
index b34431ad7a65..4960ef48b28b 100644
--- a/print/py-reportlab/Makefile
+++ b/print/py-reportlab/Makefile
@@ -3,6 +3,7 @@
PORTNAME= reportlab
PORTVERSION= 3.5.21
+PORTREVISION= 1
CATEGORIES= print python
MASTER_SITES= CHEESESHOP \
https://www.reportlab.com/ftp/
@@ -16,8 +17,6 @@ COMMENT= Library to create PDF documents using the Python language
LICENSE= BSD3CLAUSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
-
USES= python
USE_PYTHON= distutils autoplist
@@ -42,7 +41,13 @@ CJK_DESC= Adobe CMaps
CJK_RUN_DEPENDS= ${LOCALBASE}/share/fonts/adobe-cmaps/ac15/cid2code.txt:print/adobe-cmaps
FREETYPE_LIB_DEPENDS= libfreetype.so:print/freetype2
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3500
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow6>0:graphics/py-pillow6@${PY_FLAVOR}
+.else
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
+.endif
post-patch:
@${REINPLACE_CMD} -e 's|%%DISTDIR%%|${DISTDIR}|' \
@@ -66,4 +71,4 @@ post-install-DOCS-on:
${INSTALL_DATA} ${WRKSRC}/docs/${i} ${STAGEDIR}${DOCSDIR}
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>