aboutsummaryrefslogtreecommitdiff
path: root/print/py-trml2pdf
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-03-03 02:40:53 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-03-03 02:40:53 +0000
commit44b68a3a4cdb6d56d8c70dfec433af2682d61a66 (patch)
treed5a4f2df0009398fd590890fa3e3e2827d77cd32 /print/py-trml2pdf
parentff3f93364e318b1f79de11adf6f4d90611317f88 (diff)
downloadports-44b68a3a4cdb6d56d8c70dfec433af2682d61a66.tar.gz
ports-44b68a3a4cdb6d56d8c70dfec433af2682d61a66.zip
Notes
Diffstat (limited to 'print/py-trml2pdf')
-rw-r--r--print/py-trml2pdf/Makefile19
1 files changed, 7 insertions, 12 deletions
diff --git a/print/py-trml2pdf/Makefile b/print/py-trml2pdf/Makefile
index e84804126141..59e663ec980f 100644
--- a/print/py-trml2pdf/Makefile
+++ b/print/py-trml2pdf/Makefile
@@ -22,20 +22,15 @@ USE_PYTHON= yes
DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
-NO_STAGE= yes
do-install:
- @${MKDIR} ${PYTHON_SITELIBDIR}/trml2pdf
- @${INSTALL_SCRIPT} ${WRKSRC}/trml2pdf/* ${PYTHON_SITELIBDIR}/trml2pdf
+ @${MKDIR} ${STAGEDIR}${PYTHON_SITELIBDIR}/trml2pdf
+ @${INSTALL_SCRIPT} ${WRKSRC}/trml2pdf/* ${STAGEDIR}${PYTHON_SITELIBDIR}/trml2pdf
post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}
-.endif
-
-.if !defined(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}
- ${CP} -R ${WRKSRC}/rmls/ ${EXAMPLESDIR}/rmls
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.txt ${STAGEDIR}${DOCSDIR}
+
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/rmls/ ${STAGEDIR}${EXAMPLESDIR}/rmls
.include <bsd.port.mk>