aboutsummaryrefslogtreecommitdiff
path: root/print/py-uharfbuzz
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 14:44:57 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 15:07:58 +0000
commit76003b0a2b0057d8231a9b70b7e67d5ffc72c92e (patch)
tree9e0f694c506007be515582d0933834c9cdf54460 /print/py-uharfbuzz
parent02cd09dd0efb9586938b59ea49d26e6c5ec8d43f (diff)
downloadports-76003b0a2b0057d8231a9b70b7e67d5ffc72c92e.tar.gz
ports-76003b0a2b0057d8231a9b70b7e67d5ffc72c92e.zip
print/py-uharfbuzz: Update to 0.39.0
Diffstat (limited to 'print/py-uharfbuzz')
-rw-r--r--print/py-uharfbuzz/Makefile5
-rw-r--r--print/py-uharfbuzz/distinfo6
-rw-r--r--print/py-uharfbuzz/files/patch-setup.py20
3 files changed, 15 insertions, 16 deletions
diff --git a/print/py-uharfbuzz/Makefile b/print/py-uharfbuzz/Makefile
index 55ffbf88c5f2..2a568446d284 100644
--- a/print/py-uharfbuzz/Makefile
+++ b/print/py-uharfbuzz/Makefile
@@ -1,5 +1,5 @@
PORTNAME= uharfbuzz
-PORTVERSION= 0.37.3
+PORTVERSION= 0.39.0
CATEGORIES= print python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,7 +11,7 @@ WWW= https://github.com/harfbuzz/uharfbuzz
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= harfbuzz>=8.2.0:print/harfbuzz \
+BUILD_DEPENDS= harfbuzz>=8.3.0:print/harfbuzz \
${PYTHON_PKGNAMEPREFIX}setuptools>=36.4:devel/py-setuptools@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}setuptools_scm>=2.1:devel/py-setuptools_scm@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
@@ -22,7 +22,6 @@ USE_PYTHON= autoplist concurrent cython pep517
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/setup.py ${WRKSRC}/src/uharfbuzz/_harfbuzz.cpp
- @${RM} ${WRKSRC}/src/uharfbuzz/_harfbuzz.cpp
# Clean up bundled libraries
@${RM} -r ${WRKSRC}/harfbuzz/
diff --git a/print/py-uharfbuzz/distinfo b/print/py-uharfbuzz/distinfo
index a944114cb278..58971289b50c 100644
--- a/print/py-uharfbuzz/distinfo
+++ b/print/py-uharfbuzz/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1695143357
-SHA256 (uharfbuzz-0.37.3.zip) = f2b213386c1e1588c2c9baea436a85c4609902001cd21bc3065244b744223a6d
-SIZE (uharfbuzz-0.37.3.zip) = 1684765
+TIMESTAMP = 1708449432
+SHA256 (uharfbuzz-0.39.0.zip) = 06001ab50339003b04b194fd3804e3292c023b3f1d5b376f7e128891cc584491
+SIZE (uharfbuzz-0.39.0.zip) = 1842110
diff --git a/print/py-uharfbuzz/files/patch-setup.py b/print/py-uharfbuzz/files/patch-setup.py
index 94dbe247e8af..61d88af9f849 100644
--- a/print/py-uharfbuzz/files/patch-setup.py
+++ b/print/py-uharfbuzz/files/patch-setup.py
@@ -1,16 +1,16 @@
--- setup.py.orig 2023-03-13 09:18:30 UTC
+++ setup.py
-@@ -39,12 +39,8 @@ if platform.system() == 'Darwin':
+@@ -39,12 +39,8 @@ if platform.system() == "Darwin":
extension = Extension(
- 'uharfbuzz._harfbuzz',
+ "uharfbuzz._harfbuzz",
define_macros=define_macros,
-- include_dirs=['harfbuzz/src'],
-+ include_dirs=['%%LOCALBASE%%/include/harfbuzz'],
+- include_dirs=["harfbuzz/src"],
++ include_dirs=["%%LOCALBASE%%/include/harfbuzz"],
sources=[
-- 'harfbuzz/src/harfbuzz-subset.cc',
-- 'harfbuzz/src/hb-coretext.cc',
-- 'harfbuzz/src/hb-directwrite.cc',
-- 'harfbuzz/src/hb-uniscribe.cc',
- 'src/uharfbuzz/_harfbuzz.pyx',
+- "harfbuzz/src/harfbuzz-subset.cc",
+- "harfbuzz/src/hb-coretext.cc",
+- "harfbuzz/src/hb-directwrite.cc",
+- "harfbuzz/src/hb-uniscribe.cc",
+ "src/uharfbuzz/_harfbuzz.pyx",
],
- language='c++',
+ language="c++",