aboutsummaryrefslogtreecommitdiff
path: root/print/py-uharfbuzz
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-04-05 17:18:40 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-04-05 17:30:48 +0000
commitc95d3cb2995dc181e30d8852d6582e4c68d4c298 (patch)
tree101ccf97ae2c56240ebee0d3ba67ea83a934ad9c /print/py-uharfbuzz
parent863260d262919f407c6142f8e803ad30223633cb (diff)
downloadports-c95d3cb2995dc181e30d8852d6582e4c68d4c298.tar.gz
ports-c95d3cb2995dc181e30d8852d6582e4c68d4c298.zip
print/py-uharfbuzz: Update to 0.35.0
Diffstat (limited to 'print/py-uharfbuzz')
-rw-r--r--print/py-uharfbuzz/Makefile4
-rw-r--r--print/py-uharfbuzz/distinfo6
-rw-r--r--print/py-uharfbuzz/files/patch-setup.py12
-rw-r--r--print/py-uharfbuzz/files/patch-src-uharfbuzz-_harfbuzz.cpp13
4 files changed, 18 insertions, 17 deletions
diff --git a/print/py-uharfbuzz/Makefile b/print/py-uharfbuzz/Makefile
index a02c2ca6952c..97035be7a541 100644
--- a/print/py-uharfbuzz/Makefile
+++ b/print/py-uharfbuzz/Makefile
@@ -1,5 +1,5 @@
PORTNAME= uharfbuzz
-PORTVERSION= 0.33.0
+PORTVERSION= 0.35.0
CATEGORIES= print python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,7 +11,7 @@ WWW= https://github.com/harfbuzz/uharfbuzz
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= harfbuzz>=6.0.0:print/harfbuzz \
+BUILD_DEPENDS= harfbuzz>=7.1.0:print/harfbuzz \
${PYTHON_PKGNAMEPREFIX}setuptools_scm>=0:devel/py-setuptools_scm@${PY_FLAVOR}
LIB_DEPENDS= libharfbuzz.so:print/harfbuzz
diff --git a/print/py-uharfbuzz/distinfo b/print/py-uharfbuzz/distinfo
index 9b02bfaefa51..55073ea3eab6 100644
--- a/print/py-uharfbuzz/distinfo
+++ b/print/py-uharfbuzz/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1671304908
-SHA256 (uharfbuzz-0.33.0.zip) = 93c88d074df996a483f80d33144c9acad8657178518380b82ec7979988b7239c
-SIZE (uharfbuzz-0.33.0.zip) = 1364513
+TIMESTAMP = 1679498796
+SHA256 (uharfbuzz-0.35.0.zip) = 9c5c1cc77cd258ed014ceacd117fdbc7c5b13c00ad1c6dec811e6ce5b5cc5bc5
+SIZE (uharfbuzz-0.35.0.zip) = 1531904
diff --git a/print/py-uharfbuzz/files/patch-setup.py b/print/py-uharfbuzz/files/patch-setup.py
index 8f4eaa12ef40..94dbe247e8af 100644
--- a/print/py-uharfbuzz/files/patch-setup.py
+++ b/print/py-uharfbuzz/files/patch-setup.py
@@ -1,16 +1,16 @@
---- setup.py.orig 2022-07-31 12:39:52 UTC
+--- setup.py.orig 2023-03-13 09:18:30 UTC
+++ setup.py
-@@ -39,12 +39,9 @@ extension = Extension(
+@@ -39,12 +39,8 @@ if platform.system() == 'Darwin':
extension = Extension(
'uharfbuzz._harfbuzz',
define_macros=define_macros,
- include_dirs=['harfbuzz/src'],
+ include_dirs=['%%LOCALBASE%%/include/harfbuzz'],
sources=[
+- 'harfbuzz/src/harfbuzz-subset.cc',
+- 'harfbuzz/src/hb-coretext.cc',
+- 'harfbuzz/src/hb-directwrite.cc',
+- 'harfbuzz/src/hb-uniscribe.cc',
'src/uharfbuzz/_harfbuzz.pyx',
-- 'harfbuzz/src/harfbuzz.cc',
-- 'harfbuzz/src/hb-subset-repacker.cc',
-- 'harfbuzz/src/graph/gsubgpos-context.cc',
- 'src/uharfbuzz/_draw_test_funcs.cc',
],
language='c++',
diff --git a/print/py-uharfbuzz/files/patch-src-uharfbuzz-_harfbuzz.cpp b/print/py-uharfbuzz/files/patch-src-uharfbuzz-_harfbuzz.cpp
index 133d69461964..e68a963bd408 100644
--- a/print/py-uharfbuzz/files/patch-src-uharfbuzz-_harfbuzz.cpp
+++ b/print/py-uharfbuzz/files/patch-src-uharfbuzz-_harfbuzz.cpp
@@ -1,6 +1,6 @@
---- src/uharfbuzz/_harfbuzz.cpp.orig 2022-07-31 07:40:22 UTC
+--- src/uharfbuzz/_harfbuzz.cpp.orig 2023-03-13 09:19:32 UTC
+++ src/uharfbuzz/_harfbuzz.cpp
-@@ -30,15 +30,12 @@
+@@ -30,16 +30,12 @@
"-std=c++11"
],
"include_dirs": [
@@ -11,9 +11,10 @@
"name": "uharfbuzz._harfbuzz",
"sources": [
"src/uharfbuzz/_harfbuzz.pyx",
-- "harfbuzz/src/harfbuzz.cc",
-- "harfbuzz/src/hb-subset-repacker.cc",
-- "harfbuzz/src/graph/gsubgpos-context.cc",
- "src/uharfbuzz/_draw_test_funcs.cc"
+- "harfbuzz/src/harfbuzz-subset.cc",
+- "harfbuzz/src/hb-coretext.cc",
+- "harfbuzz/src/hb-directwrite.cc",
+- "harfbuzz/src/hb-uniscribe.cc"
]
},
+ "module_name": "uharfbuzz._harfbuzz"