aboutsummaryrefslogtreecommitdiff
path: root/print/qpdfview
diff options
context:
space:
mode:
authorLorenzo Salvadore <salvadore@FreeBSD.org>2022-07-23 10:17:39 +0000
committerLorenzo Salvadore <salvadore@FreeBSD.org>2022-07-23 10:21:11 +0000
commitb7d2ad1c2d961aea4f5a66b39bb916043c5f0ae5 (patch)
treeda07f31df599cebb41500a111a0d2c8a79b7fedc /print/qpdfview
parent735661161b351944dc5a588d026cbdddf7000c14 (diff)
downloadports-b7d2ad1c2d961aea4f5a66b39bb916043c5f0ae5.tar.gz
ports-b7d2ad1c2d961aea4f5a66b39bb916043c5f0ae5.zip
Diffstat (limited to 'print/qpdfview')
-rw-r--r--print/qpdfview/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/print/qpdfview/Makefile b/print/qpdfview/Makefile
index 62025e912932..0ce6e119e2b7 100644
--- a/print/qpdfview/Makefile
+++ b/print/qpdfview/Makefile
@@ -5,7 +5,7 @@ CATEGORIES= print
MASTER_SITES= https://launchpadlibrarian.net/294276875/ \
https://launchpad.net/${PORTNAME}/trunk/${DISTVERSION}/+download/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= salvadore@FreeBSD.org
COMMENT= Tabbed DjVu/PDF/PS document viewer
LICENSE= GPLv2+
@@ -14,23 +14,24 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpoppler-qt5.so:graphics/poppler-qt5
USES= compiler:c++11-lang desktop-file-utils gl pkgconfig qmake qt:5
-USE_LDCONFIG= yes
-USE_QT= buildtools_build concurrent core dbus gui imageformats linguisttools printsupport sql sql-sqlite3 svg widgets xml
USE_GL= gl
+USE_LDCONFIG= yes
+USE_QT= concurrent core dbus gui imageformats linguisttools \
+ printsupport sql sql-sqlite3 svg widgets xml buildtools_build
QMAKE_SOURCE_PATH= ${PORTNAME}.pro
DATADIR= ${PREFIX}/share/${PORTNAME}
-OPTIONS_DEFINE= CUPS DJVU PS
+OPTIONS_DEFINE= CUPS DJVU PS
OPTIONS_DEFAULT= CUPS DJVU PS
-OPTIONS_SUB= yes
+OPTIONS_SUB= yes
-CUPS_QMAKE_OFF= "CONFIG+=without_cups"
CUPS_LIB_DEPENDS= libcups.so:print/cups
+CUPS_QMAKE_OFF= "CONFIG+=without_cups"
DJVU_LIB_DEPENDS= libdjvulibre.so:graphics/djvulibre
-DJVU_QMAKE_OFF= "CONFIG+=without_djvu"
+DJVU_QMAKE_OFF= "CONFIG+=without_djvu"
PS_LIB_DEPENDS= libspectre.so:print/libspectre
PS_QMAKE_OFF= "CONFIG+=without_ps"