aboutsummaryrefslogtreecommitdiff
path: root/print/rlpr
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2012-04-02 16:01:25 +0000
committerMikhail Teterin <mi@FreeBSD.org>2012-04-02 16:01:25 +0000
commitb7542224fb7f10e4f55e8c088d17d305610d0aae (patch)
tree1b08d416e81d7fae9213df863974fcdfb119ce0a /print/rlpr
parent195098580dce96f72bf39ecb0ab0fc0d51dc1bdc (diff)
downloadports-b7542224fb7f10e4f55e8c088d17d305610d0aae.tar.gz
ports-b7542224fb7f10e4f55e8c088d17d305610d0aae.zip
Add a patch to allow specifying remote printer by IP-address, rather
than only by hostname. Bump PORTREVISION. PR: ports/166583 Submitted by: Norbert Koch While here: * replace the (short) pkg-plist with PLIST_FILES variable; * relax permissions on the client binaries from 4511 to 4555 -- otherwise tar refuses to package them, when running as non-root; * declare license (GPLv2); * link to description page, that works (author's site is down); * add some working mirrors (author's site is down). Feature safe: yes
Notes
Notes: svn path=/head/; revision=294128
Diffstat (limited to 'print/rlpr')
-rw-r--r--print/rlpr/Makefile11
-rw-r--r--print/rlpr/files/patch-ip-addr16
-rw-r--r--print/rlpr/pkg-descr1
-rw-r--r--print/rlpr/pkg-plist4
4 files changed, 25 insertions, 7 deletions
diff --git a/print/rlpr/Makefile b/print/rlpr/Makefile
index 16c97e78260b..f539290fcd21 100644
--- a/print/rlpr/Makefile
+++ b/print/rlpr/Makefile
@@ -7,13 +7,17 @@
PORTNAME= rlpr
PORTVERSION= 2.06
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= print net
-MASTER_SITES= http://truffula.com/rlpr/
+MASTER_SITES= http://fossies.org/unix/misc/old/ \
+ http://linuxfocus.org/~guido/ \
+ http://truffula.com/rlpr/
MAINTAINER= mi@aldan.algebra.com
COMMENT= Send print jobs to lpd servers anywhere on a network
+LICENSE= GPLv2
+
GNU_CONFIGURE= yes
# rlpr supports gettext/libintl, but does not currently come with ANY
# translation .po files. When this changes, it would make sense to
@@ -21,6 +25,7 @@ GNU_CONFIGURE= yes
#USE_GETTEXT= yes
#CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include" LDFLAGS="-L${PREFIX}/lib -lintl"
CONFIGURE_ARGS= --disable-nls --without-catgets
+PLIST_FILES= bin/rlpr bin/rlpq bin/rlprm bin/rlprd
post-patch:
# Replacing references to /etc/rlprrc to ${PREFIX}/etc/rlprrc
@@ -31,7 +36,7 @@ post-patch:
post-install:
# Making the installed binaries suid,\
for the remote lpds to talk to them"
- ${CHMOD} 4511 ${PREFIX}/bin/rlpq ${PREFIX}/bin/rlpr ${PREFIX}/bin/rlprm
+ ${CHMOD} 4555 ${PREFIX}/bin/rlpq ${PREFIX}/bin/rlpr ${PREFIX}/bin/rlprm
MAN1= rlpr.1 rlpq.1 rlprm.1
MAN5= rlprrc.5
diff --git a/print/rlpr/files/patch-ip-addr b/print/rlpr/files/patch-ip-addr
new file mode 100644
index 000000000000..9388e79bd272
--- /dev/null
+++ b/print/rlpr/files/patch-ip-addr
@@ -0,0 +1,16 @@
+Support contacting IP-addresses, rather than only the hostnames.
+
+PR: http://www.freebsd.org/cgi/query-pr.cgi?pr=166583
+Submited by: Norbert Koch
+--- src/util.c Thu Oct 28 08:40:13 1999
++++ src/util.c Mon Apr 2 09:19:43 2012
+@@ -73,6 +73,9 @@
+ sin->sin_port = port_hbo ? htons(port_hbo) : 0;
+
+ if (host != 0) {
++ if (inet_aton (host, &sin->sin_addr) == 1) {
++ return 1;
++ }
+
+ if ((hp = gethostbyname(host)) == 0) {
+ msg(R_ERROR, 0, "gethostbyname(%s): %s", host, h_strerror());
diff --git a/print/rlpr/pkg-descr b/print/rlpr/pkg-descr
index a1054cd68bc6..39584ac04c3a 100644
--- a/print/rlpr/pkg-descr
+++ b/print/rlpr/pkg-descr
@@ -6,4 +6,5 @@ Gettext (-lintl) is not used by this port because it adds bloat
without functionality -- there are no language files supplied with this
package yet. May be in future versions.
+WWW: http://freecode.com/projects/rlpr
WWW: http://truffula.com/rlpr/
diff --git a/print/rlpr/pkg-plist b/print/rlpr/pkg-plist
deleted file mode 100644
index cc528074d499..000000000000
--- a/print/rlpr/pkg-plist
+++ /dev/null
@@ -1,4 +0,0 @@
-bin/rlpr
-bin/rlpq
-bin/rlprm
-bin/rlprd