aboutsummaryrefslogtreecommitdiff
path: root/print/scribus-devel
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2019-11-01 21:51:36 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2019-11-01 21:51:36 +0000
commit3ca3ffe4551bee0f510c9d301bf4f312959dcf25 (patch)
treece13218697645e8981b36e7589f64b42e3049ce5 /print/scribus-devel
parent19c0b79bf443eb706820ac162b35b88fcf9088fd (diff)
downloadports-3ca3ffe4551bee0f510c9d301bf4f312959dcf25.tar.gz
ports-3ca3ffe4551bee0f510c9d301bf4f312959dcf25.zip
graphics/poppler: update to 0.82.0
Release 0.82.0: core: * Fix not being able to open some files. Issue #832 * Fix crashes in malformed files * Fix memory leak on broken files * Minor performance improvements * Minor code improvements glib: * Add poppler_document_new_from_bytes * PopplerAttachment: Silence deprecation warnings for ctime/mtime build system: * pdf-inspector: Support builddir != srcdir * Install Cairo* headers if Cairo has been found Thanks to adridg@ for fixing all the fallout. Exp-run by: antoine PR: 241532 Approved by: gnome (kwm, implicit)
Notes
Notes: svn path=/head/; revision=516270
Diffstat (limited to 'print/scribus-devel')
-rw-r--r--print/scribus-devel/Makefile2
-rw-r--r--print/scribus-devel/files/patch-scribus_plugins_import_pdf_slaoutput.cpp29
-rw-r--r--print/scribus-devel/files/patch-scribus_plugins_import_pdf_slaoutput.h22
3 files changed, 52 insertions, 1 deletions
diff --git a/print/scribus-devel/Makefile b/print/scribus-devel/Makefile
index 32f22d2c33a5..454fbf8d36f5 100644
--- a/print/scribus-devel/Makefile
+++ b/print/scribus-devel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= scribus
PORTVERSION= 1.5.5
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= print editors
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}${PKGNAMESUFFIX}/${PORTVERSION}/ \
http://www.scribus.net/downloads/${PORTVERSION}/
diff --git a/print/scribus-devel/files/patch-scribus_plugins_import_pdf_slaoutput.cpp b/print/scribus-devel/files/patch-scribus_plugins_import_pdf_slaoutput.cpp
new file mode 100644
index 000000000000..8f4f7d06a446
--- /dev/null
+++ b/print/scribus-devel/files/patch-scribus_plugins_import_pdf_slaoutput.cpp
@@ -0,0 +1,29 @@
+--- scribus/plugins/import/pdf/slaoutput.cpp.orig 2019-10-27 16:14:24 UTC
++++ scribus/plugins/import/pdf/slaoutput.cpp
+@@ -2784,7 +2784,7 @@ void SlaOutputDev::drawMaskedImage(GfxState *state, Ob
+ delete[] mbuffer;
+ }
+
+-void SlaOutputDev::drawImage(GfxState *state, Object *ref, Stream *str, int width, int height, GfxImageColorMap *colorMap, GBool interpolate, int *maskColors, GBool inlineImg)
++void SlaOutputDev::drawImage(GfxState *state, Object *ref, Stream *str, int width, int height, GfxImageColorMap *colorMap, GBool interpolate, const int *maskColors, GBool inlineImg)
+ {
+ ImageStream * imgStr = new ImageStream(str, width, colorMap->getNumPixelComps(), colorMap->getBits());
+ // qDebug() << "Image Components" << colorMap->getNumPixelComps() << "Mask" << maskColors;
+@@ -3365,7 +3365,7 @@ err1:
+ fontsrc->unref();
+ }
+
+-void SlaOutputDev::drawChar(GfxState *state, double x, double y, double dx, double dy, double originX, double originY, CharCode code, int nBytes, Unicode *u, int uLen)
++void SlaOutputDev::drawChar(GfxState *state, double x, double y, double dx, double dy, double originX, double originY, CharCode code, int nBytes, const Unicode *u, int uLen)
+ {
+ double x1, y1, x2, y2;
+ int render;
+@@ -3452,7 +3452,7 @@ void SlaOutputDev::drawChar(GfxState *state, double x,
+ }
+ }
+
+-GBool SlaOutputDev::beginType3Char(GfxState *state, double x, double y, double dx, double dy, CharCode code, Unicode *u, int uLen)
++GBool SlaOutputDev::beginType3Char(GfxState *state, double x, double y, double dx, double dy, CharCode code, const Unicode *u, int uLen)
+ {
+ // qDebug() << "beginType3Char";
+ GfxFont *gfxFont;
diff --git a/print/scribus-devel/files/patch-scribus_plugins_import_pdf_slaoutput.h b/print/scribus-devel/files/patch-scribus_plugins_import_pdf_slaoutput.h
new file mode 100644
index 000000000000..46128ebe8f14
--- /dev/null
+++ b/print/scribus-devel/files/patch-scribus_plugins_import_pdf_slaoutput.h
@@ -0,0 +1,22 @@
+--- scribus/plugins/import/pdf/slaoutput.h.orig 2019-10-27 16:12:47 UTC
++++ scribus/plugins/import/pdf/slaoutput.h
+@@ -229,7 +229,7 @@ class SlaOutputDev : public OutputDev (public)
+
+ //----- image drawing
+ void drawImageMask(GfxState *state, Object *ref, Stream *str, int width, int height, GBool invert, GBool interpolate, GBool inlineImg) override;
+- void drawImage(GfxState *state, Object *ref, Stream *str, int width, int height, GfxImageColorMap *colorMap, GBool interpolate, int *maskColors, GBool inlineImg) override;
++ void drawImage(GfxState *state, Object *ref, Stream *str, int width, int height, GfxImageColorMap *colorMap, GBool interpolate, const int *maskColors, GBool inlineImg) override;
+ void drawSoftMaskedImage(GfxState *state, Object *ref, Stream *str,
+ int width, int height,
+ GfxImageColorMap *colorMap,
+@@ -261,8 +261,8 @@ class SlaOutputDev : public OutputDev (public)
+ //----- text drawing
+ void beginTextObject(GfxState *state) override;
+ void endTextObject(GfxState *state) override;
+- void drawChar(GfxState *state, double /*x*/, double /*y*/, double /*dx*/, double /*dy*/, double /*originX*/, double /*originY*/, CharCode /*code*/, int /*nBytes*/, Unicode * /*u*/, int /*uLen*/) override;
+- GBool beginType3Char(GfxState * /*state*/, double /*x*/, double /*y*/, double /*dx*/, double /*dy*/, CharCode /*code*/, Unicode * /*u*/, int /*uLen*/) override;
++ void drawChar(GfxState *state, double /*x*/, double /*y*/, double /*dx*/, double /*dy*/, double /*originX*/, double /*originY*/, CharCode /*code*/, int /*nBytes*/, const Unicode * /*u*/, int /*uLen*/) override;
++ GBool beginType3Char(GfxState * /*state*/, double /*x*/, double /*y*/, double /*dx*/, double /*dy*/, CharCode /*code*/, const Unicode * /*u*/, int /*uLen*/) override;
+ void endType3Char(GfxState * /*state*/) override;
+ void type3D0(GfxState * /*state*/, double /*wx*/, double /*wy*/) override;
+ void type3D1(GfxState * /*state*/, double /*wx*/, double /*wy*/, double /*llx*/, double /*lly*/, double /*urx*/, double /*ury*/) override;