aboutsummaryrefslogtreecommitdiff
path: root/print/scribus-devel
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-09-14 13:29:22 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-09-14 13:29:22 +0000
commitbeeccba42f0ff3748c145c2abbe204e50fef6bd9 (patch)
tree49f152aeb46d841878b751b992cad9b42cead69b /print/scribus-devel
parent15f434f78511552e60ee46cb7ff1e8e47bb6f61b (diff)
downloadports-beeccba42f0ff3748c145c2abbe204e50fef6bd9.tar.gz
ports-beeccba42f0ff3748c145c2abbe204e50fef6bd9.zip
print/scribus-devel: remove python2 depedency
PR: 249307 Submitted by: dinoex
Notes
Notes: svn path=/head/; revision=548607
Diffstat (limited to 'print/scribus-devel')
-rw-r--r--print/scribus-devel/Makefile10
-rw-r--r--print/scribus-devel/files/patch-CMakeLists.txt20
-rw-r--r--print/scribus-devel/files/patch-scribus_plugins_CMakeLists.txt13
-rw-r--r--print/scribus-devel/pkg-plist29
4 files changed, 37 insertions, 35 deletions
diff --git a/print/scribus-devel/Makefile b/print/scribus-devel/Makefile
index 4d0419d339a9..7857096f38cb 100644
--- a/print/scribus-devel/Makefile
+++ b/print/scribus-devel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= scribus
PORTVERSION= 1.5.5
-PORTREVISION= 17
+PORTREVISION= 18
CATEGORIES= print editors
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}${PKGNAMESUFFIX}/${PORTVERSION}/ \
http://www.scribus.net/downloads/${PORTVERSION}/
@@ -15,9 +15,6 @@ COMMENT= Comprehensive desktop publishing program (development version)
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-DEPRECATED= Uses deprecated version of python
-EXPIRATION_DATE= 2020-09-15
-
LIB_DEPENDS= liblcms2.so:graphics/lcms2 \
libboost_thread.so:devel/boost-libs \
libhunspell-1.7.so:textproc/hunspell \
@@ -40,14 +37,15 @@ LIB_DEPENDS= liblcms2.so:graphics/lcms2 \
libicuuc.so:devel/icu
USES= cmake compiler:gcc-c++11-lib desktop-file-utils dos2unix gnome \
- jpeg pkgconfig python:2.7 qt:5 shared-mime-info ssl tar:xz
+ jpeg pkgconfig qt:5 shared-mime-info ssl tar:xz
USE_QT= buildtools_build core declarative gui linguisttools_build \
network opengl printsupport qmake_build widgets xml
USE_GNOME= libxml2
INSTALLS_ICONS= yes
USE_LDCONFIG= yes
-CMAKE_ARGS+= -DWANT_HUNSPELL=YES -Wno-ferror-limit -DCMAKE_COLOR_MAKEFILE:BOOL=ON
+CMAKE_ARGS+= -DWANT_HUNSPELL=YES -DWANT_SCRIPTER2=YES \
+ -Wno-ferror-limit -DCMAKE_COLOR_MAKEFILE:BOOL=ON
OPTIONS_DEFINE= DOCS
diff --git a/print/scribus-devel/files/patch-CMakeLists.txt b/print/scribus-devel/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..141626cbe668
--- /dev/null
+++ b/print/scribus-devel/files/patch-CMakeLists.txt
@@ -0,0 +1,20 @@
+--- CMakeLists.txt.orig 2020-09-13 18:32:23 UTC
++++ CMakeLists.txt
+@@ -845,17 +845,6 @@ else()
+ endif()
+ #<< JPEG, TIFF
+
+-#<< PYTHON
+-#set(PythonLibs_FIND_VERSION 2)
+-find_package(PythonInterp 2)
+-find_package(PythonLibs 2 REQUIRED)
+-if (PYTHON_LIBRARY)
+- message("Python Library Found OK")
+- set(HAVE_PYTHON ON)
+- set(COMPILE_PYTHON ON)
+-endif()
+-#>> PYTHON
+-
+ #<< FreeType2
+ find_package(Freetype REQUIRED)
+ if (FREETYPE_FOUND)
diff --git a/print/scribus-devel/files/patch-scribus_plugins_CMakeLists.txt b/print/scribus-devel/files/patch-scribus_plugins_CMakeLists.txt
new file mode 100644
index 000000000000..a3c9691febe0
--- /dev/null
+++ b/print/scribus-devel/files/patch-scribus_plugins_CMakeLists.txt
@@ -0,0 +1,13 @@
+--- scribus/plugins/CMakeLists.txt.orig 2020-09-13 18:32:25 UTC
++++ scribus/plugins/CMakeLists.txt
+@@ -15,8 +15,8 @@ if(NOT WANT_SCRIPTER2)
+ endif()
+ else()
+ #scripter2
+- message(STATUS "Building with Scripter 2")
+- add_subdirectory(scripter)
++# message(STATUS "Building with Scripter 2")
++# add_subdirectory(scripter)
+ endif()
+ add_subdirectory(short-words)
+ add_subdirectory(tools)
diff --git a/print/scribus-devel/pkg-plist b/print/scribus-devel/pkg-plist
index a5656d8a6c3c..399d2b60daaf 100644
--- a/print/scribus-devel/pkg-plist
+++ b/print/scribus-devel/pkg-plist
@@ -54,7 +54,6 @@ lib/scribus/plugins/libscribus13format.so
lib/scribus/plugins/libscribus150format.so
lib/scribus/plugins/libscribusexportpixmap.so
lib/scribus/plugins/libscribusshortwords.so
-lib/scribus/plugins/libscriptplugin.so
lib/scribus/plugins/libshapeplugin.so
lib/scribus/plugins/libsmoothpath.so
lib/scribus/plugins/libsubdivide.so
@@ -2702,33 +2701,6 @@ share/pixmaps/scribus.png
%%DATADIR%%/profiles/sRGB.icm
%%DATADIR%%/profiles/srgb.license
%%DATADIR%%/qml/qtq_test1.qml
-%%DATADIR%%/samples/3columnA4.py
-%%DATADIR%%/samples/3columnUSLTR.py
-%%DATADIR%%/samples/Calender.py
-%%DATADIR%%/samples/ExtractText.py
-%%DATADIR%%/samples/Sample1.py
-%%DATADIR%%/samples/boilerplate.py
-%%DATADIR%%/samples/golden-mean.py
-%%DATADIR%%/samples/legende.py
-%%DATADIR%%/samples/moins_10_pourcent_group.py
-%%DATADIR%%/samples/plus_10_pourcent_group.py
-%%DATADIR%%/samples/pochette_cd.py
-%%DATADIR%%/samples/quote.py
-%%DATADIR%%/samples/sample_db_usage.py
-%%DATADIR%%/samples/trait_de_coupe.py
-%%DATADIR%%/samples/wordcount.py
-%%DATADIR%%/scripts/Autoquote.py
-%%DATADIR%%/scripts/Autoquote2.py
-%%DATADIR%%/scripts/CalendarWizard.py
-%%DATADIR%%/scripts/Caption.py
-%%DATADIR%%/scripts/ColorChart.py
-%%DATADIR%%/scripts/DirectImageImport.py
-%%DATADIR%%/scripts/FontSample.py
-%%DATADIR%%/scripts/InfoBox.py
-%%DATADIR%%/scripts/Ligatursatz.py
-%%DATADIR%%/scripts/color2csv.py
-%%DATADIR%%/scripts/csv2color.py
-%%DATADIR%%/scripts/importcsv2table.py
%%DATADIR%%/swatches/All_Color_Kit.xml
%%DATADIR%%/swatches/Android_TM.xml
%%DATADIR%%/swatches/Bundesregierung_CMYK.xml
@@ -3411,4 +3383,3 @@ share/pixmaps/scribus.png
%%DATADIR%%/icons/1_5_1_dark/22/delete-table-columns.png
%%DATADIR%%/icons/1_5_1_dark/22/delete-table-rows.png
%%DATADIR%%/icons/1_5_1_dark/22/dialog-error.png
-%%DATADIR%%/scripts/Align_image_in_frame.py