aboutsummaryrefslogtreecommitdiff
path: root/print/splix
diff options
context:
space:
mode:
authorAlex Kozlov <ak@FreeBSD.org>2012-09-13 19:54:52 +0000
committerAlex Kozlov <ak@FreeBSD.org>2012-09-13 19:54:52 +0000
commit3d03f0d5e8eb3a7ff0e6559658d6c1a1d00a2ec5 (patch)
treecaaadb80192a2a028d3361a4e0495d5b7733ed7a /print/splix
parentc9633df3f67f2d2c27df16a72d4b951a056c3338 (diff)
downloadports-3d03f0d5e8eb3a7ff0e6559658d6c1a1d00a2ec5.tar.gz
ports-3d03f0d5e8eb3a7ff0e6559658d6c1a1d00a2ec5.zip
- Remove indefinite article from COMMENT
- Convert to new options framework - Remove hardcoded CC/CXX [1] PR: 171295 [1] Submitted by: Christian Mangin <christian.mangin@gmail.com> [1]
Notes
Notes: svn path=/head/; revision=304229
Diffstat (limited to 'print/splix')
-rw-r--r--print/splix/Makefile34
1 files changed, 14 insertions, 20 deletions
diff --git a/print/splix/Makefile b/print/splix/Makefile
index c3729a4e820d..a03d40c5b7de 100644
--- a/print/splix/Makefile
+++ b/print/splix/Makefile
@@ -1,9 +1,4 @@
-# Ports collection makefile for: splix
-# Date created: 2007-03-30
-# Whom: Tomas Verbaitis <tomasv@megalogika.lt>
-#
# $FreeBSD$
-#
PORTNAME= splix
PORTVERSION= 2.0.0
@@ -12,9 +7,8 @@ CATEGORIES?= print
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
-COMMENT= A set of CUPS printer drivers for Samsung Printer Language printers
+COMMENT= CUPS printer drivers for Samsung Printer Language printers
-LIB_DEPENDS=
BUILD_DEPENDS= cups-config:${PORTSDIR}/print/cups-base
RUN_DEPENDS:= ${BUILD_DEPENDS}
@@ -43,29 +37,29 @@ DEST_DIR_DELL= ${CUPS_DATA_DIR}/model/dell
DEST_DIR_SAMSUNG= ${CUPS_DATA_DIR}/model/samsung
DEST_DIR_XEROX= ${CUPS_DATA_DIR}/model/xerox
-THREADS= 2
-WITH_THREADS= 1
-
-OPTIONS= JBIG "Enable use of JBIG algorithm (pattented)" on \
- BLACKOPTIM "Enable black correction algorithm" on \
+OPTIONS_DEFINE= JBIG BLACKOPTIM
+JBIG_DESC= Enable use of JBIG algorithm (pattented)
+BLACKOPTIM_DESC= Enable black correction algorithm
+OPTIONS_DEFAULT= JBIG BLACKOPTIM
.include "bsd.port.options.mk"
-.include "bsd.port.pre.mk"
+post-patch:
+ @${REINPLACE_CMD} -e '/^CC.*:= gcc/d' -e '/^CXX.*:= g++/d' \
+ -e 's/make/gmake/' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's/g++/$$(CXX)/' ${WRKSRC}/rules.mk
post-configure:
-.if !defined(WITHOUT_JBIG)
+.if ${PORT_OPTIONS:MJBIG}
PPD_SAMSUNG+= ${PPD_SAMSUNG_JBIG}
PPD_XEROX+= ${PPD_XEROX_JBIG}
-LIB_DEPENDS= jbig:${PORTSDIR}/graphics/jbigkit
-.endif
-
-.if defined(WITHOUT_JBIG)
+LIB_DEPENDS+= jbig:${PORTSDIR}/graphics/jbigkit
+.else
MAKE_ARGS+= DISABLE_JBIG=1
.endif
-.if defined(WITHOUT_BLACKOPTIM)
+.if empty(PORT_OPTIONS:MBLACKOPTIM)
MAKE_ARGS+= DISABLE_BLACKOPTIM=1
.endif
@@ -85,4 +79,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/optimized/${FILTER} ${BIN_DEST_DIR}
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>