aboutsummaryrefslogtreecommitdiff
path: root/print/tex-aleph
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2015-07-26 06:57:26 +0000
committerHiroki Sato <hrs@FreeBSD.org>2015-07-26 06:57:26 +0000
commit520677c14aad26c1f25a6135132732a3d8ae473c (patch)
tree2f0bed45179ba9632d6f4d71623d8fe71c8dd85b /print/tex-aleph
parentf58520633bcc1c333b3f58740c53c65617143f33 (diff)
downloadports-520677c14aad26c1f25a6135132732a3d8ae473c.tar.gz
ports-520677c14aad26c1f25a6135132732a3d8ae473c.zip
Notes
Diffstat (limited to 'print/tex-aleph')
-rw-r--r--print/tex-aleph/Makefile22
-rw-r--r--print/tex-aleph/files/patch-configure429
2 files changed, 437 insertions, 14 deletions
diff --git a/print/tex-aleph/Makefile b/print/tex-aleph/Makefile
index 0eac497f8e88..c8abbdd206af 100644
--- a/print/tex-aleph/Makefile
+++ b/print/tex-aleph/Makefile
@@ -2,7 +2,7 @@
PORTNAME= aleph
PORTVERSION= 1.15.2.1.r.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= print
MASTER_SITES= ftp://tug.org/historic/systems/texlive/2015/
PKGNAMEPREFIX= tex-
@@ -15,7 +15,10 @@ EXTRACT_ONLY= texlive-${DISTVERSION_TEXLIVE_SOURCE}-source${EXTRACT_SUFX}
MAINTAINER= hrs@FreeBSD.org
COMMENT= TeX Engine including Omega and e-TeX features
-USES= gmake tar:xz pkgconfig
+LIB_DEPENDS= libmpfr.so:${PORTSDIR}/math/mpfr \
+ libpng.so:${PORTSDIR}/graphics/png
+
+USES= tar:xz pkgconfig
USE_TEX= kpathsea web2c texmf formats fmtutil
USE_XORG= pixman
USE_GNOME= cairo
@@ -37,20 +40,11 @@ EXTRACT_FILES_TEXMF= \
texmf-dist/tex/lambda
WRKSRC= ${WRKDIR}/${DISTNAME}/texk/web2c
GNU_CONFIGURE= yes
-EXCLUDE_ENGINES=etex luatex luajittex pdftex mf mf-nowin ptex eptex uptex \
- euptex xetex tex synctex
+EXCLUDE_ENGINES=etex pdftex luatex luajittex mf mf-nowin \
+ ptex eptex uptex euptex \
+ otangle mp pmp upmp web2c web-progs xetex tex synctex
CONFIGURE_ARGS= ${EXCLUDE_ENGINES:S/^/--disable-/} \
--enable-aleph \
- --enable-otangle \
- --disable-mp \
- --enable-web2c \
- --disable-web-progs \
- --with-system-freetype2 \
- --with-freetype2-includes=${LOCALBASE}/include/freetype2 \
- --with-freetype2-libdir=${LOCALBASE}/lib \
- --with-system-poppler \
- --with-system-t1lib \
- --with-system-zziplib \
--with-system-zlib
.for L in cairo gmp kpathsea libpng mpfr pixman ptexenc
CONFIGURE_ARGS+=--with-system-$L \
diff --git a/print/tex-aleph/files/patch-configure b/print/tex-aleph/files/patch-configure
new file mode 100644
index 000000000000..ffcef7d0c69d
--- /dev/null
+++ b/print/tex-aleph/files/patch-configure
@@ -0,0 +1,429 @@
+--- configure.orig 2015-04-12 11:22:39 UTC
++++ configure
+@@ -23712,26 +23712,6 @@ $as_echo "#define z_const /**/" >>confde
+ ;;
+ esac
+
+-## _KPSE_LIB_FLAGS: Setup lua52 (-ltexlua52) flags
+- LUA52_INCLUDES="-I$kpse_BLD/libs/lua52/include"
+- LUA52_LIBS="$kpse_BLD/libs/lua52/libtexlua52.la"
+- LUA52_DEPEND='${top_builddir}/../../libs/lua52/libtexlua52.la'
+- LUA52_RULE='# Rebuild libtexlua52
+-$(LUA52_DEPEND): ${top_builddir}/../../libs/lua52/include/lua.h
+- cd ${top_builddir}/../../libs/lua52 && $(MAKE) $(AM_MAKEFLAGS) rebuild
+-${top_builddir}/../../libs/lua52/include/lua.h:
+- cd ${top_builddir}/../../libs/lua52 && $(MAKE) $(AM_MAKEFLAGS) rebuild'
+-
+-## _KPSE_LIB_FLAGS: Setup luajit (-ltexluajit) flags
+- LUAJIT_INCLUDES="-I$kpse_BLD/libs/luajit/include"
+- LUAJIT_LIBS="$kpse_BLD/libs/luajit/libtexluajit.la"
+- LUAJIT_DEPEND='${top_builddir}/../../libs/luajit/libtexluajit.la'
+- LUAJIT_RULE='# Rebuild libtexluajit
+-$(LUAJIT_DEPEND): ${top_builddir}/../../libs/luajit/include/luajit.h
+- cd ${top_builddir}/../../libs/luajit && $(MAKE) $(AM_MAKEFLAGS) rebuild
+-${top_builddir}/../../libs/luajit/include/luajit.h:
+- cd ${top_builddir}/../../libs/luajit && $(MAKE) $(AM_MAKEFLAGS) rebuild'
+-
+ ## _KPSE_LIB_FLAGS: Setup libpng (-lpng) flags
+
+ # Check whether --with-system-libpng was given.
+@@ -23756,121 +23736,6 @@ ${top_builddir}/../../libs/libpng/includ
+ cd ${top_builddir}/../../libs/libpng && $(MAKE) $(AM_MAKEFLAGS) rebuild'
+ fi
+
+-## _KPSE_LIB_FLAGS: Setup freetype2 (-lfreetype) flags
+-
+-# Check whether --with-system-freetype2 was given.
+-if test "${with_system_freetype2+set}" = set; then :
+- withval=$with_system_freetype2;
+-fi
+-if test "x$with_system_freetype2" = xyes; then
+- if test -n "$ac_tool_prefix"; then
+- # Extract the first word of "${ac_tool_prefix}freetype-config", so it can be a program name with args.
+-set dummy ${ac_tool_prefix}freetype-config; ac_word=$2
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
+-$as_echo_n "checking for $ac_word... " >&6; }
+-if ${ac_cv_prog_FT2_CONFIG+:} false; then :
+- $as_echo_n "(cached) " >&6
+-else
+- if test -n "$FT2_CONFIG"; then
+- ac_cv_prog_FT2_CONFIG="$FT2_CONFIG" # Let the user override the test.
+-else
+-as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+-for as_dir in $PATH
+-do
+- IFS=$as_save_IFS
+- test -z "$as_dir" && as_dir=.
+- for ac_exec_ext in '' $ac_executable_extensions; do
+- if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
+- ac_cv_prog_FT2_CONFIG="${ac_tool_prefix}freetype-config"
+- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
+- break 2
+- fi
+-done
+- done
+-IFS=$as_save_IFS
+-
+-fi
+-fi
+-FT2_CONFIG=$ac_cv_prog_FT2_CONFIG
+-if test -n "$FT2_CONFIG"; then
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $FT2_CONFIG" >&5
+-$as_echo "$FT2_CONFIG" >&6; }
+-else
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+-$as_echo "no" >&6; }
+-fi
+-
+-
+-fi
+-if test -z "$ac_cv_prog_FT2_CONFIG"; then
+- ac_ct_FT2_CONFIG=$FT2_CONFIG
+- # Extract the first word of "freetype-config", so it can be a program name with args.
+-set dummy freetype-config; ac_word=$2
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
+-$as_echo_n "checking for $ac_word... " >&6; }
+-if ${ac_cv_prog_ac_ct_FT2_CONFIG+:} false; then :
+- $as_echo_n "(cached) " >&6
+-else
+- if test -n "$ac_ct_FT2_CONFIG"; then
+- ac_cv_prog_ac_ct_FT2_CONFIG="$ac_ct_FT2_CONFIG" # Let the user override the test.
+-else
+-as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+-for as_dir in $PATH
+-do
+- IFS=$as_save_IFS
+- test -z "$as_dir" && as_dir=.
+- for ac_exec_ext in '' $ac_executable_extensions; do
+- if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
+- ac_cv_prog_ac_ct_FT2_CONFIG="freetype-config"
+- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
+- break 2
+- fi
+-done
+- done
+-IFS=$as_save_IFS
+-
+-fi
+-fi
+-ac_ct_FT2_CONFIG=$ac_cv_prog_ac_ct_FT2_CONFIG
+-if test -n "$ac_ct_FT2_CONFIG"; then
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_ct_FT2_CONFIG" >&5
+-$as_echo "$ac_ct_FT2_CONFIG" >&6; }
+-else
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+-$as_echo "no" >&6; }
+-fi
+-
+- if test "x$ac_ct_FT2_CONFIG" = x; then
+- FT2_CONFIG="false"
+- else
+- case $cross_compiling:$ac_tool_warned in
+-yes:)
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: using cross tools not prefixed with host triplet" >&5
+-$as_echo "$as_me: WARNING: using cross tools not prefixed with host triplet" >&2;}
+-ac_tool_warned=yes ;;
+-esac
+- FT2_CONFIG=$ac_ct_FT2_CONFIG
+- fi
+-else
+- FT2_CONFIG="$ac_cv_prog_FT2_CONFIG"
+-fi
+-if $FT2_CONFIG --ftversion >/dev/null 2>&1; then
+- FREETYPE2_INCLUDES=`$FT2_CONFIG --cflags`
+- FREETYPE2_LIBS=`$FT2_CONFIG --libs`
+-elif test "x$need_freetype2:$with_system_freetype2" = xyes:yes; then
+- as_fn_error $? "did not find freetype-config required for system freetype2 library" "$LINENO" 5
+-fi
+-else
+- FREETYPE2_INCLUDES="-I$kpse_BLD/libs/freetype2/freetype2"
+- FREETYPE2_LIBS="$kpse_BLD/libs/freetype2/libfreetype.a"
+- FREETYPE2_DEPEND='${top_builddir}/../../libs/freetype2/libfreetype.a'
+- FREETYPE2_RULE='# Rebuild libfreetype
+-$(FREETYPE2_DEPEND): ${top_builddir}/../../libs/freetype2/freetype2/ft2build.h
+- cd ${top_builddir}/../../libs/freetype2 && $(MAKE) $(AM_MAKEFLAGS) rebuild
+-${top_builddir}/../../libs/freetype2/freetype2/ft2build.h:
+- cd ${top_builddir}/../../libs/freetype2 && $(MAKE) $(AM_MAKEFLAGS) rebuild'
+-fi
+-
+ ## _KPSE_LIB_FLAGS: Setup pixman (-lpixman) flags
+
+ # Check whether --with-system-pixman was given.
+@@ -23989,34 +23854,6 @@ ${top_builddir}/../../libs/mpfr/include/
+ cd ${top_builddir}/../../libs/mpfr && $(MAKE) $(AM_MAKEFLAGS) rebuild'
+ fi
+
+-## _KPSE_LIB_FLAGS: Setup poppler (-lpoppler) flags
+-
+-# Check whether --with-system-poppler was given.
+-if test "${with_system_poppler+set}" = set; then :
+- withval=$with_system_poppler;
+-fi
+-if test "x$with_system_poppler" = xyes; then
+- if $PKG_CONFIG poppler --atleast-version=0.18; then
+- POPPLER_INCLUDES=`$PKG_CONFIG poppler --cflags`
+- POPPLER_LIBS=`$PKG_CONFIG poppler --libs`
+-elif test "x$need_poppler:$with_system_poppler" = xyes:yes; then
+- as_fn_error $? "did not find poppler 0.18 or better" "$LINENO" 5
+-fi
+-
+-POPPLER_VERSION='-DPOPPLER_VERSION=\"'`$PKG_CONFIG poppler --modversion`'\"'
+-POPPLER_INCLUDES="$POPPLER_VERSION $POPPLER_INCLUDES"
+-else
+- POPPLER_INCLUDES="-I$kpse_BLD/libs/poppler/include"
+- POPPLER_LIBS="$kpse_BLD/libs/poppler/libpoppler.a"
+- POPPLER_DEPEND='${top_builddir}/../../libs/poppler/libpoppler.a'
+- POPPLER_RULE='# Rebuild libpoppler
+-$(POPPLER_DEPEND): ${top_builddir}/../../libs/poppler/include/Stream.h
+- cd ${top_builddir}/../../libs/poppler && $(MAKE) $(AM_MAKEFLAGS) rebuild
+-${top_builddir}/../../libs/poppler/include/Stream.h:
+- cd ${top_builddir}/../../libs/poppler && $(MAKE) $(AM_MAKEFLAGS) rebuild'
+-fi
+-test "x$kpse_cv_have_win32" = xno || POPPLER_LIBS="$POPPLER_LIBS -lgdi32"
+-
+ ## _KPSE_LIB_FLAGS: Setup xpdf (-lxpdf) flags
+
+ # Check whether --with-system-xpdf was given.
+@@ -24045,242 +23882,6 @@ ${top_builddir}/../../libs/xpdf/xpdf/Str
+ fi
+ test "x$kpse_cv_have_win32" = xno || XPDF_LIBS="$XPDF_LIBS -lgdi32"
+
+-## _KPSE_LIB_FLAGS: Setup zziplib (-lzzip) flags
+-
+-# Check whether --with-system-zziplib was given.
+-if test "${with_system_zziplib+set}" = set; then :
+- withval=$with_system_zziplib;
+-fi
+-if test "x$with_system_zziplib" = xyes; then
+- if $PKG_CONFIG zziplib --atleast-version=0.12; then
+- ZZIPLIB_INCLUDES=`$PKG_CONFIG zziplib --cflags`
+- ZZIPLIB_LIBS=`$PKG_CONFIG zziplib --libs`
+-elif test "x$need_zziplib:$with_system_zziplib" = xyes:yes; then
+- as_fn_error $? "did not find zziplib 0.12 or better" "$LINENO" 5
+-fi
+-else
+- ZZIPLIB_INCLUDES="-I$kpse_BLD/libs/zziplib/include"
+- ZZIPLIB_LIBS="$kpse_BLD/libs/zziplib/libzzip.a"
+- ZZIPLIB_DEPEND='${top_builddir}/../../libs/zziplib/libzzip.a'
+- ZZIPLIB_RULE='# Rebuild libzzip
+-$(ZZIPLIB_DEPEND): ${top_builddir}/../../libs/zziplib/include/zzip/zzip.h
+- cd ${top_builddir}/../../libs/zziplib && $(MAKE) $(AM_MAKEFLAGS) rebuild
+-${top_builddir}/../../libs/zziplib/include/zzip/zzip.h:
+- cd ${top_builddir}/../../libs/zziplib && $(MAKE) $(AM_MAKEFLAGS) rebuild'
+-fi
+-
+-## _KPSE_LIB_FLAGS: Setup teckit (-lTECkit) flags
+-
+-# Check whether --with-system-teckit was given.
+-if test "${with_system_teckit+set}" = set; then :
+- withval=$with_system_teckit;
+-fi
+-if test "x$with_system_teckit" = xyes; then
+- if $PKG_CONFIG teckit; then
+- TECKIT_INCLUDES=`$PKG_CONFIG teckit --cflags`
+- TECKIT_LIBS=`$PKG_CONFIG teckit --libs`
+-elif test "x$need_teckit:$with_system_teckit" = xyes:yes; then
+- as_fn_error $? "did not find teckit" "$LINENO" 5
+-fi
+-else
+- TECKIT_INCLUDES="-I$kpse_BLD/libs/teckit/include"
+- TECKIT_LIBS="$kpse_BLD/libs/teckit/libTECkit.a"
+- TECKIT_DEPEND='${top_builddir}/../../libs/teckit/libTECkit.a'
+- TECKIT_RULE='# Rebuild libTECkit
+-$(TECKIT_DEPEND): ${top_builddir}/../../libs/teckit/include/teckit/TECkit_Common.h
+- cd ${top_builddir}/../../libs/teckit && $(MAKE) $(AM_MAKEFLAGS) rebuild
+-${top_builddir}/../../libs/teckit/include/teckit/TECkit_Common.h:
+- cd ${top_builddir}/../../libs/teckit && $(MAKE) $(AM_MAKEFLAGS) rebuild'
+-fi
+-
+-## _KPSE_LIB_FLAGS: Setup icu (-licuxxx) flags
+-
+-# Check whether --with-system-icu was given.
+-if test "${with_system_icu+set}" = set; then :
+- withval=$with_system_icu;
+-fi
+-if test "x$with_system_icu" = xyes; then
+- if test -n "$ac_tool_prefix"; then
+- # Extract the first word of "${ac_tool_prefix}icu-config", so it can be a program name with args.
+-set dummy ${ac_tool_prefix}icu-config; ac_word=$2
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
+-$as_echo_n "checking for $ac_word... " >&6; }
+-if ${ac_cv_prog_ICU_CONFIG+:} false; then :
+- $as_echo_n "(cached) " >&6
+-else
+- if test -n "$ICU_CONFIG"; then
+- ac_cv_prog_ICU_CONFIG="$ICU_CONFIG" # Let the user override the test.
+-else
+-as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+-for as_dir in $PATH
+-do
+- IFS=$as_save_IFS
+- test -z "$as_dir" && as_dir=.
+- for ac_exec_ext in '' $ac_executable_extensions; do
+- if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
+- ac_cv_prog_ICU_CONFIG="${ac_tool_prefix}icu-config"
+- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
+- break 2
+- fi
+-done
+- done
+-IFS=$as_save_IFS
+-
+-fi
+-fi
+-ICU_CONFIG=$ac_cv_prog_ICU_CONFIG
+-if test -n "$ICU_CONFIG"; then
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ICU_CONFIG" >&5
+-$as_echo "$ICU_CONFIG" >&6; }
+-else
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+-$as_echo "no" >&6; }
+-fi
+-
+-
+-fi
+-if test -z "$ac_cv_prog_ICU_CONFIG"; then
+- ac_ct_ICU_CONFIG=$ICU_CONFIG
+- # Extract the first word of "icu-config", so it can be a program name with args.
+-set dummy icu-config; ac_word=$2
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
+-$as_echo_n "checking for $ac_word... " >&6; }
+-if ${ac_cv_prog_ac_ct_ICU_CONFIG+:} false; then :
+- $as_echo_n "(cached) " >&6
+-else
+- if test -n "$ac_ct_ICU_CONFIG"; then
+- ac_cv_prog_ac_ct_ICU_CONFIG="$ac_ct_ICU_CONFIG" # Let the user override the test.
+-else
+-as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+-for as_dir in $PATH
+-do
+- IFS=$as_save_IFS
+- test -z "$as_dir" && as_dir=.
+- for ac_exec_ext in '' $ac_executable_extensions; do
+- if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
+- ac_cv_prog_ac_ct_ICU_CONFIG="icu-config"
+- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
+- break 2
+- fi
+-done
+- done
+-IFS=$as_save_IFS
+-
+-fi
+-fi
+-ac_ct_ICU_CONFIG=$ac_cv_prog_ac_ct_ICU_CONFIG
+-if test -n "$ac_ct_ICU_CONFIG"; then
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_ct_ICU_CONFIG" >&5
+-$as_echo "$ac_ct_ICU_CONFIG" >&6; }
+-else
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+-$as_echo "no" >&6; }
+-fi
+-
+- if test "x$ac_ct_ICU_CONFIG" = x; then
+- ICU_CONFIG="false"
+- else
+- case $cross_compiling:$ac_tool_warned in
+-yes:)
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: using cross tools not prefixed with host triplet" >&5
+-$as_echo "$as_me: WARNING: using cross tools not prefixed with host triplet" >&2;}
+-ac_tool_warned=yes ;;
+-esac
+- ICU_CONFIG=$ac_ct_ICU_CONFIG
+- fi
+-else
+- ICU_CONFIG="$ac_cv_prog_ICU_CONFIG"
+-fi
+-if $ICU_CONFIG --version >/dev/null 2>&1; then
+- ICU_INCLUDES=`$ICU_CONFIG --cppflags`
+- ICU_LIBS=`$ICU_CONFIG --ldflags-searchpath --ldflags-libsonly --ldflags-system`
+-elif test "x$need_icu:$with_system_icu" = xyes:yes; then
+- as_fn_error $? "did not find icu-config required for system icu libraries" "$LINENO" 5
+-fi
+-else
+- ICU_INCLUDES="-DU_STATIC_IMPLEMENTATION -I$kpse_BLD/libs/icu/include"
+- ICU_LIBS=" $kpse_BLD/libs/icu/icu-build/lib/libicuuc.a $kpse_BLD/libs/icu/icu-build/lib/libicudata.a"
+- ICU_DEPEND=' ${top_builddir}/../../libs/icu/icu-build/lib/libicuuc.a ${top_builddir}/../../libs/icu/icu-build/lib/libicudata.a'
+- ICU_RULE='# Rebuild libicuxxx
+-$(ICU_DEPEND): ${top_builddir}/../../libs/icu/include/unicode/uversion.h
+- cd ${top_builddir}/../../libs/icu && $(MAKE) $(AM_MAKEFLAGS) rebuild
+-${top_builddir}/../../libs/icu/include/unicode/uversion.h:
+- cd ${top_builddir}/../../libs/icu && $(MAKE) $(AM_MAKEFLAGS) rebuild'
+-fi
+-
+-## _KPSE_LIB_FLAGS: Setup graphite2 (-lgraphite2) flags
+-
+-# Check whether --with-system-graphite2 was given.
+-if test "${with_system_graphite2+set}" = set; then :
+- withval=$with_system_graphite2;
+-fi
+-if test "x$with_system_graphite2" = xyes; then
+- if $PKG_CONFIG graphite2; then
+- GRAPHITE2_INCLUDES=`$PKG_CONFIG graphite2 --cflags`
+- GRAPHITE2_LIBS=`$PKG_CONFIG graphite2 --libs`
+-elif test "x$need_graphite2:$with_system_graphite2" = xyes:yes; then
+- as_fn_error $? "did not find graphite2" "$LINENO" 5
+-fi
+-else
+- GRAPHITE2_INCLUDES="-I$kpse_BLD/libs/graphite2/include -DGRAPHITE2_STATIC"
+- GRAPHITE2_LIBS="$kpse_BLD/libs/graphite2/libgraphite2.a"
+- GRAPHITE2_DEPEND='${top_builddir}/../../libs/graphite2/libgraphite2.a'
+- GRAPHITE2_RULE='# Rebuild libgraphite2
+-$(GRAPHITE2_DEPEND): ${top_builddir}/../../libs/graphite2/include/graphite2/Font.h
+- cd ${top_builddir}/../../libs/graphite2 && $(MAKE) $(AM_MAKEFLAGS) rebuild
+-${top_builddir}/../../libs/graphite2/include/graphite2/Font.h:
+- cd ${top_builddir}/../../libs/graphite2 && $(MAKE) $(AM_MAKEFLAGS) rebuild'
+-fi
+-
+-## _KPSE_LIB_FLAGS: Setup harfbuzz (-lharfbuzz) flags
+-
+-# Check whether --with-system-harfbuzz was given.
+-if test "${with_system_harfbuzz+set}" = set; then :
+- withval=$with_system_harfbuzz;
+-fi
+-if test "x$with_system_harfbuzz" = xyes; then
+- if $PKG_CONFIG harfbuzz-icu; then
+- HARFBUZZ_INCLUDES=`$PKG_CONFIG harfbuzz-icu --cflags`
+- HARFBUZZ_LIBS=`$PKG_CONFIG harfbuzz-icu --libs`
+-elif test "x$need_harfbuzz:$with_system_harfbuzz" = xyes:yes; then
+- as_fn_error $? "did not find harfbuzz-icu" "$LINENO" 5
+-fi
+-else
+- HARFBUZZ_INCLUDES="-I$kpse_BLD/libs/harfbuzz/include"
+- HARFBUZZ_LIBS="$kpse_BLD/libs/harfbuzz/libharfbuzz.a"
+- HARFBUZZ_DEPEND='${top_builddir}/../../libs/harfbuzz/libharfbuzz.a'
+- HARFBUZZ_RULE='# Rebuild libharfbuzz
+-$(HARFBUZZ_DEPEND): ${top_builddir}/../../libs/harfbuzz/include/hb.h
+- cd ${top_builddir}/../../libs/harfbuzz && $(MAKE) $(AM_MAKEFLAGS) rebuild
+-${top_builddir}/../../libs/harfbuzz/include/hb.h:
+- cd ${top_builddir}/../../libs/harfbuzz && $(MAKE) $(AM_MAKEFLAGS) rebuild'
+-fi
+-
+-## _KPSE_LIB_FLAGS: Setup graphite2 (-lgraphite2) flags
+-
+-# Check whether --with-system-graphite2 was given.
+-if test "${with_system_graphite2+set}" = set; then :
+- withval=$with_system_graphite2;
+-fi
+-if test "x$with_system_graphite2" = xyes; then
+- if $PKG_CONFIG graphite2; then
+- GRAPHITE2_INCLUDES=`$PKG_CONFIG graphite2 --cflags`
+- GRAPHITE2_LIBS=`$PKG_CONFIG graphite2 --libs`
+-elif test "x$need_graphite2:$with_system_graphite2" = xyes:yes; then
+- as_fn_error $? "did not find graphite2" "$LINENO" 5
+-fi
+-else
+- GRAPHITE2_INCLUDES="-I$kpse_BLD/libs/graphite2/include -DGRAPHITE2_STATIC"
+- GRAPHITE2_LIBS="$kpse_BLD/libs/graphite2/libgraphite2.a"
+- GRAPHITE2_DEPEND='${top_builddir}/../../libs/graphite2/libgraphite2.a'
+- GRAPHITE2_RULE='# Rebuild libgraphite2
+-$(GRAPHITE2_DEPEND): ${top_builddir}/../../libs/graphite2/include/graphite2/Font.h
+- cd ${top_builddir}/../../libs/graphite2 && $(MAKE) $(AM_MAKEFLAGS) rebuild
+-${top_builddir}/../../libs/graphite2/include/graphite2/Font.h:
+- cd ${top_builddir}/../../libs/graphite2 && $(MAKE) $(AM_MAKEFLAGS) rebuild'
+-fi
+-
+-
+ # Check size of off_t (using <kpathsea/config.h>)
+ eval CPPFLAGS=\"$KPATHSEA_INCLUDES \$CPPFLAGS\"
+ eval LIBS=\"$KPATHSEA_LIBS \$LIBS\"