aboutsummaryrefslogtreecommitdiff
path: root/print/tex-ptexenc
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2015-07-25 21:36:56 +0000
committerHiroki Sato <hrs@FreeBSD.org>2015-07-25 21:36:56 +0000
commitf58520633bcc1c333b3f58740c53c65617143f33 (patch)
treebbcce3615eaf675f612d54cb21b7d4fc41b80d57 /print/tex-ptexenc
parent41750ec3c61c926c0a24fdfa5d60d7e26b9f5129 (diff)
downloadports-f58520633bcc1c333b3f58740c53c65617143f33.tar.gz
ports-f58520633bcc1c333b3f58740c53c65617143f33.zip
- Add iconv support.
- Add LICENSE. - Add CTAN mirror to MASTER_SITES.
Notes
Notes: svn path=/head/; revision=392908
Diffstat (limited to 'print/tex-ptexenc')
-rw-r--r--print/tex-ptexenc/Makefile19
-rw-r--r--print/tex-ptexenc/files/patch-configure38
2 files changed, 50 insertions, 7 deletions
diff --git a/print/tex-ptexenc/Makefile b/print/tex-ptexenc/Makefile
index 15b5abdba3ff..7be070b9d68d 100644
--- a/print/tex-ptexenc/Makefile
+++ b/print/tex-ptexenc/Makefile
@@ -2,9 +2,9 @@
PORTNAME= ptexenc
PORTVERSION= 1.3.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= print
-MASTER_SITES= ftp://tug.org/historic/systems/texlive/2015/
+MASTER_SITES= TEX_CTAN/systems/texlive/Source/
PKGNAMEPREFIX= tex-
DISTNAME= texlive-20150521-source
DIST_SUBDIR= TeX
@@ -12,17 +12,22 @@ DIST_SUBDIR= TeX
MAINTAINER= hrs@FreeBSD.org
COMMENT= Library for Japanese pTeX and its tools
-USES= tar:xz libtool pkgconfig
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYRIGHT
+
+USES= iconv libtool pkgconfig tar:xz
USE_TEX= kpathsea
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/texk/ptexenc
-EXTRACT_AFTER_ARGS= ${EXTRACT_FILES}
-EXTRACT_FILES= ${DISTNAME}/build-aux \
- ${DISTNAME}/texk/ptexenc
+EXTRACT_AFTER_ARGS= ${EXTRACT_FILES:S/^/${DISTNAME}\//}
+EXTRACT_FILES= build-aux texk/ptexenc
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-system-kpathsea \
+CONFIGURE_ARGS= --enable-kanji-iconv \
+ --with-system-kpathsea \
--with-kpathsea-includes=${LOCALBASE}/include \
--with-kpathsea-libdir=${LOCALBASE}/lib
+LIBS+= ${ICONV_LIB}
+CPPFLAGS+= -I${ICONV_PREFIX}/include
INSTALL_TARGET= install-strip
.include <bsd.port.mk>
diff --git a/print/tex-ptexenc/files/patch-configure b/print/tex-ptexenc/files/patch-configure
new file mode 100644
index 000000000000..e295021adb53
--- /dev/null
+++ b/print/tex-ptexenc/files/patch-configure
@@ -0,0 +1,38 @@
+--- configure.orig 2015-07-25 21:31:25 UTC
++++ configure
+@@ -14889,7 +14889,7 @@ if ${ac_cv_lib_iconv_iconv_open+:} false
+ $as_echo_n "(cached) " >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-liconv $LIBS"
++LIBS="$LIBS"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+
+@@ -14924,7 +14924,7 @@ if test "x$ac_cv_lib_iconv_iconv_open" =
+ #define HAVE_LIBICONV 1
+ _ACEOF
+
+- LIBS="-liconv $LIBS"
++ LIBS="$LIBS"
+
+ else
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for libiconv_open in -liconv" >&5
+@@ -14933,7 +14933,7 @@ if ${ac_cv_lib_iconv_libiconv_open+:} fa
+ $as_echo_n "(cached) " >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-liconv $LIBS"
++LIBS="$LIBS"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+
+@@ -14968,7 +14968,7 @@ if test "x$ac_cv_lib_iconv_libiconv_open
+ #define HAVE_LIBICONV 1
+ _ACEOF
+
+- LIBS="-liconv $LIBS"
++ LIBS="$LIBS"
+
+ fi
+