aboutsummaryrefslogtreecommitdiff
path: root/print/xpp
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-04-03 19:03:00 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-04-03 19:03:00 +0000
commit4942d87e8bb779d2a9ddacb17486dfc23b7607b0 (patch)
tree320ee65381f3c10605280e6267132ef983ad4538 /print/xpp
parent80596ca8a39573121e23c6a12eb495c57b720fbd (diff)
downloadports-4942d87e8bb779d2a9ddacb17486dfc23b7607b0.tar.gz
ports-4942d87e8bb779d2a9ddacb17486dfc23b7607b0.zip
Notes
Diffstat (limited to 'print/xpp')
-rw-r--r--print/xpp/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/print/xpp/Makefile b/print/xpp/Makefile
index 3e6dc30c4e8b..a10fce27a9f1 100644
--- a/print/xpp/Makefile
+++ b/print/xpp/Makefile
@@ -10,18 +10,17 @@ MASTER_SITES= SF/cups/${PORTNAME}/${PORTVERSION}
MAINTAINER= cy@FreeBSD.org
COMMENT= X11-based printer manager for CUPS
-LIB_DEPENDS= cups.2:${PORTSDIR}/print/cups-client \
- fltk.1:${PORTSDIR}/x11-toolkits/fltk
+LIB_DEPENDS= libcups.so:${PORTSDIR}/print/cups-client \
+ libfltk.so.1:${PORTSDIR}/x11-toolkits/fltk
BUILD_DEPENDS= ${LOCALBASE}/sbin/cupsd:${PORTSDIR}/print/cups-base
-USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake tar:bzip2
GNU_CONFIGURE= yes
+CFLAGS+= -D_IPP_PRIVATE_STRUCTURES
PLIST_FILES= bin/xpp share/doc/xpp/README
PLIST_DIRS= share/doc/xpp
-NO_STAGE= yes
post-configure:
@${REINPLACE_CMD} -e 's|$$(all_includes)|-I ${PREFIX}/include|' \
${WRKSRC}/Makefile
@@ -29,7 +28,7 @@ post-configure:
@${REINPLACE_CMD} -e 's|printFiles::get|get|' ${WRKSRC}/xpp.h
post-install:
- ${MKDIR} ${PREFIX}/share/doc/xpp
- ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/xpp
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/doc/xpp
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${PREFIX}/share/doc/xpp
.include <bsd.port.mk>