aboutsummaryrefslogtreecommitdiff
path: root/print/xreader
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2020-02-03 13:22:28 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2020-02-03 13:22:28 +0000
commit664a5424a2d29c57a3fb4063787b9d9b2899912a (patch)
tree7e73454697e0fdca88332e41c9955dbef7a4be77 /print/xreader
parentad8ad2b15d0857bba452c779ed0cd1d2ce161ae3 (diff)
downloadports-664a5424a2d29c57a3fb4063787b9d9b2899912a.tar.gz
ports-664a5424a2d29c57a3fb4063787b9d9b2899912a.zip
Xreader is a document viewer capable of displaying multiple and single page
document formats like CBR (comics), DjVu, DVI, PDF, PostScript, XPS, etc. WWW: https://github.com/linuxmint/xreader
Notes
Notes: svn path=/head/; revision=525035
Diffstat (limited to 'print/xreader')
-rw-r--r--print/xreader/Makefile55
-rw-r--r--print/xreader/distinfo3
-rw-r--r--print/xreader/pkg-descr4
-rw-r--r--print/xreader/pkg-plist226
4 files changed, 288 insertions, 0 deletions
diff --git a/print/xreader/Makefile b/print/xreader/Makefile
new file mode 100644
index 000000000000..0aca321c7ee1
--- /dev/null
+++ b/print/xreader/Makefile
@@ -0,0 +1,55 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= xreader
+PORTVERSION= 2.4.4
+CATEGORIES= print
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Generic document reader
+
+LICENSE= GPLv2+
+
+BUILD_DEPENDS= intltool-merge:textproc/intltool
+LIB_DEPENDS= libxapp.so:x11/xapps
+
+USES= desktop-file-utils gettext-tools gnome meson pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= linuxmint
+USE_LDCONFIG= yes
+USE_GNOME= cairo gdkpixbuf2 gtk30 libxml2
+USE_XORG= ice sm x11
+GLIB_SCHEMAS= org.x.reader.gschema.xml
+INSTALLS_ICONS= yes
+
+MESON_ARGS= -Depub=false -Dtests=false
+
+OPTIONS_DEFINE= DJVU KEYRING PDF PS TIFF XPS
+OPTIONS_DEFAULT= DJVU KEYRING PDF TIFF XPS
+KEYRING_DESC= Password-protected document support
+XPS_DESC= XPS document support
+OPTIONS_SUB= yes
+
+DJVU_LIB_DEPENDS= libdjvulibre.so:graphics/djvulibre
+DJVU_MESON_ON= -Ddjvu=true
+
+KEYRING_LIB_DEPENDS= libsecret-1.so:security/libsecret
+KEYRING_MESON_OFF= -Dkeyring=false
+
+PDF_LIB_DEPENDS= libpoppler-glib.so:graphics/poppler-glib
+PDF_MESON_OFF= -Dpdf=false
+
+PS_LIB_DEPENDS= libspectre.so:print/libspectre
+PS_MESON_OFF= -Dps=false
+
+TIFF_LIB_DEPENDS= libtiff.so:graphics/tiff
+TIFF_MESON_OFF= -Dtiff=false
+
+XPS_LIB_DEPENDS= libgxps.so:graphics/libgxps
+XPS_MESON_OFF= -Dxps=false
+
+post-patch:
+ @${REINPLACE_CMD} -e '/gdk\/gdkwayland\.h/d' \
+ ${WRKSRC}/libdocument/ev-document-misc.h
+
+.include <bsd.port.mk>
diff --git a/print/xreader/distinfo b/print/xreader/distinfo
new file mode 100644
index 000000000000..c766e6b32cba
--- /dev/null
+++ b/print/xreader/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1578585874
+SHA256 (linuxmint-xreader-2.4.4_GH0.tar.gz) = 1ccfee598aef723e8815c7a2b782624c0d5f6c4d15194dbeb74f5e45b8aff898
+SIZE (linuxmint-xreader-2.4.4_GH0.tar.gz) = 2177561
diff --git a/print/xreader/pkg-descr b/print/xreader/pkg-descr
new file mode 100644
index 000000000000..19ac40809f5b
--- /dev/null
+++ b/print/xreader/pkg-descr
@@ -0,0 +1,4 @@
+Xreader is a document viewer capable of displaying multiple and single page
+document formats like CBR (comics), DjVu, DVI, PDF, PostScript, XPS, etc.
+
+WWW: https://github.com/linuxmint/xreader
diff --git a/print/xreader/pkg-plist b/print/xreader/pkg-plist
new file mode 100644
index 000000000000..4174d7044b85
--- /dev/null
+++ b/print/xreader/pkg-plist
@@ -0,0 +1,226 @@
+bin/xreader
+bin/xreader-previewer
+bin/xreader-thumbnailer
+include/xreader/1.5/libdocument/ev-annotation.h
+include/xreader/1.5/libdocument/ev-async-renderer.h
+include/xreader/1.5/libdocument/ev-attachment.h
+include/xreader/1.5/libdocument/ev-backends-manager.h
+include/xreader/1.5/libdocument/ev-document-annotations.h
+include/xreader/1.5/libdocument/ev-document-attachments.h
+include/xreader/1.5/libdocument/ev-document-factory.h
+include/xreader/1.5/libdocument/ev-document-find.h
+include/xreader/1.5/libdocument/ev-document-fonts.h
+include/xreader/1.5/libdocument/ev-document-forms.h
+include/xreader/1.5/libdocument/ev-document-images.h
+include/xreader/1.5/libdocument/ev-document-info.h
+include/xreader/1.5/libdocument/ev-document-layers.h
+include/xreader/1.5/libdocument/ev-document-links.h
+include/xreader/1.5/libdocument/ev-document-misc.h
+include/xreader/1.5/libdocument/ev-document-print.h
+include/xreader/1.5/libdocument/ev-document-security.h
+include/xreader/1.5/libdocument/ev-document-text.h
+include/xreader/1.5/libdocument/ev-document-thumbnails.h
+include/xreader/1.5/libdocument/ev-document-transition.h
+include/xreader/1.5/libdocument/ev-document-type-builtins.h
+include/xreader/1.5/libdocument/ev-document.h
+include/xreader/1.5/libdocument/ev-file-exporter.h
+include/xreader/1.5/libdocument/ev-file-helpers.h
+include/xreader/1.5/libdocument/ev-form-field.h
+include/xreader/1.5/libdocument/ev-image.h
+include/xreader/1.5/libdocument/ev-init.h
+include/xreader/1.5/libdocument/ev-layer.h
+include/xreader/1.5/libdocument/ev-link-action.h
+include/xreader/1.5/libdocument/ev-link-dest.h
+include/xreader/1.5/libdocument/ev-link.h
+include/xreader/1.5/libdocument/ev-macros.h
+include/xreader/1.5/libdocument/ev-mapping-list.h
+include/xreader/1.5/libdocument/ev-page.h
+include/xreader/1.5/libdocument/ev-render-context.h
+include/xreader/1.5/libdocument/ev-selection.h
+include/xreader/1.5/libdocument/ev-transition-effect.h
+include/xreader/1.5/libdocument/ev-version.h
+include/xreader/1.5/libview/ev-document-model.h
+include/xreader/1.5/libview/ev-job-scheduler.h
+include/xreader/1.5/libview/ev-jobs.h
+include/xreader/1.5/libview/ev-print-operation.h
+include/xreader/1.5/libview/ev-stock-icons.h
+include/xreader/1.5/libview/ev-view-presentation.h
+include/xreader/1.5/libview/ev-view-type-builtins.h
+include/xreader/1.5/libview/ev-view.h
+include/xreader/1.5/libview/ev-web-view.h
+include/xreader/1.5/xreader-document.h
+include/xreader/1.5/xreader-view.h
+lib/libxreaderdocument.so
+lib/libxreaderdocument.so.3
+lib/libxreaderdocument.so.3.0.0
+lib/libxreaderview.so
+lib/libxreaderview.so.3
+lib/libxreaderview.so.3.0.0
+%%DJVU%%lib/xreader/3/backends/djvudocument.xreader-backend
+%%DJVU%%lib/xreader/3/backends/libdjvudocument.so
+%%PDF%%lib/xreader/3/backends/libpdfdocument.so
+%%PS%%lib/xreader/3/backends/libpsdocument.so
+%%TIFF%%lib/xreader/3/backends/libtiffdocument.so
+%%XPS%%lib/xreader/3/backends/libxpsdocument.so
+%%PDF%%lib/xreader/3/backends/pdfdocument.xreader-backend
+%%PS%%lib/xreader/3/backends/psdocument.xreader-backend
+%%TIFF%%lib/xreader/3/backends/tiffdocument.xreader-backend
+%%XPS%%lib/xreader/3/backends/xpsdocument.xreader-backend
+libdata/pkgconfig/xreader-document-1.5.pc
+libdata/pkgconfig/xreader-view-1.5.pc
+libexec/xreaderd
+man/man1/xreader-previewer.1.gz
+man/man1/xreader-thumbnailer.1.gz
+man/man1/xreader.1.gz
+share/appdata/xreader.appdata.xml
+share/applications/xreader.desktop
+share/dbus-1/services/org.x.reader.Daemon.service
+share/icons/hicolor/16x16/apps/xreader.png
+share/icons/hicolor/22x22/apps/xreader.png
+share/icons/hicolor/24x24/apps/xreader.png
+share/icons/hicolor/48x48/apps/xreader.png
+share/icons/hicolor/scalable/apps/xreader.svg
+share/locale/ab/LC_MESSAGES/xreader.mo
+share/locale/af/LC_MESSAGES/xreader.mo
+share/locale/am/LC_MESSAGES/xreader.mo
+share/locale/ar/LC_MESSAGES/xreader.mo
+share/locale/as/LC_MESSAGES/xreader.mo
+share/locale/ast/LC_MESSAGES/xreader.mo
+share/locale/az/LC_MESSAGES/xreader.mo
+share/locale/be/LC_MESSAGES/xreader.mo
+share/locale/be@latin/LC_MESSAGES/xreader.mo
+share/locale/bg/LC_MESSAGES/xreader.mo
+share/locale/bn/LC_MESSAGES/xreader.mo
+share/locale/bn_IN/LC_MESSAGES/xreader.mo
+share/locale/br/LC_MESSAGES/xreader.mo
+share/locale/ca/LC_MESSAGES/xreader.mo
+share/locale/ca@valencia/LC_MESSAGES/xreader.mo
+share/locale/cmn/LC_MESSAGES/xreader.mo
+share/locale/cs/LC_MESSAGES/xreader.mo
+share/locale/cy/LC_MESSAGES/xreader.mo
+share/locale/da/LC_MESSAGES/xreader.mo
+share/locale/de/LC_MESSAGES/xreader.mo
+share/locale/dz/LC_MESSAGES/xreader.mo
+share/locale/el/LC_MESSAGES/xreader.mo
+share/locale/en@shaw/LC_MESSAGES/xreader.mo
+share/locale/en_AU/LC_MESSAGES/xreader.mo
+share/locale/en_CA/LC_MESSAGES/xreader.mo
+share/locale/en_GB/LC_MESSAGES/xreader.mo
+share/locale/eo/LC_MESSAGES/xreader.mo
+share/locale/es/LC_MESSAGES/xreader.mo
+share/locale/es_CO/LC_MESSAGES/xreader.mo
+share/locale/es_VE/LC_MESSAGES/xreader.mo
+share/locale/et/LC_MESSAGES/xreader.mo
+share/locale/eu/LC_MESSAGES/xreader.mo
+share/locale/fa/LC_MESSAGES/xreader.mo
+share/locale/fi/LC_MESSAGES/xreader.mo
+share/locale/fr/LC_MESSAGES/xreader.mo
+share/locale/fr_CA/LC_MESSAGES/xreader.mo
+share/locale/ga/LC_MESSAGES/xreader.mo
+share/locale/gl/LC_MESSAGES/xreader.mo
+share/locale/gu/LC_MESSAGES/xreader.mo
+share/locale/he/LC_MESSAGES/xreader.mo
+share/locale/hi/LC_MESSAGES/xreader.mo
+share/locale/hr/LC_MESSAGES/xreader.mo
+share/locale/hu/LC_MESSAGES/xreader.mo
+share/locale/hy/LC_MESSAGES/xreader.mo
+share/locale/ia/LC_MESSAGES/xreader.mo
+share/locale/id/LC_MESSAGES/xreader.mo
+share/locale/ie/LC_MESSAGES/xreader.mo
+share/locale/is/LC_MESSAGES/xreader.mo
+share/locale/it/LC_MESSAGES/xreader.mo
+share/locale/ja/LC_MESSAGES/xreader.mo
+share/locale/ka/LC_MESSAGES/xreader.mo
+share/locale/kab/LC_MESSAGES/xreader.mo
+share/locale/kk/LC_MESSAGES/xreader.mo
+share/locale/kn/LC_MESSAGES/xreader.mo
+share/locale/ko/LC_MESSAGES/xreader.mo
+share/locale/ks/LC_MESSAGES/xreader.mo
+share/locale/ku/LC_MESSAGES/xreader.mo
+share/locale/ky/LC_MESSAGES/xreader.mo
+share/locale/la/LC_MESSAGES/xreader.mo
+share/locale/lt/LC_MESSAGES/xreader.mo
+share/locale/lv/LC_MESSAGES/xreader.mo
+share/locale/mai/LC_MESSAGES/xreader.mo
+share/locale/mg/LC_MESSAGES/xreader.mo
+share/locale/mk/LC_MESSAGES/xreader.mo
+share/locale/ml/LC_MESSAGES/xreader.mo
+share/locale/mn/LC_MESSAGES/xreader.mo
+share/locale/mr/LC_MESSAGES/xreader.mo
+share/locale/ms/LC_MESSAGES/xreader.mo
+share/locale/nb/LC_MESSAGES/xreader.mo
+share/locale/nds/LC_MESSAGES/xreader.mo
+share/locale/ne/LC_MESSAGES/xreader.mo
+share/locale/nl/LC_MESSAGES/xreader.mo
+share/locale/nn/LC_MESSAGES/xreader.mo
+share/locale/oc/LC_MESSAGES/xreader.mo
+share/locale/or/LC_MESSAGES/xreader.mo
+share/locale/pa/LC_MESSAGES/xreader.mo
+share/locale/pl/LC_MESSAGES/xreader.mo
+share/locale/ps/LC_MESSAGES/xreader.mo
+share/locale/pt/LC_MESSAGES/xreader.mo
+share/locale/pt_BR/LC_MESSAGES/xreader.mo
+share/locale/ro/LC_MESSAGES/xreader.mo
+share/locale/ru/LC_MESSAGES/xreader.mo
+share/locale/rw/LC_MESSAGES/xreader.mo
+share/locale/sc/LC_MESSAGES/xreader.mo
+share/locale/si/LC_MESSAGES/xreader.mo
+share/locale/sk/LC_MESSAGES/xreader.mo
+share/locale/sl/LC_MESSAGES/xreader.mo
+share/locale/sq/LC_MESSAGES/xreader.mo
+share/locale/sr/LC_MESSAGES/xreader.mo
+share/locale/sr@latin/LC_MESSAGES/xreader.mo
+share/locale/sv/LC_MESSAGES/xreader.mo
+share/locale/ta/LC_MESSAGES/xreader.mo
+share/locale/te/LC_MESSAGES/xreader.mo
+share/locale/th/LC_MESSAGES/xreader.mo
+share/locale/tr/LC_MESSAGES/xreader.mo
+share/locale/tt/LC_MESSAGES/xreader.mo
+share/locale/uk/LC_MESSAGES/xreader.mo
+share/locale/ur/LC_MESSAGES/xreader.mo
+share/locale/vi/LC_MESSAGES/xreader.mo
+share/locale/wa/LC_MESSAGES/xreader.mo
+share/locale/zh_CN/LC_MESSAGES/xreader.mo
+share/locale/zh_HK/LC_MESSAGES/xreader.mo
+share/locale/zh_TW/LC_MESSAGES/xreader.mo
+share/thumbnailers/xreader.thumbnailer
+%%DATADIR%%/hand-open.png
+%%DATADIR%%/icons/hicolor/16x16/actions/object-rotate-left.png
+%%DATADIR%%/icons/hicolor/16x16/actions/object-rotate-right.png
+%%DATADIR%%/icons/hicolor/16x16/actions/view-page-continuous.png
+%%DATADIR%%/icons/hicolor/16x16/actions/view-page-facing.png
+%%DATADIR%%/icons/hicolor/16x16/actions/zoom-fit-height.png
+%%DATADIR%%/icons/hicolor/16x16/actions/zoom-fit-width.png
+%%DATADIR%%/icons/hicolor/16x16/actions/zoom.png
+%%DATADIR%%/icons/hicolor/16x16/mimetypes/x-office-presentation.png
+%%DATADIR%%/icons/hicolor/22x22/actions/eye.png
+%%DATADIR%%/icons/hicolor/22x22/actions/object-rotate-left.png
+%%DATADIR%%/icons/hicolor/22x22/actions/object-rotate-right.png
+%%DATADIR%%/icons/hicolor/22x22/actions/view-page-continuous.png
+%%DATADIR%%/icons/hicolor/22x22/actions/view-page-facing.png
+%%DATADIR%%/icons/hicolor/22x22/actions/zoom-fit-page.png
+%%DATADIR%%/icons/hicolor/22x22/actions/zoom-fit-width.png
+%%DATADIR%%/icons/hicolor/22x22/actions/zoom.png
+%%DATADIR%%/icons/hicolor/22x22/mimetypes/x-office-presentation.png
+%%DATADIR%%/icons/hicolor/24x24/actions/object-rotate-left.png
+%%DATADIR%%/icons/hicolor/24x24/actions/object-rotate-right.png
+%%DATADIR%%/icons/hicolor/24x24/actions/stock_filters-invert.png
+%%DATADIR%%/icons/hicolor/24x24/actions/view-page-continuous.png
+%%DATADIR%%/icons/hicolor/24x24/actions/view-page-facing.png
+%%DATADIR%%/icons/hicolor/24x24/actions/zoom-fit-height.png
+%%DATADIR%%/icons/hicolor/24x24/actions/zoom-fit-width.png
+%%DATADIR%%/icons/hicolor/24x24/actions/zoom.png
+%%DATADIR%%/icons/hicolor/24x24/mimetypes/x-office-presentation.png
+%%DATADIR%%/icons/hicolor/32x32/actions/object-rotate-left.png
+%%DATADIR%%/icons/hicolor/32x32/actions/object-rotate-right.png
+%%DATADIR%%/icons/hicolor/32x32/actions/view-page-continuous.png
+%%DATADIR%%/icons/hicolor/32x32/actions/view-page-facing.png
+%%DATADIR%%/icons/hicolor/32x32/mimetypes/x-office-presentation.png
+%%DATADIR%%/icons/hicolor/48x48/actions/close.png
+%%DATADIR%%/icons/hicolor/48x48/actions/resize-se.png
+%%DATADIR%%/icons/hicolor/48x48/actions/resize-sw.png
+%%DATADIR%%/icons/hicolor/48x48/actions/view-page-continuous.png
+%%DATADIR%%/icons/hicolor/48x48/actions/view-page-facing.png
+%%DATADIR%%/icons/hicolor/scalable/actions/object-rotate-left.svg
+%%DATADIR%%/icons/hicolor/scalable/actions/object-rotate-right.svg
+%%DATADIR%%/icons/hicolor/scalable/mimetypes/x-office-presentation.svg