aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-02-11 12:31:45 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-02-11 12:31:45 +0000
commit00ddf5cfb3b826d453723c26bb32cdd5e2b1228a (patch)
tree3118d62926449d0c3d1a04005e706bebe9513090 /print
parent11338fde41532258b8a30e80c1c46a999240dd9b (diff)
downloadports-00ddf5cfb3b826d453723c26bb32cdd5e2b1228a.tar.gz
ports-00ddf5cfb3b826d453723c26bb32cdd5e2b1228a.zip
print/scribus-devel: update to 1.5.6.1
Notes
Notes: svn path=/head/; revision=564938
Diffstat (limited to 'print')
-rw-r--r--print/scribus-devel/Makefile9
-rw-r--r--print/scribus-devel/distinfo6
-rw-r--r--print/scribus-devel/files/patch-CMakeLists.txt20
-rw-r--r--print/scribus-devel/files/patch-scribus_plugins_CMakeLists.txt13
-rw-r--r--print/scribus-devel/files/patch-scribus_plugins_import_pdf_importpdf.cpp81
-rw-r--r--print/scribus-devel/files/patch-scribus_plugins_import_pdf_slaoutput.cpp227
-rw-r--r--print/scribus-devel/files/patch-scribus_plugins_import_pdf_slaoutput.h31
-rw-r--r--print/scribus-devel/files/patch-scribus_ui_scresizecursor.cpp10
-rw-r--r--print/scribus-devel/pkg-plist156
9 files changed, 163 insertions, 390 deletions
diff --git a/print/scribus-devel/Makefile b/print/scribus-devel/Makefile
index 6dadfcccdec4..6eb5c97eec3f 100644
--- a/print/scribus-devel/Makefile
+++ b/print/scribus-devel/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= scribus
-PORTVERSION= 1.5.5
-PORTREVISION= 25
+PORTVERSION= 1.5.6.1
CATEGORIES= print editors
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}${PKGNAMESUFFIX}/${PORTVERSION}/ \
http://www.scribus.net/downloads/${PORTVERSION}/
@@ -34,10 +33,11 @@ LIB_DEPENDS= liblcms2.so:graphics/lcms2 \
libfontconfig.so:x11-fonts/fontconfig \
libpodofo.so:graphics/podofo \
libharfbuzz.so:print/harfbuzz \
+ libpng16.so:graphics/png \
libicuuc.so:devel/icu
USES= cmake compiler:gcc-c++11-lib desktop-file-utils dos2unix gnome \
- jpeg pkgconfig qt:5 shared-mime-info ssl tar:xz
+ jpeg pkgconfig python:3.6+ qt:5 shared-mime-info ssl tar:xz
USE_QT= buildtools_build core declarative gui linguisttools_build \
network opengl printsupport qmake_build widgets xml
DOS2UNIX_REGEX= .*\.(cpp|h|txt)
@@ -45,8 +45,7 @@ USE_GNOME= libxml2
INSTALLS_ICONS= yes
USE_LDCONFIG= yes
-CMAKE_ARGS+= -DWANT_HUNSPELL=YES -DWANT_SCRIPTER2=YES \
- -Wno-ferror-limit -DCMAKE_COLOR_MAKEFILE:BOOL=ON
+CMAKE_ARGS+= -DWANT_HUNSPELL=YES -DCMAKE_COLOR_MAKEFILE:BOOL=ON
OPTIONS_DEFINE= DOCS
diff --git a/print/scribus-devel/distinfo b/print/scribus-devel/distinfo
index a2c11c32980e..97dd56544a68 100644
--- a/print/scribus-devel/distinfo
+++ b/print/scribus-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1565628826
-SHA256 (scribus-1.5.5.tar.xz) = 7908b21a6ce843269f58cedf5f8f791893257e6201cce5fbddc70daca2fe3f71
-SIZE (scribus-1.5.5.tar.xz) = 73861836
+TIMESTAMP = 1613016147
+SHA256 (scribus-1.5.6.1.tar.xz) = d4257695539cfa40dead8abdaf04c51e34d4d74bcad5a2c934d08e6e9d43b7ab
+SIZE (scribus-1.5.6.1.tar.xz) = 74307132
diff --git a/print/scribus-devel/files/patch-CMakeLists.txt b/print/scribus-devel/files/patch-CMakeLists.txt
deleted file mode 100644
index 141626cbe668..000000000000
--- a/print/scribus-devel/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,20 +0,0 @@
---- CMakeLists.txt.orig 2020-09-13 18:32:23 UTC
-+++ CMakeLists.txt
-@@ -845,17 +845,6 @@ else()
- endif()
- #<< JPEG, TIFF
-
--#<< PYTHON
--#set(PythonLibs_FIND_VERSION 2)
--find_package(PythonInterp 2)
--find_package(PythonLibs 2 REQUIRED)
--if (PYTHON_LIBRARY)
-- message("Python Library Found OK")
-- set(HAVE_PYTHON ON)
-- set(COMPILE_PYTHON ON)
--endif()
--#>> PYTHON
--
- #<< FreeType2
- find_package(Freetype REQUIRED)
- if (FREETYPE_FOUND)
diff --git a/print/scribus-devel/files/patch-scribus_plugins_CMakeLists.txt b/print/scribus-devel/files/patch-scribus_plugins_CMakeLists.txt
deleted file mode 100644
index a3c9691febe0..000000000000
--- a/print/scribus-devel/files/patch-scribus_plugins_CMakeLists.txt
+++ /dev/null
@@ -1,13 +0,0 @@
---- scribus/plugins/CMakeLists.txt.orig 2020-09-13 18:32:25 UTC
-+++ scribus/plugins/CMakeLists.txt
-@@ -15,8 +15,8 @@ if(NOT WANT_SCRIPTER2)
- endif()
- else()
- #scripter2
-- message(STATUS "Building with Scripter 2")
-- add_subdirectory(scripter)
-+# message(STATUS "Building with Scripter 2")
-+# add_subdirectory(scripter)
- endif()
- add_subdirectory(short-words)
- add_subdirectory(tools)
diff --git a/print/scribus-devel/files/patch-scribus_plugins_import_pdf_importpdf.cpp b/print/scribus-devel/files/patch-scribus_plugins_import_pdf_importpdf.cpp
deleted file mode 100644
index 032a42a5c3f1..000000000000
--- a/print/scribus-devel/files/patch-scribus_plugins_import_pdf_importpdf.cpp
+++ /dev/null
@@ -1,81 +0,0 @@
---- scribus/plugins/import/pdf/importpdf.cpp.orig 2020-03-15 14:15:45 UTC
-+++ scribus/plugins/import/pdf/importpdf.cpp
-@@ -75,7 +75,7 @@ PdfPlug::PdfPlug(ScribusDoc* doc, int flags)
- QImage PdfPlug::readThumbnail(const QString& fName)
- {
- QString pdfFile = QDir::toNativeSeparators(fName);
-- globalParams = new GlobalParams();
-+ globalParams.reset(new GlobalParams());
- if (globalParams)
- {
- #if defined(Q_OS_WIN32) && POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 62, 0)
-@@ -90,7 +90,6 @@ QImage PdfPlug::readThumbnail(const QString& fName)
- if (pdfDoc->getErrorCode() == errEncrypted)
- {
- delete pdfDoc;
-- delete globalParams;
- return QImage();
- }
- if (pdfDoc->isOk())
-@@ -134,11 +133,9 @@ QImage PdfPlug::readThumbnail(const QString& fName)
- image.setText("YSize", QString("%1").arg(h));
- delete dev;
- delete pdfDoc;
-- delete globalParams;
- return image;
- }
- delete pdfDoc;
-- delete globalParams;
- }
- }
- return QImage();
-@@ -387,7 +384,7 @@ bool PdfPlug::convert(const QString& fn)
- qApp->processEvents();
- }
-
-- globalParams = new GlobalParams();
-+ globalParams.reset(new GlobalParams());
- GooString *userPW = nullptr;
- if (globalParams)
- {
-@@ -429,7 +426,6 @@ bool PdfPlug::convert(const QString& fn)
- if (progressDialog)
- progressDialog->close();
- delete pdfDoc;
-- delete globalParams;
- return false;
- }
- if (progressDialog)
-@@ -474,7 +470,6 @@ bool PdfPlug::convert(const QString& fn)
- progressDialog->close();
- delete optImp;
- delete pdfDoc;
-- delete globalParams;
- return false;
- }
- pageString = optImp->getPagesString();
-@@ -839,13 +834,13 @@ bool PdfPlug::convert(const QString& fn)
- if (names.isDict())
- {
- LinkAction *linkAction = nullptr;
-- linkAction = LinkAction::parseAction(&names, pdfDoc->getCatalog()->getBaseURI());
-+ linkAction = LinkAction::parseAction(&names, pdfDoc->getCatalog()->getBaseURI()).get();
- if (linkAction)
- {
- LinkJavaScript *jsa = (LinkJavaScript*)linkAction;
- if (jsa->isOk())
- {
-- QString script = UnicodeParsedString(jsa->getScript());
-+ QString script = QString::fromStdString(jsa->getScript());
- if (script.startsWith("this."))
- {
- script.remove(0, 5);
-@@ -908,7 +903,7 @@ bool PdfPlug::convert(const QString& fn)
- }
- delete pdfDoc;
- }
-- delete globalParams;
-+ globalParams.release();
- globalParams = nullptr;
-
- // qDebug() << "converting finished";
diff --git a/print/scribus-devel/files/patch-scribus_plugins_import_pdf_slaoutput.cpp b/print/scribus-devel/files/patch-scribus_plugins_import_pdf_slaoutput.cpp
deleted file mode 100644
index 2ecb817de967..000000000000
--- a/print/scribus-devel/files/patch-scribus_plugins_import_pdf_slaoutput.cpp
+++ /dev/null
@@ -1,227 +0,0 @@
---- scribus/plugins/import/pdf/slaoutput.cpp.orig 2020-03-15 14:15:45 UTC
-+++ scribus/plugins/import/pdf/slaoutput.cpp
-@@ -324,7 +324,7 @@ LinkAction* SlaOutputDev::SC_getAdditionalAction(const
- {
- Object actionObject = additionalActionsObject.dictLookup(key);
- if (actionObject.isDict())
-- linkAction = LinkAction::parseAction(&actionObject, pdfDoc->getCatalog()->getBaseURI());
-+ linkAction = LinkAction::parseAction(&actionObject, pdfDoc->getCatalog()->getBaseURI()).get();
- }
- }
- return linkAction;
-@@ -455,7 +455,7 @@ bool SlaOutputDev::handleLinkAnnot(Annot* annota, doub
- POPPLER_CONST GooString *ndst = gto->getNamedDest();
- if (ndst)
- {
-- LinkDest *dstn = pdfDoc->findDest(ndst);
-+ LinkDest *dstn = pdfDoc->findDest(ndst).get();
- if (dstn)
- {
- if (dstn->getKind() == destXYZ)
-@@ -499,7 +499,7 @@ bool SlaOutputDev::handleLinkAnnot(Annot* annota, doub
- POPPLER_CONST GooString *ndst = gto->getNamedDest();
- if (ndst)
- {
-- LinkDest *dstn = pdfDoc->findDest(ndst);
-+ LinkDest *dstn = pdfDoc->findDest(ndst).get();
- if (dstn)
- {
- if (dstn->getKind() == destXYZ)
-@@ -517,7 +517,7 @@ bool SlaOutputDev::handleLinkAnnot(Annot* annota, doub
- {
- LinkURI *gto = (LinkURI*)act;
- validLink = true;
-- fileName = UnicodeParsedString(gto->getURI());
-+ fileName = QString::fromStdString(gto->getURI());
- }
- if (validLink)
- {
-@@ -930,7 +930,7 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotW
- if (jsa->isOk())
- {
- ite->annotation().setActionType(1);
-- ite->annotation().setAction(UnicodeParsedString(jsa->getScript()));
-+ ite->annotation().setAction(QString::fromStdString(jsa->getScript()));
- }
- }
- else if (Lact->getKind() == actionGoTo)
-@@ -967,7 +967,7 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotW
- POPPLER_CONST GooString *ndst = gto->getNamedDest();
- if (ndst)
- {
-- LinkDest *dstn = pdfDoc->findDest(ndst);
-+ LinkDest *dstn = pdfDoc->findDest(ndst).get();
- if (dstn)
- {
- if (dstn->getKind() == destXYZ)
-@@ -1019,7 +1019,7 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotW
- POPPLER_CONST GooString *ndst = gto->getNamedDest();
- if (ndst)
- {
-- LinkDest *dstn = pdfDoc->findDest(ndst);
-+ LinkDest *dstn = pdfDoc->findDest(ndst).get();
- if (dstn)
- {
- if (dstn->getKind() == destXYZ)
-@@ -1039,7 +1039,7 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotW
- else if (Lact->getKind() == actionUnknown)
- {
- LinkUnknown *uno = (LinkUnknown*)Lact;
-- QString actString = UnicodeParsedString(uno->getAction());
-+ QString actString = QString::fromStdString(uno->getAction());
- if (actString == "ResetForm")
- {
- ite->annotation().setActionType(4);
-@@ -1083,7 +1083,7 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotW
- {
- LinkNamed *uno = (LinkNamed*)Lact;
- ite->annotation().setActionType(10);
-- ite->annotation().setAction(UnicodeParsedString(uno->getName()));
-+ ite->annotation().setAction(QString::fromStdString(uno->getName()));
- }
- else
- qDebug() << "Found unsupported Action of type" << Lact->getKind();
-@@ -1096,7 +1096,7 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotW
- LinkJavaScript *jsa = (LinkJavaScript*)Aact;
- if (jsa->isOk())
- {
-- ite->annotation().setD_act(UnicodeParsedString(jsa->getScript()));
-+ ite->annotation().setD_act(QString::fromStdString(jsa->getScript()));
- ite->annotation().setAAact(true);
- }
- }
-@@ -1110,7 +1110,7 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotW
- LinkJavaScript *jsa = (LinkJavaScript*)Aact;
- if (jsa->isOk())
- {
-- ite->annotation().setE_act(UnicodeParsedString(jsa->getScript()));
-+ ite->annotation().setE_act(QString::fromStdString(jsa->getScript()));
- ite->annotation().setAAact(true);
- }
- }
-@@ -1124,7 +1124,7 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotW
- LinkJavaScript *jsa = (LinkJavaScript*)Aact;
- if (jsa->isOk())
- {
-- ite->annotation().setX_act(UnicodeParsedString(jsa->getScript()));
-+ ite->annotation().setX_act(QString::fromStdString(jsa->getScript()));
- ite->annotation().setAAact(true);
- }
- }
-@@ -1138,7 +1138,7 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotW
- LinkJavaScript *jsa = (LinkJavaScript*)Aact;
- if (jsa->isOk())
- {
-- ite->annotation().setFo_act(UnicodeParsedString(jsa->getScript()));
-+ ite->annotation().setFo_act(QString::fromStdString(jsa->getScript()));
- ite->annotation().setAAact(true);
- }
- }
-@@ -1152,7 +1152,7 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotW
- LinkJavaScript *jsa = (LinkJavaScript*)Aact;
- if (jsa->isOk())
- {
-- ite->annotation().setBl_act(UnicodeParsedString(jsa->getScript()));
-+ ite->annotation().setBl_act(QString::fromStdString(jsa->getScript()));
- ite->annotation().setAAact(true);
- }
- }
-@@ -1166,7 +1166,7 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotW
- LinkJavaScript *jsa = (LinkJavaScript*)Aact;
- if (jsa->isOk())
- {
-- ite->annotation().setC_act(UnicodeParsedString(jsa->getScript()));
-+ ite->annotation().setC_act(QString::fromStdString(jsa->getScript()));
- ite->annotation().setAAact(true);
- }
- }
-@@ -1180,7 +1180,7 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotW
- LinkJavaScript *jsa = (LinkJavaScript*)Aact;
- if (jsa->isOk())
- {
-- ite->annotation().setF_act(UnicodeParsedString(jsa->getScript()));
-+ ite->annotation().setF_act(QString::fromStdString(jsa->getScript()));
- ite->annotation().setAAact(true);
- ite->annotation().setFormat(5);
- }
-@@ -1195,7 +1195,7 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotW
- LinkJavaScript *jsa = (LinkJavaScript*)Aact;
- if (jsa->isOk())
- {
-- ite->annotation().setK_act(UnicodeParsedString(jsa->getScript()));
-+ ite->annotation().setK_act(QString::fromStdString(jsa->getScript()));
- ite->annotation().setAAact(true);
- ite->annotation().setFormat(5);
- }
-@@ -1210,7 +1210,7 @@ void SlaOutputDev::handleActions(PageItem* ite, AnnotW
- LinkJavaScript *jsa = (LinkJavaScript*)Aact;
- if (jsa->isOk())
- {
-- ite->annotation().setV_act(UnicodeParsedString(jsa->getScript()));
-+ ite->annotation().setV_act(QString::fromStdString(jsa->getScript()));
- ite->annotation().setAAact(true);
- }
- }
-@@ -1224,16 +1224,7 @@ void SlaOutputDev::startDoc(PDFDoc *doc, XRef *xrefA,
- catalog = catA;
- pdfDoc = doc;
- updateGUICounter = 0;
-- m_fontEngine = new SplashFontEngine(
--#if HAVE_T1LIB_H
-- globalParams->getEnableT1lib(),
--#endif
--#if HAVE_FREETYPE_H
-- globalParams->getEnableFreeType(),
-- true,
-- true,
--#endif
-- true);
-+ m_fontEngine = new SplashFontEngine(true, true, true, true);
- }
-
- void SlaOutputDev::startPage(int pageNum, GfxState *, XRef *)
-@@ -2784,7 +2775,7 @@ void SlaOutputDev::drawMaskedImage(GfxState *state, Ob
- delete[] mbuffer;
- }
-
--void SlaOutputDev::drawImage(GfxState *state, Object *ref, Stream *str, int width, int height, GfxImageColorMap *colorMap, GBool interpolate, int *maskColors, GBool inlineImg)
-+void SlaOutputDev::drawImage(GfxState *state, Object *ref, Stream *str, int width, int height, GfxImageColorMap *colorMap, GBool interpolate, const int *maskColors, GBool inlineImg)
- {
- ImageStream * imgStr = new ImageStream(str, width, colorMap->getNumPixelComps(), colorMap->getBits());
- // qDebug() << "Image Components" << colorMap->getNumPixelComps() << "Mask" << maskColors;
-@@ -3365,7 +3356,7 @@ err1:
- fontsrc->unref();
- }
-
--void SlaOutputDev::drawChar(GfxState *state, double x, double y, double dx, double dy, double originX, double originY, CharCode code, int nBytes, Unicode *u, int uLen)
-+void SlaOutputDev::drawChar(GfxState *state, double x, double y, double dx, double dy, double originX, double originY, CharCode code, int nBytes, const Unicode *u, int uLen)
- {
- double x1, y1, x2, y2;
- int render;
-@@ -3452,7 +3443,7 @@ void SlaOutputDev::drawChar(GfxState *state, double x,
- }
- }
-
--GBool SlaOutputDev::beginType3Char(GfxState *state, double x, double y, double dx, double dy, CharCode code, Unicode *u, int uLen)
-+GBool SlaOutputDev::beginType3Char(GfxState *state, double x, double y, double dx, double dy, CharCode code, const Unicode *u, int uLen)
- {
- // qDebug() << "beginType3Char";
- GfxFont *gfxFont;
-@@ -3705,7 +3696,7 @@ QString SlaOutputDev::getAnnotationColor(const AnnotCo
- return fNam;
- }
-
--QString SlaOutputDev::convertPath(GfxPath *path)
-+QString SlaOutputDev::convertPath(const GfxPath *path)
- {
- if (! path)
- return QString();
-@@ -3715,7 +3706,7 @@ QString SlaOutputDev::convertPath(GfxPath *path)
-
- for (int i = 0; i < path->getNumSubpaths(); ++i)
- {
-- GfxSubpath * subpath = path->getSubpath(i);
-+ const GfxSubpath * subpath = path->getSubpath(i);
- if (subpath->getNumPoints() > 0)
- {
- output += QString("M %1 %2").arg(subpath->getX(0)).arg(subpath->getY(0));
diff --git a/print/scribus-devel/files/patch-scribus_plugins_import_pdf_slaoutput.h b/print/scribus-devel/files/patch-scribus_plugins_import_pdf_slaoutput.h
deleted file mode 100644
index 849403c1d0c3..000000000000
--- a/print/scribus-devel/files/patch-scribus_plugins_import_pdf_slaoutput.h
+++ /dev/null
@@ -1,31 +0,0 @@
---- scribus/plugins/import/pdf/slaoutput.h.orig 2020-01-18 17:22:17 UTC
-+++ scribus/plugins/import/pdf/slaoutput.h
-@@ -229,7 +229,7 @@ class SlaOutputDev : public OutputDev (public)
-
- //----- image drawing
- void drawImageMask(GfxState *state, Object *ref, Stream *str, int width, int height, GBool invert, GBool interpolate, GBool inlineImg) override;
-- void drawImage(GfxState *state, Object *ref, Stream *str, int width, int height, GfxImageColorMap *colorMap, GBool interpolate, int *maskColors, GBool inlineImg) override;
-+ void drawImage(GfxState *state, Object *ref, Stream *str, int width, int height, GfxImageColorMap *colorMap, GBool interpolate, const int *maskColors, GBool inlineImg) override;
- void drawSoftMaskedImage(GfxState *state, Object *ref, Stream *str,
- int width, int height,
- GfxImageColorMap *colorMap,
-@@ -261,8 +261,8 @@ class SlaOutputDev : public OutputDev (public)
- //----- text drawing
- void beginTextObject(GfxState *state) override;
- void endTextObject(GfxState *state) override;
-- void drawChar(GfxState *state, double /*x*/, double /*y*/, double /*dx*/, double /*dy*/, double /*originX*/, double /*originY*/, CharCode /*code*/, int /*nBytes*/, Unicode * /*u*/, int /*uLen*/) override;
-- GBool beginType3Char(GfxState * /*state*/, double /*x*/, double /*y*/, double /*dx*/, double /*dy*/, CharCode /*code*/, Unicode * /*u*/, int /*uLen*/) override;
-+ void drawChar(GfxState *state, double /*x*/, double /*y*/, double /*dx*/, double /*dy*/, double /*originX*/, double /*originY*/, CharCode /*code*/, int /*nBytes*/, const Unicode * /*u*/, int /*uLen*/) override;
-+ GBool beginType3Char(GfxState * /*state*/, double /*x*/, double /*y*/, double /*dx*/, double /*dy*/, CharCode /*code*/, const Unicode * /*u*/, int /*uLen*/) override;
- void endType3Char(GfxState * /*state*/) override;
- void type3D0(GfxState * /*state*/, double /*wx*/, double /*wy*/) override;
- void type3D1(GfxState * /*state*/, double /*wx*/, double /*wy*/, double /*llx*/, double /*lly*/, double /*urx*/, double /*ury*/) override;
-@@ -282,7 +282,7 @@ class SlaOutputDev : public OutputDev (public)
- void getPenState(GfxState *state);
- QString getColor(GfxColorSpace *color_space, POPPLER_CONST_070 GfxColor *color, int *shade);
- QString getAnnotationColor(const AnnotColor *color);
-- QString convertPath(GfxPath *path);
-+ QString convertPath(const GfxPath *path);
- int getBlendMode(GfxState *state);
- void applyMask(PageItem *ite);
- void pushGroup(const QString& maskName = "", GBool forSoftMask = gFalse, GBool alpha = gFalse, bool inverted = false);
diff --git a/print/scribus-devel/files/patch-scribus_ui_scresizecursor.cpp b/print/scribus-devel/files/patch-scribus_ui_scresizecursor.cpp
deleted file mode 100644
index d202073707a1..000000000000
--- a/print/scribus-devel/files/patch-scribus_ui_scresizecursor.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- scribus/ui/scresizecursor.cpp.orig 2020-05-29 20:30:14 UTC
-+++ scribus/ui/scresizecursor.cpp
-@@ -12,6 +12,7 @@
-
- #include <QDebug>
- #include <QPainter>
-+#include <QPainterPath>
- #include <QPixmap>
- #include <QPen>
- #include <QBrush>
diff --git a/print/scribus-devel/pkg-plist b/print/scribus-devel/pkg-plist
index 399d2b60daaf..36d386bdbde3 100644
--- a/print/scribus-devel/pkg-plist
+++ b/print/scribus-devel/pkg-plist
@@ -3383,3 +3383,159 @@ share/pixmaps/scribus.png
%%DATADIR%%/icons/1_5_1_dark/22/delete-table-columns.png
%%DATADIR%%/icons/1_5_1_dark/22/delete-table-rows.png
%%DATADIR%%/icons/1_5_1_dark/22/dialog-error.png
+ lib/scribus/plugins/gettext/libMARKDOWNimplugin.so
+ lib/scribus/plugins/libscriptplugin.so
+ %%PORTDOCS%%%%DOCSDIR%%/de/readme_needs_update_please_keep it_in.html
+ %%PORTDOCS%%%%DOCSDIR%%/de/specs_needs_update_please_keep it_in.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/DropShadows.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/EditingShapes.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/SearchReplace.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/TextProp.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/WwFill.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/WwFrames.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/WwImages.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/WwLines.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/WwRenderframes.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/WwShapes.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/WwStyles.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/WwText.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/about1.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/about2.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/add_colors.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/bugreport.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/cli.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/cms.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/collect4output.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/color1.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/color2.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/color3.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/color4.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/color5.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/color6.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/color7a.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/color7b.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/color7c.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/color8.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/color_editing.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/colorwheel.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/config.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/configfiles.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/contributions.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/createlinks.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/docinfo.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/documentation.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/editorial.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/faq1.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/fileproblems.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/fonts1.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/fonts2.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/hyphenator.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/importbitmap1.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/importclipart.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/importhints.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/importhints1.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/importhints2.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/importhints3.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/importhints4.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/importoutput.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/install4.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/keys.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/layers.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/mailing_lists.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/manual.css
+ %%PORTDOCS%%%%DOCSDIR%%/ru/menu.xml
+ %%PORTDOCS%%%%DOCSDIR%%/ru/moncal.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/mouse.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/multiple_transform.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/pagenumber.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/pagetemplate1.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/pdf_form.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/pdfexport1.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/pdfexport2.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/pdfexport3.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/pdfexport4.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/pdfexport_image.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/pdflavor.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/pdfx3.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/print1.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/print2.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/psd.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/qsg.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/readme-haiku.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/readme-win32.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/readme.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/renderframes.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/scribus-svg.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/scripter-extensions.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/scripter-faq.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/scripter1.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/scripter2.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/scripterapi-ImageExport.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/scripterapi-PDFfile.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/scripterapi-Printer.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/scripterapi-color.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/scripterapi-constants.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/scripterapi-dialogs.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/scripterapi-doc.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/scripterapi-extensions.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/scripterapi-font.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/scripterapi-getobjprop.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/scripterapi-images.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/scripterapi-layer.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/scripterapi-lines.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/scripterapi-manobj.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/scripterapi-masterpages.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/scripterapi-object.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/scripterapi-page.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/scripterapi-pdfannotations.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/scripterapi-select.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/scripterapi-setobjprop.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/scripterapi-styles.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/scripterapi-textframes.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/scripterapi.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/settings1.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/short-words.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/specs.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/toolbox12.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/toolbox13.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/toolbox15.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/toolbox19.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/toolbox20.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/toolbox5.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/toolbox8.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/toolbox9.html
+ %%PORTDOCS%%%%DOCSDIR%%/ru/topten.html
+ %%DATADIR%%/icons/1_5_1/fill-rule-even-odd.png
+ %%DATADIR%%/icons/1_5_1/fill-rule-nonzero.png
+ %%DATADIR%%/icons/1_5_1/round-corners.png
+ %%DATADIR%%/samples/3columnA4.py
+ %%DATADIR%%/samples/3columnUSLTR.py
+ %%DATADIR%%/samples/Calender.py
+ %%DATADIR%%/samples/ExtractText.py
+ %%DATADIR%%/samples/Sample1.py
+ %%DATADIR%%/samples/boilerplate.py
+ %%DATADIR%%/samples/golden-mean.py
+ %%DATADIR%%/samples/legende.py
+ %%DATADIR%%/samples/moins_10_pourcent_group.py
+ %%DATADIR%%/samples/plus_10_pourcent_group.py
+ %%DATADIR%%/samples/pochette_cd.py
+ %%DATADIR%%/samples/quote.py
+ %%DATADIR%%/samples/sample_db_usage.py
+ %%DATADIR%%/samples/trait_de_coupe.py
+ %%DATADIR%%/samples/wordcount.py
+ %%DATADIR%%/scripts/Align_image_in_frame.py
+ %%DATADIR%%/scripts/Autoquote.py
+ %%DATADIR%%/scripts/Autoquote2.py
+ %%DATADIR%%/scripts/CalendarWizard.py
+ %%DATADIR%%/scripts/Caption.py
+ %%DATADIR%%/scripts/ColorChart.py
+ %%DATADIR%%/scripts/DirectImageImport.py
+ %%DATADIR%%/scripts/FontSample.py
+ %%DATADIR%%/scripts/InfoBox.py
+ %%DATADIR%%/scripts/Ligatursatz.py
+ %%DATADIR%%/scripts/color2csv.py
+ %%DATADIR%%/scripts/csv2color.py
+ %%DATADIR%%/scripts/importcsv2table.py
+ %%DATADIR%%/translations/scribus.az.qm
+ %%DATADIR%%/translations/scribus.bn_IN.qm
+ %%DATADIR%%/translations/scribus.ms_MY.qm