aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2021-02-16 06:13:21 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2021-02-16 06:13:21 +0000
commit1ad520f4bef3b69cb558ecc120282066a5881241 (patch)
treea4d8f759da1bd7ca5289debcc695e96d85419679 /print
parent2b93417b05416ca4b979cf10d6f7f72697eee6be (diff)
downloadports-1ad520f4bef3b69cb558ecc120282066a5881241.tar.gz
ports-1ad520f4bef3b69cb558ecc120282066a5881241.zip
Add posterazor 1.9.7, cuts an image into pieces which can be printed out
as a poster.
Notes
Notes: svn path=/head/; revision=565382
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/posterazor/Makefile40
-rw-r--r--print/posterazor/distinfo3
-rw-r--r--print/posterazor/files/patch-src_paintcanvas.cpp10
-rw-r--r--print/posterazor/pkg-descr8
5 files changed, 62 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index 4c0d62ff7a07..73e28ac41ff8 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -164,6 +164,7 @@
SUBDIR += pkfonts400
SUBDIR += pkfonts600
SUBDIR += pnm2ppa
+ SUBDIR += posterazor
SUBDIR += print-manager
SUBDIR += ps2eps
SUBDIR += pscal
diff --git a/print/posterazor/Makefile b/print/posterazor/Makefile
new file mode 100644
index 000000000000..2efa0d7c056d
--- /dev/null
+++ b/print/posterazor/Makefile
@@ -0,0 +1,40 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= posterazor
+PORTVERSION= 1.9.7
+DISTVERSIONPREFIX= v
+CATEGORIES= print graphics
+MASTER_SITES= LOCAL/ehaupt:extras
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Cuts an image into pieces which can be printed out as a poster
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= dos2unix gl localbase:ldflags qmake qt:5
+USE_GITHUB= yes
+GH_ACCOUNT= ehaupt
+USE_GL= gl
+USE_QT= core gui printsupport widgets buildtools_build
+
+QMAKE_SOURCE_PATH= ${WRKSRC}/src/posterazor.pro
+
+DESKTOP_ENTRIES= "PosteRazor" \
+ "Make your own poster!" \
+ "${PREFIX}/share/pixmaps/posterazor.xpm" \
+ "posterazor" \
+ "Application;Graphics;" \
+ ""
+
+PLIST_FILES= bin/posterazor \
+ share/pixmaps/posterazor.xpm
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/PosteRazor \
+ ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/icons/${PORTNAME}.xpm \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
+
+.include <bsd.port.mk>
diff --git a/print/posterazor/distinfo b/print/posterazor/distinfo
new file mode 100644
index 000000000000..1fb1791d0b6b
--- /dev/null
+++ b/print/posterazor/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1613429041
+SHA256 (ehaupt-posterazor-v1.9.7_GH0.tar.gz) = a6ffe3dfab63476cfdb1842998ca6faea162fd698382e95b2537405a74dda1db
+SIZE (ehaupt-posterazor-v1.9.7_GH0.tar.gz) = 224399
diff --git a/print/posterazor/files/patch-src_paintcanvas.cpp b/print/posterazor/files/patch-src_paintcanvas.cpp
new file mode 100644
index 000000000000..c506a07016a7
--- /dev/null
+++ b/print/posterazor/files/patch-src_paintcanvas.cpp
@@ -0,0 +1,10 @@
+--- src/paintcanvas.cpp.orig 2021-02-15 21:19:18 UTC
++++ src/paintcanvas.cpp
+@@ -24,6 +24,7 @@
+
+ #include <QImage>
+ #include <QPainter>
++#include <QPainterPath>
+ #include <QVariant>
+
+ PaintCanvas::PaintCanvas(QWidget *parent)
diff --git a/print/posterazor/pkg-descr b/print/posterazor/pkg-descr
new file mode 100644
index 000000000000..7c49574bff62
--- /dev/null
+++ b/print/posterazor/pkg-descr
@@ -0,0 +1,8 @@
+PosteRazor cuts a raster image into pieces which can afterwards be
+printed out and assembled to a poster.
+
+As input, the PosteRazor takes a raster image. The resulting poster is
+saved as a multipage PDF document. An easy to use, wizard like user
+interface guides through 5 steps.
+
+WWW: https://github.com/aportale/posterazor