aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-02-01 19:47:15 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-02-01 19:47:15 +0000
commit2e59383460db7cc227d18fc531b710f3e2be34db (patch)
tree6123b538ef8687e8a206decfb9818dd4cb7b016f /print
parentf4e3f9b5e221a44d82ddbd48be2d9304da070c73 (diff)
downloadports-2e59383460db7cc227d18fc531b710f3e2be34db.tar.gz
ports-2e59383460db7cc227d18fc531b710f3e2be34db.zip
Remove python 2.7 support
Notes
Notes: svn path=/head/; revision=563749
Diffstat (limited to 'print')
-rw-r--r--print/cups-cloud-print/Makefile15
1 files changed, 4 insertions, 11 deletions
diff --git a/print/cups-cloud-print/Makefile b/print/cups-cloud-print/Makefile
index 4523551ca28c..47d5553d2ca3 100644
--- a/print/cups-cloud-print/Makefile
+++ b/print/cups-cloud-print/Makefile
@@ -14,13 +14,14 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= cups-config:print/cups
RUN_DEPENDS= cancel:print/cups \
bash:shells/bash \
- ${PYTHON_PKGNAMEPREFIX}httplib2>0:www/py-httplib2@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}httplib2>0:www/py-httplib2@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pycups>=0:print/py-pycups@${PY_FLAVOR}
USE_GITHUB= yes
GH_ACCOUNT= simoncadman
GH_PROJECT= CUPS-Cloud-Print
-USES= gmake python shebangfix
+USES= gmake python:3.6+ shebangfix
SHEBANG_FILES= testing/*.sh
GNU_CONFIGURE= yes
MAKE_ARGS= NOPERMS=1
@@ -32,14 +33,6 @@ DOCSDIR= ${PREFIX}/share/doc/cloudprint-cups
OPTIONS_DEFINE= DOCS
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_REL} < 3500
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pycups1>=0:print/py-pycups1@${PY_FLAVOR}
-.else
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pycups>=0:print/py-pycups@${PY_FLAVOR}
-.endif
-
post-patch:
@${REINPLACE_CMD} -e \
'/README.md/s|^|#| ; \
@@ -49,4 +42,4 @@ post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>