aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-02-18 16:24:06 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-02-18 16:24:06 +0000
commit493936897aec9ba3b71fcdbd96080bbb539c7de2 (patch)
treefa196deabc610d39d7c81fd2a927117695ce68df /print
parentb65c10c36f2aaef12443ce768396b52d7434698e (diff)
downloadports-493936897aec9ba3b71fcdbd96080bbb539c7de2.tar.gz
ports-493936897aec9ba3b71fcdbd96080bbb539c7de2.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/cups-cloud-print/Makefile25
-rw-r--r--print/cups-cloud-print/distinfo4
-rw-r--r--print/cups-cloud-print/pkg-descr6
-rw-r--r--print/cups-cloud-print/pkg-plist10
4 files changed, 27 insertions, 18 deletions
diff --git a/print/cups-cloud-print/Makefile b/print/cups-cloud-print/Makefile
index e89d98187827..2496f0c82bd5 100644
--- a/print/cups-cloud-print/Makefile
+++ b/print/cups-cloud-print/Makefile
@@ -1,32 +1,33 @@
# $FreeBSD$
PORTNAME= cups-cloud-print
-PORTVERSION= 20140814.1
+PORTVERSION= 20140814.2
CATEGORIES= print
-MASTER_SITES= GH
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Print using Google Cloud Print
LICENSE= GPLv3
BUILD_DEPENDS= cups-config:${PORTSDIR}/print/cups-client
-RUN_DEPENDS= cancel:${PORTSDIR}/print/cups-base \
- ${PYTHON_PKGNAMEPREFIX}cups>0:${PORTSDIR}/print/py-cups \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cups>=0:${PORTSDIR}/print/py-cups \
+ ${PYTHON_PKGNAMEPREFIX}httplib2>=0:${PORTSDIR}/www/py-httplib2 \
bash:${PORTSDIR}/shells/bash \
- ${PYTHON_PKGNAMEPREFIX}httplib2>0:${PORTSDIR}/www/py-httplib2
+ cancel:${PORTSDIR}/print/cups-base
+CONFIGURE_ENV= cupsgroup=cups
+GNU_CONFIGURE= yes
+MAKE_ARGS= NOPERMS=1
NO_ARCH= yes
NO_BUILD= yes
+USES= gmake python shebangfix
+
+SHEBANG_FILES= testing/*.sh
USE_GITHUB= yes
GH_ACCOUNT= simoncadman
+GH_COMMIT= f287aed
GH_PROJECT= CUPS-Cloud-Print
-GH_COMMIT= 65d3bff
-
-USES= gmake python shebangfix
-SHEBANG_FILES= testing/*.sh
-GNU_CONFIGURE= yes
-MAKE_ARGS= NOPERMS=1
+GH_TAGNAME= ${PORTVERSION}
.include <bsd.port.mk>
diff --git a/print/cups-cloud-print/distinfo b/print/cups-cloud-print/distinfo
index c17917c887b9..3b80139c67db 100644
--- a/print/cups-cloud-print/distinfo
+++ b/print/cups-cloud-print/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cups-cloud-print-20140814.1.tar.gz) = d31cdcb2bc5baa2b32c80684b631b5882b77e2f0663c6ba0b8d08539c19ed6d2
-SIZE (cups-cloud-print-20140814.1.tar.gz) = 1260629
+SHA256 (cups-cloud-print-20140814.2.tar.gz) = 5dfb949b4aa70aeeaf0f63345202ce6f422f4ec6cee12dc38fc993e710c942af
+SIZE (cups-cloud-print-20140814.2.tar.gz) = 1286222
diff --git a/print/cups-cloud-print/pkg-descr b/print/cups-cloud-print/pkg-descr
index e08c323188ee..bb79b8336bd7 100644
--- a/print/cups-cloud-print/pkg-descr
+++ b/print/cups-cloud-print/pkg-descr
@@ -1,5 +1,5 @@
-CUPS Cloud Print is a Google Cloud Print driver for UNIX-like operating
-systems. It allows any application which prints via CUPS to print to
-Google Cloud Print directly.
+CUPS Cloud Print is a Google Cloud Print driver for UNIX-like operating systems.
+It allows any application which prints via CUPS to print to Google Cloud Print
+directly.
WWW: http://www.niftiestsoftware.com/cups-cloud-print/
diff --git a/print/cups-cloud-print/pkg-plist b/print/cups-cloud-print/pkg-plist
index 3710b7449fa8..3ec240511760 100644
--- a/print/cups-cloud-print/pkg-plist
+++ b/print/cups-cloud-print/pkg-plist
@@ -11,12 +11,20 @@ share/cloudprint-cups/deleteaccount.py
share/cloudprint-cups/dynamicppd.py
share/cloudprint-cups/listcloudprinters.py
share/cloudprint-cups/oauth2client/__init__.py
-share/cloudprint-cups/oauth2client/anyjson.py
+share/cloudprint-cups/oauth2client/appengine.py
share/cloudprint-cups/oauth2client/client.py
share/cloudprint-cups/oauth2client/clientsecrets.py
share/cloudprint-cups/oauth2client/crypt.py
+share/cloudprint-cups/oauth2client/django_orm.py
+share/cloudprint-cups/oauth2client/file.py
+share/cloudprint-cups/oauth2client/gce.py
+share/cloudprint-cups/oauth2client/keyring_storage.py
share/cloudprint-cups/oauth2client/locked_file.py
share/cloudprint-cups/oauth2client/multistore_file.py
+share/cloudprint-cups/oauth2client/service_account.py
+share/cloudprint-cups/oauth2client/tools.py
+share/cloudprint-cups/oauth2client/util.py
+share/cloudprint-cups/oauth2client/xsrfutil.py
share/cloudprint-cups/printer.py
share/cloudprint-cups/printermanager.py
share/cloudprint-cups/refreshtokens.py