aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2006-05-11 17:26:35 +0000
committerXin LI <delphij@FreeBSD.org>2006-05-11 17:26:35 +0000
commit5496cfb272947f5b07e3cb13a581594920aba81b (patch)
tree0adf643dd5a8e3538bda3d37e83953f147ebb032 /print
parent3fb5ddd6926e5e435a9218f23685ca01b091fc90 (diff)
downloadports-5496cfb272947f5b07e3cb13a581594920aba81b.tar.gz
ports-5496cfb272947f5b07e3cb13a581594920aba81b.zip
Add kpdftool, a tool to ease your PDF related work.
Submitted by: Yuan Jue <yuanjue at yuanjue net> PR: ports/96773 Approved by: mentor (sem)
Notes
Notes: svn path=/head/; revision=162105
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/kpdftool/Makefile32
-rw-r--r--print/kpdftool/distinfo3
-rw-r--r--print/kpdftool/pkg-descr10
4 files changed, 46 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index e5c031545620..fe7c683deac3 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -116,6 +116,7 @@
SUBDIR += kaspaliste
SUBDIR += kcdlabel
SUBDIR += kover
+ SUBDIR += kpdftool
SUBDIR += latex
SUBDIR += latex-arydshln
SUBDIR += latex-auto-greek
diff --git a/print/kpdftool/Makefile b/print/kpdftool/Makefile
new file mode 100644
index 000000000000..c64dc224f3b7
--- /dev/null
+++ b/print/kpdftool/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: kpdftool
+# Date created: 04 May 2006
+# Whom: Yuan, Jue <yuanjue@yuanjue.net>
+# $FreeBSD$
+#
+
+PORTNAME= kpdftool
+PORTVERSION= 0.22
+CATEGORIES= print kde
+MASTER_SITES= http://www.yuanjue.net/download/
+
+MAINTAINER= yuanjue@yuanjue.net
+COMMENT= Tool to ease your PDF related work
+
+BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
+RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick
+
+USE_GMAKE= yes
+USE_QT_VER= 3
+CONFIGURE_ENV= QMAKESPEC=${LOCALBASE}/share/qt/mkspecs/freebsd-g++
+MAKE_ARGS+= QTDIR=${X11BASE}
+
+do-configure:
+ cd ${WRKSRC}; \
+ ${LOCALBASE}/bin/qmake -spec ${LOCALBASE}/share/qt/mkspecs/freebsd-g++ ${PORTNAME}.pro;
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+PLIST_FILES= bin/kpdftool
+
+.include <bsd.port.mk>
diff --git a/print/kpdftool/distinfo b/print/kpdftool/distinfo
new file mode 100644
index 000000000000..a3f49547c74a
--- /dev/null
+++ b/print/kpdftool/distinfo
@@ -0,0 +1,3 @@
+MD5 (kpdftool-0.22.tar.gz) = 90dbd5d64de4df7aedef264efa1885d5
+SHA256 (kpdftool-0.22.tar.gz) = 0300453cf54dcafc45f383bf3ad3e9f3f5a57a4795472df546a34b77214eac63
+SIZE (kpdftool-0.22.tar.gz) = 5521
diff --git a/print/kpdftool/pkg-descr b/print/kpdftool/pkg-descr
new file mode 100644
index 000000000000..fa41247497f6
--- /dev/null
+++ b/print/kpdftool/pkg-descr
@@ -0,0 +1,10 @@
+KPDFTool is a GUI interface for GhostView/KGhostview and
+ImageMagick to perform basic and useful operations
+with PDF and PS (PostScript) files such as merging or
+extracting pages, as well as protecting the text from
+copying into new files in a simple and practical way.
+
+WWW: http://www.kde-apps.org/content/show.php?content=33194
+
+- Yuan, Jue
+yuanjue@yuanjue.net