aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2013-08-05 10:32:31 +0000
committerChris Rees <crees@FreeBSD.org>2013-08-05 10:32:31 +0000
commit6cc4f5292cc7a442ed7abcb4c15302472e7f0745 (patch)
treeed347b5d3822e0d5dcb1809c10f5c61e1241255b /print
parent54575bcb911ac670d358c332f0e9ca7e13423516 (diff)
downloadports-6cc4f5292cc7a442ed7abcb4c15302472e7f0745.tar.gz
ports-6cc4f5292cc7a442ed7abcb4c15302472e7f0745.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/cups-base/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/print/cups-base/Makefile b/print/cups-base/Makefile
index 65505ba501ea..4ebc356f6bc2 100644
--- a/print/cups-base/Makefile
+++ b/print/cups-base/Makefile
@@ -21,6 +21,7 @@ UNIQUENAME= ${PORTNAME}${PKGNAMESUFFIX}
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
+INSTALLS_ICONS= yes
CFLAGS+= ${PTHREAD_CFLAGS}
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -148,7 +149,7 @@ PLIST_SUB+= PHP="@comment "
.if !defined(CUPS_CLIENT) && !defined(CUPS_IMAGE) && ${PORT_OPTIONS:MGHOSTSCRIPT}
.if ${PORT_OPTIONS:MXPDF}
-IGNORE= you must select one and only one option to build pdftops
+IGNORE= You must select one and only one option to build pdftops
.endif
USE_GHOSTSCRIPT= yes
CONFIGURE_ARGS+= --enable-pdftops --with-pdftops=${LOCALBASE}/bin/gs
@@ -175,7 +176,7 @@ LIB_DEPENDS+= paper:${PORTSDIR}/print/libpaper
.if !defined(CUPS_CLIENT) && !defined(CUPS_IMAGE) && ${PORT_OPTIONS:MMDNSRESPONDER}
.if ${PORT_OPTIONS:MAVAHI}
-IGNORE= you must select one and only one option to build for Zeroconf
+IGNORE= You must select one and only one option to build for Zeroconf
.endif
LIB_DEPENDS+= dns_sd:${PORTSDIR}/net/mDNSResponder
CONFIGURE_ARGS+= --with-dnssd-includes=${LOCALBASE}/include
@@ -231,7 +232,7 @@ CONFIGURE_ARGS+= LIBS="-lssp_nonshared"
MAN1= cups-config.1
.elif defined(CUPS_IMAGE)
.else
-MAN1= cancel.1 \
+MAN1+= cancel.1 \
cupstestdsc.1 \
cupstestppd.1 \
ipptool.1 \
@@ -387,7 +388,7 @@ post-install:
.if ${PORT_OPTIONS:MGHOSTSCRIPT} || ${PORT_OPTIONS:MXPDF}
${INSTALL_PROGRAM} ${WRKSRC}/filter/pdftops ${PREFIX}/libexec/cups/filter/
.endif
- ${LN} -s ${PREFIX}/bin/lpr ${PREFIX}/bin/lpr-cups
+ ${LN} -sf ${PREFIX}/bin/lpr ${PREFIX}/bin/lpr-cups
${INSTALL} -d ${CUPS_ETCDIR}/
${CP} -p ${WRKSRC}/conf/snmp.conf ${WRKSRC}/conf/snmp.conf.N
.for f in cupsd.conf mime.convs mime.types snmp.conf