aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2013-05-21 08:02:48 +0000
committerHiroki Sato <hrs@FreeBSD.org>2013-05-21 08:02:48 +0000
commit742627e2e155f1bfcc2d48af567970a3d7e952f0 (patch)
tree9c558b20f7de82c1cad1609109701b57778c7982 /print
parente8ee385588a3a74b8afad7780f69e0521262c8f8 (diff)
downloadports-742627e2e155f1bfcc2d48af567970a3d7e952f0.tar.gz
ports-742627e2e155f1bfcc2d48af567970a3d7e952f0.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/passivetex/Makefile69
-rw-r--r--print/passivetex/files/pkg-message.in (renamed from print/passivetex/pkg-message)0
-rw-r--r--print/passivetex/pkg-descr2
-rw-r--r--print/passivetex/pkg-plist52
4 files changed, 28 insertions, 95 deletions
diff --git a/print/passivetex/Makefile b/print/passivetex/Makefile
index 4ba245f73610..d5e32c3626a1 100644
--- a/print/passivetex/Makefile
+++ b/print/passivetex/Makefile
@@ -1,50 +1,31 @@
-# New ports collection makefile for: passivetex
-# Date created: 9 May 2002
-# Whom: Nik Clayton <nik@FreeBSD.org>
-#
+# Created by: Nik Clayton <nik@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= passivetex
PORTVERSION= 1.24
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= print
-MASTER_SITES= http://www.tei-c.org/Software/passivetex/
+MASTER_SITES= http://projects.oucs.ox.ac.uk/passivetex/
DISTNAME= ${PORTNAME}
DIST_SUBDIR= ${PORTNAME}
MAINTAINER= hrs@FreeBSD.org
COMMENT= XSL FO processor, written in TeX
-BUILD_DEPENDS= ${LOCALBASE}/${TEXMFLOCAL}/web2c/xmltex.fmt:${PORTSDIR}/print/xmltex \
- ${TEXMFLOCAL_LSR}:${PORTSDIR}/print/tex-texmflocal
-RUN_DEPENDS:= ${BUILD_DEPENDS}
-
NO_BUILD= yes
USE_ZIP= yes
+USE_TEX= tetex xmltex texhash
+TEXHASHDIRS= ${TEXMFDIR}
WRKSRC= ${WRKDIR}/passivetex
-MAKE_ENV= TEXMFCNF=${FILESDIR}:${LOCALBASE}/share/texmf/web2c
-
-MESSAGE= ${PKGDIR}/pkg-message
+MAKE_ENV= TEXMFCNF=${FILESDIR}:${LOCALBASE}/${TEXMFDIR}/web2c
+SUB_FILES= pkg-message
+SUB_LIST= TEXMFDIR=${TEXMFDIR}
+PLIST_SUB= CLASSDIR=${CLASSDIR}
PKGMESSAGE= ${WRKDIR}/pkg-message
-.include <bsd.port.pre.mk>
-
-PLIST_SUB= MKTEXLSR=${MKTEXLSR} CLASSDIR=${CLASSDIR}
-
-TEXMFLOCAL= share/texmf-local
-TEXMFLOCAL_LSR= ${LOCALBASE}/${TEXMFLOCAL}/ls-R
-MKTEXLSR= ${LOCALBASE}/bin/mktexlsr
-
-CLASSDIR= ${TEXMFLOCAL}/tex/passivetex
-CLASS_FILES= dummyels.sty fotex.xmt fotex.sty \
- mlnames.sty ucharacters.sty unicode.sty \
- dummyels.sty nomulticol.sty
-
-DOC_FILES= LICENSE README.passivetex index.html index.xml
+PORTDOCS= LICENSE README.passivetex index.html index.xml
-TESTDIR= ${DOCSDIR}/test
-TEST_FILES= Makefile chap01.xml chap02.xml chap03.xml chap04.xml \
+EXAMPLES= Makefile chap01.xml chap02.xml chap03.xml chap04.xml \
check.xsl darkness.fo darkness.pdf darkness.xml darkness.xsl \
exercise-print.xsl exercise.fo exercise.pdf exercise.xml \
fezziPic.png fotex.cfg.eg hyperref.cfg \
@@ -55,22 +36,26 @@ TEST_FILES= Makefile chap01.xml chap02.xml chap03.xml chap04.xml \
teimath2.xml teiu5-print.xsl teiu5.fo teiu5.pdf teiu5.xml \
teixlite.dtd teixml.cfg test1.fot test2.fot
-post-patch:
- @${SED} -e 's,%%TEXMFDIR%%,${LOCALBASE}/share/texmf,' \
- ${MESSAGE} > ${PKGMESSAGE}
+CLASSDIR= ${TEXMFDIR}/tex/passivetex
+CLASS_FILES= dummyels.sty fotex.xmt fotex.sty \
+ mlnames.sty ucharacters.sty unicode.sty \
+ dummyels.sty nomulticol.sty
+
+.include <bsd.port.options.mk>
do-install:
- ${MKDIR} -m 555 ${PREFIX}/${CLASSDIR}
- ${INSTALL_DATA} ${CLASS_FILES:S@^@${WRKSRC}/@} ${PREFIX}/${CLASSDIR}
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${DOC_FILES:S@^@${WRKSRC}/@} ${DOCSDIR}
- ${MKDIR} ${TESTDIR}
- ${INSTALL_DATA} ${TEST_FILES:S@^@${WRKSRC}/test/@} ${TESTDIR}
+ @${MKDIR} -m 555 ${PREFIX}/${CLASSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${CLASS_FILES} ${PREFIX}/${CLASSDIR}
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${EXAMPLESDIR}
+ cd ${WRKSRC}/test && ${INSTALL_DATA} ${PORTEXAMPLES} ${EXAMPLESDIR}
+.endif
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
post-install:
- ${MKTEXLSR}
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/print/passivetex/pkg-message b/print/passivetex/files/pkg-message.in
index cf3479547ea8..cf3479547ea8 100644
--- a/print/passivetex/pkg-message
+++ b/print/passivetex/files/pkg-message.in
diff --git a/print/passivetex/pkg-descr b/print/passivetex/pkg-descr
index 8062396e3f67..069a97cab4b5 100644
--- a/print/passivetex/pkg-descr
+++ b/print/passivetex/pkg-descr
@@ -7,4 +7,4 @@ For example, to generate a PDF file from an FO file, run
pdftex --interaction nonstopmode "&pdfxmltex" file.fo
-WWW: http://www.tei-c.org.uk/Software/passivetex/
+WWW: http://projects.oucs.ox.ac.uk/passivetex/
diff --git a/print/passivetex/pkg-plist b/print/passivetex/pkg-plist
index 1762855de882..885b6f44efea 100644
--- a/print/passivetex/pkg-plist
+++ b/print/passivetex/pkg-plist
@@ -1,54 +1,4 @@
@comment $FreeBSD$
-%%PORTDOCS%%%%DOCSDIR%%/test/Makefile
-%%PORTDOCS%%%%DOCSDIR%%/test/chap01.xml
-%%PORTDOCS%%%%DOCSDIR%%/test/chap02.xml
-%%PORTDOCS%%%%DOCSDIR%%/test/chap03.xml
-%%PORTDOCS%%%%DOCSDIR%%/test/chap04.xml
-%%PORTDOCS%%%%DOCSDIR%%/test/check.xsl
-%%PORTDOCS%%%%DOCSDIR%%/test/darkness.fo
-%%PORTDOCS%%%%DOCSDIR%%/test/darkness.pdf
-%%PORTDOCS%%%%DOCSDIR%%/test/darkness.xml
-%%PORTDOCS%%%%DOCSDIR%%/test/darkness.xsl
-%%PORTDOCS%%%%DOCSDIR%%/test/exercise-print.xsl
-%%PORTDOCS%%%%DOCSDIR%%/test/exercise.fo
-%%PORTDOCS%%%%DOCSDIR%%/test/exercise.pdf
-%%PORTDOCS%%%%DOCSDIR%%/test/exercise.xml
-%%PORTDOCS%%%%DOCSDIR%%/test/fezziPic.png
-%%PORTDOCS%%%%DOCSDIR%%/test/fotex.cfg.eg
-%%PORTDOCS%%%%DOCSDIR%%/test/hyperref.cfg
-%%PORTDOCS%%%%DOCSDIR%%/test/mathex.xml
-%%PORTDOCS%%%%DOCSDIR%%/test/mathex.xsl
-%%PORTDOCS%%%%DOCSDIR%%/test/mathml.xsl
-%%PORTDOCS%%%%DOCSDIR%%/test/mathtei.dtd
-%%PORTDOCS%%%%DOCSDIR%%/test/novel.dtd
-%%PORTDOCS%%%%DOCSDIR%%/test/phys332-1.jpg
-%%PORTDOCS%%%%DOCSDIR%%/test/phys332-2.jpg
-%%PORTDOCS%%%%DOCSDIR%%/test/rmsd.xml
-%%PORTDOCS%%%%DOCSDIR%%/test/tei-oucs.dtd
-%%PORTDOCS%%%%DOCSDIR%%/test/tei.sty
-%%PORTDOCS%%%%DOCSDIR%%/test/teimath-print.xsl
-%%PORTDOCS%%%%DOCSDIR%%/test/teimath.aux
-%%PORTDOCS%%%%DOCSDIR%%/test/teimath.fo
-%%PORTDOCS%%%%DOCSDIR%%/test/teimath.log
-%%PORTDOCS%%%%DOCSDIR%%/test/teimath.out
-%%PORTDOCS%%%%DOCSDIR%%/test/teimath.pdf
-%%PORTDOCS%%%%DOCSDIR%%/test/teimath.xml
-%%PORTDOCS%%%%DOCSDIR%%/test/teimath.xsl
-%%PORTDOCS%%%%DOCSDIR%%/test/teimath2.xml
-%%PORTDOCS%%%%DOCSDIR%%/test/teiu5-print.xsl
-%%PORTDOCS%%%%DOCSDIR%%/test/teiu5.fo
-%%PORTDOCS%%%%DOCSDIR%%/test/teiu5.pdf
-%%PORTDOCS%%%%DOCSDIR%%/test/teiu5.xml
-%%PORTDOCS%%%%DOCSDIR%%/test/teixlite.dtd
-%%PORTDOCS%%%%DOCSDIR%%/test/teixml.cfg
-%%PORTDOCS%%%%DOCSDIR%%/test/test1.fot
-%%PORTDOCS%%%%DOCSDIR%%/test/test2.fot
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/test
-%%PORTDOCS%%%%DOCSDIR%%/LICENSE
-%%PORTDOCS%%%%DOCSDIR%%/README.passivetex
-%%PORTDOCS%%%%DOCSDIR%%/index.html
-%%PORTDOCS%%%%DOCSDIR%%/index.xml
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
%%CLASSDIR%%/dummyels.sty
%%CLASSDIR%%/fotex.xmt
%%CLASSDIR%%/fotex.sty
@@ -57,5 +7,3 @@
%%CLASSDIR%%/unicode.sty
%%CLASSDIR%%/nomulticol.sty
@dirrm %%CLASSDIR%%
-@exec %%MKTEXLSR%%
-@unexec %%MKTEXLSR%%