aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
commit7887c684adab042fed1bfcba2e91589ecd17c4a8 (patch)
tree961839899dce7f75292a08c079f548973bdbd40d /print
parent85544f2c01be814e0af1ebee1076012e7ed60bb0 (diff)
downloadports-7887c684adab042fed1bfcba2e91589ecd17c4a8.tar.gz
ports-7887c684adab042fed1bfcba2e91589ecd17c4a8.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/freetype2/Makefile2
-rw-r--r--print/gnome-cups-manager/Makefile6
-rw-r--r--print/libgnomecups/Makefile11
-rw-r--r--print/libgnomecups/files/patch-libgnomecups_gnome-cups-i18n.c9
-rw-r--r--print/libgnomecups/files/patch-libgnomecups_gnome-cups-init.h12
-rw-r--r--print/p5-Font-FreeType/Makefile1
-rw-r--r--print/ttf2pt1/Makefile8
7 files changed, 35 insertions, 14 deletions
diff --git a/print/freetype2/Makefile b/print/freetype2/Makefile
index f23f41e39f93..4b78b5f1f0f8 100644
--- a/print/freetype2/Makefile
+++ b/print/freetype2/Makefile
@@ -23,7 +23,7 @@ MAKE_JOBS_SAFE= yes
MAKE_ENV= TOP=""
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-USE_GNOME= pkgconfig ltverhack:9
+USE_GNOME= ltverhack:9
LIBTOOLFILES= builds/unix/configure
CONFIGURE_WRKSRC= ${WRKSRC}/builds/unix
diff --git a/print/gnome-cups-manager/Makefile b/print/gnome-cups-manager/Makefile
index 6870baa9015b..3b40b565f9ab 100644
--- a/print/gnome-cups-manager/Makefile
+++ b/print/gnome-cups-manager/Makefile
@@ -40,6 +40,12 @@ post-patch:
's|-D.*_DISABLE_DEPRECATED||g'
@${REINPLACE_CMD} -e 's|/usr/share|${LOCALBASE}/share|g' \
${WRKSRC}/libgnomecups/gnome-cups-ui-driver.c
+ @${REINPLACE_CMD} -e 's|glib/gmacros.h>|glib.h>|g' \
+ -e 's|glib/gstrfuncs.h>|glib.h>|g' \
+ ${WRKSRC}/libgnomecups/gnome-cups-ui-init.h \
+ ${WRKSRC}/libgnomecups/gnome-cups-ui-print.h \
+ ${WRKSRC}/libgnomecups/gnome-cups-i18n.c \
+ ${WRKSRC}/libgnomecups/gnome-cups-ui-driver.c
post-install:
${MKDIR} ${PREFIX}/share/applications
diff --git a/print/libgnomecups/Makefile b/print/libgnomecups/Makefile
index c825b3d33126..9c7bc4a6f47f 100644
--- a/print/libgnomecups/Makefile
+++ b/print/libgnomecups/Makefile
@@ -1,13 +1,9 @@
-# New ports collection makefile for: libgnomecups
-# Date created: 14 Jul 2003
-# Whom: Glenn Johnson <glennpj@charter.net>
-#
+# Created by: Glenn Johnson <glennpj@charter.net>
# $FreeBSD$
-#
PORTNAME= libgnomecups
PORTVERSION= 0.2.3
-PORTREVISION= 4
+PORTREVISION= 5
PORTEPOCH= 1
CATEGORIES= print gnome
MASTER_SITES= GNOME
@@ -16,11 +12,12 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Support library for gnome cups administration
-LIB_DEPENDS= cups.2:${PORTSDIR}/print/cups-client
+LIB_DEPENDS= cups:${PORTSDIR}/print/cups-client
USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= gnomehack intlhack ltverhack glib20
+USE_PKGCONFIG= build
USE_GETTEXT= yes
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool
diff --git a/print/libgnomecups/files/patch-libgnomecups_gnome-cups-i18n.c b/print/libgnomecups/files/patch-libgnomecups_gnome-cups-i18n.c
new file mode 100644
index 000000000000..bfe8c876b34e
--- /dev/null
+++ b/print/libgnomecups/files/patch-libgnomecups_gnome-cups-i18n.c
@@ -0,0 +1,9 @@
+--- libgnomecups/gnome-cups-i18n.c.orig 2012-06-07 10:55:30.000000000 +0200
++++ libgnomecups/gnome-cups-i18n.c 2012-06-07 10:55:37.000000000 +0200
+@@ -1,5 +1,5 @@
+ #include <config.h>
+-#include <glib/gmacros.h>
++#include <glib.h>
+ #include "gnome-cups-i18n.h"
+
+ #ifdef ENABLE_NLS
diff --git a/print/libgnomecups/files/patch-libgnomecups_gnome-cups-init.h b/print/libgnomecups/files/patch-libgnomecups_gnome-cups-init.h
new file mode 100644
index 000000000000..688ddc36c315
--- /dev/null
+++ b/print/libgnomecups/files/patch-libgnomecups_gnome-cups-init.h
@@ -0,0 +1,12 @@
+--- libgnomecups/gnome-cups-init.h.orig 2012-06-07 10:56:20.000000000 +0200
++++ libgnomecups/gnome-cups-init.h 2012-06-07 10:56:30.000000000 +0200
+@@ -1,8 +1,7 @@
+ #ifndef GNOME_CUPS_INIT
+ #define GNOME_CUPS_INIT
+
+-#include <glib/gtypes.h>
+-#include <glib/gmacros.h>
++#include <glib.h>
+
+ G_BEGIN_DECLS
+
diff --git a/print/p5-Font-FreeType/Makefile b/print/p5-Font-FreeType/Makefile
index 3ea18c298ae3..39d1b376606e 100644
--- a/print/p5-Font-FreeType/Makefile
+++ b/print/p5-Font-FreeType/Makefile
@@ -17,6 +17,7 @@ COMMENT= Perl extension to read font files and render glyphs using FreeType2
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
PERL_CONFIGURE= yes
+USE_PKGCONFIG= build
MAN3= Font::FreeType.3 \
Font::FreeType::Face.3 \
diff --git a/print/ttf2pt1/Makefile b/print/ttf2pt1/Makefile
index 0adb4163a0e9..4d8c4d3cbf8f 100644
--- a/print/ttf2pt1/Makefile
+++ b/print/ttf2pt1/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# New ports collection makefile for: ttf2pt1
-# Date created: Aug 11, 2001
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= ttf2pt1
PORTVERSION= 3.4.4
@@ -19,6 +14,7 @@ COMMENT= True Type Font to Postscript Type 1 Converter
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
RUN_DEPENDS= t1asm:${PORTSDIR}/print/t1utils
+USE_PKGCONFIG= build
USE_PERL5= yes
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} ${CPPFLAGS}" LIBS="${LDFLAGS}" \
INSTDIR="${PREFIX}" LIBXDIR="${PREFIX}/bin"