aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2021-02-26 16:08:09 +0000
committerMark Linimon <linimon@FreeBSD.org>2021-02-26 16:08:09 +0000
commitcbb5b58fa3bf33fa71c0b13145cb9005d78228f1 (patch)
tree538f86d96a5bc96a02f26092cd2b3054c6a3150d /print
parent7cd0252d245bff7d9876f12e7333ca196a920d20 (diff)
downloadports-cbb5b58fa3bf33fa71c0b13145cb9005d78228f1.tar.gz
ports-cbb5b58fa3bf33fa71c0b13145cb9005d78228f1.zip
Add compiler:c++11-lang to USES to fix build on GCC-based systems:
CMake Error in CMakeLists.txt: The compiler feature "cxx_decltype" is not known to CXX compiler "GNU" version 4.2.1. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=566612
Diffstat (limited to 'print')
-rw-r--r--print/limereport/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/print/limereport/Makefile b/print/limereport/Makefile
index 17dcbafd05bf..fd3703dfa1a1 100644
--- a/print/limereport/Makefile
+++ b/print/limereport/Makefile
@@ -11,7 +11,7 @@ COMMENT= Multi-platform C++ report generator library written using Qt framework
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= cmake dos2unix gl qt:5
+USES= cmake compiler:c++11-lang dos2unix gl qt:5
USE_QT+= buildtools_build core gui script sql xml svg quickcontrols2 \
printsupport uitools network widgets declarative qmake_build
USE_GL= gl