aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2013-02-26 15:10:29 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2013-02-26 15:10:29 +0000
commitd5296efa63aeceaddcb1ba0c6bba07538cd05a7a (patch)
treef3ff515d6347e82db06a199ce513f0690d9cca22 /print
parent09e55c96c0454ed8716c81f53b18d41d72b3db39 (diff)
downloadports-d5296efa63aeceaddcb1ba0c6bba07538cd05a7a.tar.gz
ports-d5296efa63aeceaddcb1ba0c6bba07538cd05a7a.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/photoprint/Makefile39
-rw-r--r--print/photoprint/distinfo2
-rw-r--r--print/photoprint/pkg-descr4
-rw-r--r--print/photoprint/pkg-plist36
5 files changed, 82 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index d9bef38085d6..7a3f6b841b9d 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -229,6 +229,7 @@
SUBDIR += pecl-pdflib
SUBDIR += pecl-ps
SUBDIR += pfbtopfa
+ SUBDIR += photoprint
SUBDIR += phppdflib
SUBDIR += pic2fig
SUBDIR += pkfonts118
diff --git a/print/photoprint/Makefile b/print/photoprint/Makefile
new file mode 100644
index 000000000000..8f0137fffc88
--- /dev/null
+++ b/print/photoprint/Makefile
@@ -0,0 +1,39 @@
+# $FreeBSD$
+
+PORTNAME= photoprint
+DISTVERSION= 0.4.2-pre2
+CATEGORIES= print graphics
+MASTER_SITES= http://www.blackfiveimaging.co.uk/photoprint/
+#DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= bsam@FreeBSD.org
+COMMENT= Utility to print multiple images per sheet
+
+LIB_DEPENDS= cups:${PORTSDIR}/print/cups-client \
+ expat:${PORTSDIR}/textproc/expat2 \
+ gdk_pixbuf-2.0:${PORTSDIR}/graphics/gdk-pixbuf2 \
+ gutenprint:${PORTSDIR}/print/gutenprint \
+ lcms:${PORTSDIR}/graphics/lcms \
+ netpbm:${PORTSDIR}/graphics/netpbm \
+ pcre:${PORTSDIR}/devel/pcre \
+ pcre:${PORTSDIR}/devel/pcre \
+ pixman:${PORTSDIR}/x11/pixman \
+ png15:${PORTSDIR}/graphics/png \
+ pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
+ tiff:${PORTSDIR}/graphics/tiff \
+ xcb:${PORTSDIR}/x11/libxcb
+
+LICENCE= GPLv2
+
+USE_GETTEXT= yes
+HAS_CONFIGURE= yes
+INSTALLS_ICONS= yes
+CONFIGURE_ARGS+=LDFLAGS=-L/usr/local/lib
+USE_GNOME= desktopfileutils pango
+USE_XORG= x11 xau xcomposite xcursor xdamage xdmcp xext \
+ xfixes xi xinerama xrandr xrender
+
+post-install:
+ -@update-desktop-database
+
+.include <bsd.port.mk>
diff --git a/print/photoprint/distinfo b/print/photoprint/distinfo
new file mode 100644
index 000000000000..dc2c636bfec0
--- /dev/null
+++ b/print/photoprint/distinfo
@@ -0,0 +1,2 @@
+SHA256 (photoprint-0.4.2-pre2.tar.gz) = d7fdaac4928083c499164ca676fe08eac5d9f4c8763309af03b6a2a3c53dab7d
+SIZE (photoprint-0.4.2-pre2.tar.gz) = 2002424
diff --git a/print/photoprint/pkg-descr b/print/photoprint/pkg-descr
new file mode 100644
index 000000000000..b3288dab1d1c
--- /dev/null
+++ b/print/photoprint/pkg-descr
@@ -0,0 +1,4 @@
+PhotoPrint is a utility to print multiple images per sheet, using
+Gutenprint, with support for 16-bit images and ICC profiles.
+
+WWW: http://blackfiveimaging.co.uk
diff --git a/print/photoprint/pkg-plist b/print/photoprint/pkg-plist
new file mode 100644
index 000000000000..95386c1a56ce
--- /dev/null
+++ b/print/photoprint/pkg-plist
@@ -0,0 +1,36 @@
+bin/photoprint
+share/applications/fotoprint.desktop
+share/icons/hicolor/48x48/apps/fotoprint.png
+share/locale/cs/LC_MESSAGES/photoprint.mo
+share/locale/da/LC_MESSAGES/photoprint.mo
+share/locale/de/LC_MESSAGES/photoprint.mo
+share/locale/es/LC_MESSAGES/photoprint.mo
+share/locale/fr/LC_MESSAGES/photoprint.mo
+share/locale/nl/LC_MESSAGES/photoprint.mo
+share/locale/pl/LC_MESSAGES/photoprint.mo
+share/locale/pt/LC_MESSAGES/photoprint.mo
+share/locale/pt_BR/LC_MESSAGES/photoprint.mo
+share/locale/ru/LC_MESSAGES/photoprint.mo
+%%DATADIR%%/borders/licence.txt
+%%DATADIR%%/borders/Flaky.tif
+%%DATADIR%%/borders/HeartsLandscape.tif
+%%DATADIR%%/borders/SoftRectangle.tif
+%%DATADIR%%/borders/Vignette.tif
+%%DATADIR%%/borders/GentleRipple.tif
+%%DATADIR%%/borders/HeartsPortrait.tif
+%%DATADIR%%/borders/Sponged.tif
+%%DATADIR%%/shortcuts/profiling/A4Profiling.preset
+%%DATADIR%%/shortcuts/profiling/LetterProfiling.preset
+%%DATADIR%%/shortcuts/size/A4-10x8-1up.preset
+%%DATADIR%%/shortcuts/size/Letter-8x6-1up.preset
+%%DATADIR%%/shortcuts/size/A4-7x5-2up.preset
+%%DATADIR%%/shortcuts/size/Letter-10x8-1up.preset
+%%DATADIR%%/shortcuts/size/A4-8x6-1up.preset
+%%DATADIR%%/shortcuts/size/Letter-7x5-2up.preset
+@dirrm %%DATADIR%%/shortcuts/profiling
+@dirrm %%DATADIR%%/shortcuts/size
+@dirrm %%DATADIR%%/shortcuts
+@dirrm %%DATADIR%%/borders
+@dirrm %%DATADIR%%
+@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true