aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorAndreas Klemm <andreas@FreeBSD.org>2000-09-11 19:07:36 +0000
committerAndreas Klemm <andreas@FreeBSD.org>2000-09-11 19:07:36 +0000
commitd8a523e701d73c1ffc49eb39884fd192e02a7512 (patch)
tree2f9c78abcc63b32862a171c02f33dbeac823a204 /print
parentc7945503dffc1c1683ef00681efba8848535db5d (diff)
downloadports-d8a523e701d73c1ffc49eb39884fd192e02a7512.tar.gz
ports-d8a523e701d73c1ffc49eb39884fd192e02a7512.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/ghostscript-gnu/Makefile20
-rw-r--r--print/ghostscript55/Makefile20
-rw-r--r--print/ghostscript7/Makefile20
3 files changed, 24 insertions, 36 deletions
diff --git a/print/ghostscript-gnu/Makefile b/print/ghostscript-gnu/Makefile
index 34bcf6b62370..e5476b2dda13 100644
--- a/print/ghostscript-gnu/Makefile
+++ b/print/ghostscript-gnu/Makefile
@@ -11,15 +11,16 @@ CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_GNU} \
ftp://ftp.cs.wisc.edu/ghost/gnu/gs550/ \
ftp://ftp.cs.wisc.edu/ghost/gnu/fonts/ \
+ http://www.ozemail.com.au/~geoffk/pdfencrypt/ \
http://www.erdw.ethz.ch/~bonk/ftp/gs-driver-distrib/
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTFILES= ${GS_SOURCES} ${GS_FONTS_STD} ${GS_FONTS_OTHER} \
- ${HP850_DRV}
+ ${DECRYPT_PDF} ${HP850_DRV}
EXTRACT_ONLY= ${GS_SOURCES}
MAINTAINER= andreas@FreeBSD.org
-BUILD_DEPENDS= /nonexistent:${PORTSDIR}/graphics/jpeg:extract \
+BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/graphics/jpeg:extract \
unzip:${PORTSDIR}/archivers/unzip
LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png
@@ -41,6 +42,9 @@ GS_FONTS_OTHER= gnu-gs-fonts-other-6.0.tar.gz
# Additional driver HP 850, see http://www.erdw.ethz.ch/~bonk/hp850/hp850.html
HP850_DRV= hp8xxs13.zip
+# replacement for pdf_sec.ps, that allows you to read encrypted PDF files
+DECRYPT_PDF= pdf_sec.ps
+
.if defined(A4)
CFLAGS+= -DA4
.endif
@@ -76,19 +80,11 @@ post-install:
strip ${PREFIX}/bin/gs
${INSTALL_SCRIPT} ${WRKSRC}/unix-lpr.sh ${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/lprsetup.sh ${PREFIX}/bin
+ ${INSTALL_DATA} ${DISTDIR}/pdf_sec.ps \
+ ${PREFIX}/share/ghostscript/5.50
${INSTALL_DATA} ${WRKSRC}/license.hp8 \
${PREFIX}/share/ghostscript/5.50/doc
${INSTALL_DATA} ${WRKSRC}/readme.hp8 \
${PREFIX}/share/ghostscript/5.50/doc
-.if defined(PDFENCRYPT)
- ${INSTALL_DATA} ${DISTDIR}/pdf_sec.ps ${PREFIX}/share/ghostscript/5.50
-.endif
-
-# encrypted PDF support. can't be packaged due to export control issues.
-.if defined(PDFENCRYPT)
-MASTER_SITES+= http://www.ozemail.com.au/~geoffk/pdfencrypt/
-DISTFILES+= pdf_sec.ps
-RESTRICTED= "Crypto; export controlled, RC4 in PostScript code included"
-.endif
.include <bsd.port.mk>
diff --git a/print/ghostscript55/Makefile b/print/ghostscript55/Makefile
index 34bcf6b62370..e5476b2dda13 100644
--- a/print/ghostscript55/Makefile
+++ b/print/ghostscript55/Makefile
@@ -11,15 +11,16 @@ CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_GNU} \
ftp://ftp.cs.wisc.edu/ghost/gnu/gs550/ \
ftp://ftp.cs.wisc.edu/ghost/gnu/fonts/ \
+ http://www.ozemail.com.au/~geoffk/pdfencrypt/ \
http://www.erdw.ethz.ch/~bonk/ftp/gs-driver-distrib/
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTFILES= ${GS_SOURCES} ${GS_FONTS_STD} ${GS_FONTS_OTHER} \
- ${HP850_DRV}
+ ${DECRYPT_PDF} ${HP850_DRV}
EXTRACT_ONLY= ${GS_SOURCES}
MAINTAINER= andreas@FreeBSD.org
-BUILD_DEPENDS= /nonexistent:${PORTSDIR}/graphics/jpeg:extract \
+BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/graphics/jpeg:extract \
unzip:${PORTSDIR}/archivers/unzip
LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png
@@ -41,6 +42,9 @@ GS_FONTS_OTHER= gnu-gs-fonts-other-6.0.tar.gz
# Additional driver HP 850, see http://www.erdw.ethz.ch/~bonk/hp850/hp850.html
HP850_DRV= hp8xxs13.zip
+# replacement for pdf_sec.ps, that allows you to read encrypted PDF files
+DECRYPT_PDF= pdf_sec.ps
+
.if defined(A4)
CFLAGS+= -DA4
.endif
@@ -76,19 +80,11 @@ post-install:
strip ${PREFIX}/bin/gs
${INSTALL_SCRIPT} ${WRKSRC}/unix-lpr.sh ${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/lprsetup.sh ${PREFIX}/bin
+ ${INSTALL_DATA} ${DISTDIR}/pdf_sec.ps \
+ ${PREFIX}/share/ghostscript/5.50
${INSTALL_DATA} ${WRKSRC}/license.hp8 \
${PREFIX}/share/ghostscript/5.50/doc
${INSTALL_DATA} ${WRKSRC}/readme.hp8 \
${PREFIX}/share/ghostscript/5.50/doc
-.if defined(PDFENCRYPT)
- ${INSTALL_DATA} ${DISTDIR}/pdf_sec.ps ${PREFIX}/share/ghostscript/5.50
-.endif
-
-# encrypted PDF support. can't be packaged due to export control issues.
-.if defined(PDFENCRYPT)
-MASTER_SITES+= http://www.ozemail.com.au/~geoffk/pdfencrypt/
-DISTFILES+= pdf_sec.ps
-RESTRICTED= "Crypto; export controlled, RC4 in PostScript code included"
-.endif
.include <bsd.port.mk>
diff --git a/print/ghostscript7/Makefile b/print/ghostscript7/Makefile
index 34bcf6b62370..e5476b2dda13 100644
--- a/print/ghostscript7/Makefile
+++ b/print/ghostscript7/Makefile
@@ -11,15 +11,16 @@ CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_GNU} \
ftp://ftp.cs.wisc.edu/ghost/gnu/gs550/ \
ftp://ftp.cs.wisc.edu/ghost/gnu/fonts/ \
+ http://www.ozemail.com.au/~geoffk/pdfencrypt/ \
http://www.erdw.ethz.ch/~bonk/ftp/gs-driver-distrib/
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTFILES= ${GS_SOURCES} ${GS_FONTS_STD} ${GS_FONTS_OTHER} \
- ${HP850_DRV}
+ ${DECRYPT_PDF} ${HP850_DRV}
EXTRACT_ONLY= ${GS_SOURCES}
MAINTAINER= andreas@FreeBSD.org
-BUILD_DEPENDS= /nonexistent:${PORTSDIR}/graphics/jpeg:extract \
+BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/graphics/jpeg:extract \
unzip:${PORTSDIR}/archivers/unzip
LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png
@@ -41,6 +42,9 @@ GS_FONTS_OTHER= gnu-gs-fonts-other-6.0.tar.gz
# Additional driver HP 850, see http://www.erdw.ethz.ch/~bonk/hp850/hp850.html
HP850_DRV= hp8xxs13.zip
+# replacement for pdf_sec.ps, that allows you to read encrypted PDF files
+DECRYPT_PDF= pdf_sec.ps
+
.if defined(A4)
CFLAGS+= -DA4
.endif
@@ -76,19 +80,11 @@ post-install:
strip ${PREFIX}/bin/gs
${INSTALL_SCRIPT} ${WRKSRC}/unix-lpr.sh ${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/lprsetup.sh ${PREFIX}/bin
+ ${INSTALL_DATA} ${DISTDIR}/pdf_sec.ps \
+ ${PREFIX}/share/ghostscript/5.50
${INSTALL_DATA} ${WRKSRC}/license.hp8 \
${PREFIX}/share/ghostscript/5.50/doc
${INSTALL_DATA} ${WRKSRC}/readme.hp8 \
${PREFIX}/share/ghostscript/5.50/doc
-.if defined(PDFENCRYPT)
- ${INSTALL_DATA} ${DISTDIR}/pdf_sec.ps ${PREFIX}/share/ghostscript/5.50
-.endif
-
-# encrypted PDF support. can't be packaged due to export control issues.
-.if defined(PDFENCRYPT)
-MASTER_SITES+= http://www.ozemail.com.au/~geoffk/pdfencrypt/
-DISTFILES+= pdf_sec.ps
-RESTRICTED= "Crypto; export controlled, RC4 in PostScript code included"
-.endif
.include <bsd.port.mk>