aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorFelix Palmen <zirias@FreeBSD.org>2022-09-11 10:20:14 +0000
committerFelix Palmen <zirias@FreeBSD.org>2022-09-11 10:20:14 +0000
commitddae4e92d8313a1461145e3b4f0232fe463feaee (patch)
treee84ab3fcfdf00dbf560f8ef9ae031d0c2ed252f5 /print
parent51a360b7fe98be99d21134e5fe624ba12d596dd9 (diff)
downloadports-ddae4e92d8313a1461145e3b4f0232fe463feaee.tar.gz
ports-ddae4e92d8313a1461145e3b4f0232fe463feaee.zip
Diffstat (limited to 'print')
-rw-r--r--print/hplip/Makefile2
-rw-r--r--print/limereport/Makefile4
-rw-r--r--print/lyx/Makefile2
-rw-r--r--print/miktex/Makefile2
-rw-r--r--print/posterazor/Makefile2
-rw-r--r--print/print-manager/Makefile4
-rw-r--r--print/qpdfview/Makefile2
-rw-r--r--print/qt5-printsupport/Makefile2
-rw-r--r--print/scribus-devel/Makefile4
9 files changed, 12 insertions, 12 deletions
diff --git a/print/hplip/Makefile b/print/hplip/Makefile
index fecead4632c8..f806d60e9e8a 100644
--- a/print/hplip/Makefile
+++ b/print/hplip/Makefile
@@ -68,7 +68,7 @@ NETWORK_CONFIGURE_ENABLE= network-build
X11_DESC= Graphical User Interface (Qt)
X11_CONFIGURE_ENABLE= gui-build qt5
X11_USES= pyqt:5
-X11_USE= PYQT=pyqt5_run
+X11_USE= PYQT=pyqt5:run
XSANE_DESC= Install XSane for scanning (implies SCAN)
XSANE_IMPLIES= SCAN
diff --git a/print/limereport/Makefile b/print/limereport/Makefile
index 8b5345fd45f1..8c178dd6c6c2 100644
--- a/print/limereport/Makefile
+++ b/print/limereport/Makefile
@@ -11,8 +11,8 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= cmake compiler:c++11-lang dos2unix gl qt:5
-USE_QT+= buildtools_build core gui script sql xml svg quickcontrols2 \
- printsupport uitools network widgets declarative qmake_build
+USE_QT+= buildtools:build core gui script sql xml svg quickcontrols2 \
+ printsupport uitools network widgets declarative qmake:build
USE_GL= gl
USE_GITHUB= yes
diff --git a/print/lyx/Makefile b/print/lyx/Makefile
index a45afd79cebf..4193e5809c4d 100644
--- a/print/lyx/Makefile
+++ b/print/lyx/Makefile
@@ -22,7 +22,7 @@ MINOR_VERSION= 6.1
USES= autoreconf compiler:c++11-lang desktop-file-utils gmake iconv \
pkgconfig perl5 python qt:5 shebangfix tar:xz xorg
-USE_QT= core concurrent gui svg widgets x11extras buildtools_build qmake_build
+USE_QT= core concurrent gui svg widgets x11extras buildtools:build qmake:build
USE_XORG= xcb
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-included-boost \
diff --git a/print/miktex/Makefile b/print/miktex/Makefile
index e67c41ad3454..e90f7a9eae65 100644
--- a/print/miktex/Makefile
+++ b/print/miktex/Makefile
@@ -64,7 +64,7 @@ MANPAGES_CMAKE_BOOL= WITH_MAN_PAGES
UIQT_CMAKE_BOOL= WITH_UI_QT
UIQT_USES= qt:5 gl
-UIQT_USE= qt=core,concurrent,declarative,dbus,gui,linguisttools,network,printsupport,script,scripttools,uitools,widgets,xml,buildtools_build,qmake_build gl=gl
+UIQT_USE= qt=core,concurrent,declarative,dbus,gui,linguisttools,network,printsupport,script,scripttools,uitools,widgets,xml,buildtools:build,qmake:build gl=gl
CMAKE_ARGS= -DMIKTEX_SYSTEM_ETC_FONTS_CONFD_DIR=${LOCALBASE}/etc/fonts/conf.d \
-DMIKTEX_SYSTEM_VAR_CACHE_DIR=${DATADIR}/cache \
diff --git a/print/posterazor/Makefile b/print/posterazor/Makefile
index 87a80a64bb4b..86a57bef4c27 100644
--- a/print/posterazor/Makefile
+++ b/print/posterazor/Makefile
@@ -15,7 +15,7 @@ USES= compiler:c++11-lang dos2unix gl localbase:ldflags qmake qt:5
USE_GITHUB= yes
GH_ACCOUNT= ehaupt
USE_GL= gl
-USE_QT= core gui printsupport widgets buildtools_build
+USE_QT= core gui printsupport widgets buildtools:build
QMAKE_SOURCE_PATH= ${WRKSRC}/src/posterazor.pro
diff --git a/print/print-manager/Makefile b/print/print-manager/Makefile
index 15fe820453fe..aecca3356024 100644
--- a/print/print-manager/Makefile
+++ b/print/print-manager/Makefile
@@ -13,9 +13,9 @@ USE_KDE= auth codecs completion config configwidgets coreaddons \
dbusaddons i18n iconthemes itemviews jobwidgets kcmutils \
kio notifications plasma-framework service solid widgetsaddons \
windowsystem \
- ecm_build
+ ecm:build
USE_QT= concurrent core dbus declarative gui network widgets xml \
- buildtools_build qmake_build
+ buildtools:build qmake:build
USE_XORG= x11
post-patch:
diff --git a/print/qpdfview/Makefile b/print/qpdfview/Makefile
index 8678a86868e8..75a643885ab0 100644
--- a/print/qpdfview/Makefile
+++ b/print/qpdfview/Makefile
@@ -18,7 +18,7 @@ USES= compiler:c++11-lang desktop-file-utils gl pkgconfig qmake qt:5
USE_GL= gl
USE_LDCONFIG= yes
USE_QT= concurrent core dbus gui imageformats linguisttools \
- printsupport sql sql-sqlite3 svg widgets xml buildtools_build
+ printsupport sql sql-sqlite3 svg widgets xml buildtools:build
QMAKE_SOURCE_PATH= ${PORTNAME}.pro
diff --git a/print/qt5-printsupport/Makefile b/print/qt5-printsupport/Makefile
index 38fe74a6cafb..a62b8603597d 100644
--- a/print/qt5-printsupport/Makefile
+++ b/print/qt5-printsupport/Makefile
@@ -8,7 +8,7 @@ COMMENT= Qt print support module
USES= compiler:c++11-lang perl5 qmake:no_env qt-dist:5,base
USE_PERL5= extract
-USE_QT= core gui widgets qmake_build buildtools_build
+USE_QT= core gui widgets qmake:build buildtools:build
HAS_CONFIGURE= yes
BUILD_WRKSRC= ${WRKSRC}/src/${PORTNAME}
diff --git a/print/scribus-devel/Makefile b/print/scribus-devel/Makefile
index f7f9109ce148..be5eb8c733f2 100644
--- a/print/scribus-devel/Makefile
+++ b/print/scribus-devel/Makefile
@@ -39,8 +39,8 @@ LIB_DEPENDS= liblcms2.so:graphics/lcms2 \
USES= cmake compiler:c++17-lang desktop-file-utils dos2unix gnome \
jpeg pkgconfig python:3.6+ qt:5 shared-mime-info tar:xz
-USE_QT= buildtools_build core declarative gui linguisttools_build \
- network opengl printsupport qmake_build widgets xml
+USE_QT= buildtools:build core declarative gui linguisttools:build \
+ network opengl printsupport qmake:build widgets xml
DOS2UNIX_REGEX= .*\.(cpp|h|txt)
USE_GNOME= libxml2