aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-05-19 09:22:54 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-05-19 09:22:54 +0000
commite5a36098a3162677ff90f5d52de0ac2c4e08f06d (patch)
treea5891f0a6a6e313c8bd27fe2e0363c2aa5523ed8 /print
parent1f8332289998d08fe8d6f22bc7ad2867480474cf (diff)
downloadports-e5a36098a3162677ff90f5d52de0ac2c4e08f06d.tar.gz
ports-e5a36098a3162677ff90f5d52de0ac2c4e08f06d.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/bophook/Makefile45
-rw-r--r--print/bophook/distinfo2
-rw-r--r--print/bophook/pkg-descr6
4 files changed, 54 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index cf884c495425..19a31e665ae0 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -26,6 +26,7 @@
SUBDIR += bibcursed
SUBDIR += biblio-py
SUBDIR += bibview
+ SUBDIR += bophook
SUBDIR += c2ps-a4
SUBDIR += c2ps-letter
SUBDIR += catdvi
diff --git a/print/bophook/Makefile b/print/bophook/Makefile
new file mode 100644
index 000000000000..9a0b1b75c973
--- /dev/null
+++ b/print/bophook/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: bophook
+# Date created: 2012-05-11
+# Whom: Hiroto Kagotani <hiroto.kagotani@gmail.com>
+#
+# $FreeBSD$
+
+PORTNAME= bophook
+PORTVERSION= 0.02
+CATEGORIES= print
+MASTER_SITES= ${MASTER_SITE_TEX_CTAN}
+MASTER_SITE_SUBDIR= macros/latex/contrib/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= hiroto.kagotani@gmail.com
+COMMENT= Style file providing a beginning-of-page hook for LaTeX
+
+BUILD_DEPENDS= latex:${PORTSDIR}/print/teTeX-base
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_ZIP= yes
+
+PLIST= ${WRKDIR}/pkg-plist
+
+TEXMFDIR= share/texmf-local
+MKTEXLSR= ${LOCALBASE}/bin/mktexlsr
+CLASSDIR= ${TEXMFDIR}/tex/latex/${PORTNAME}
+CLASS_FILES= ${PORTNAME}.sty
+
+do-build:
+ cd ${WRKSRC} && latex ${PORTNAME}.ins
+
+pre-install:
+ ${ECHO_CMD} "${CLASSDIR}/${CLASS_FILES}" > ${PLIST}
+ ${ECHO_CMD} "@dirrm ${CLASSDIR}" >> ${PLIST}
+ ${ECHO_CMD} "@exec ${MKTEXLSR}" >> ${PLIST}
+ ${ECHO_CMD} "@unexec ${MKTEXLSR}" >> ${PLIST}
+
+do-install:
+ @${MKDIR} ${PREFIX}/${CLASSDIR}
+ ${INSTALL_DATA} ${CLASS_FILES:S@^@${WRKSRC}/@} ${PREFIX}/${CLASSDIR}
+
+post-install:
+ ${MKTEXLSR}
+
+.include <bsd.port.mk>
diff --git a/print/bophook/distinfo b/print/bophook/distinfo
new file mode 100644
index 000000000000..8d57fc2fd940
--- /dev/null
+++ b/print/bophook/distinfo
@@ -0,0 +1,2 @@
+SHA256 (bophook.zip) = 08fd05b340ae25724d256d71d28e69c805f023f78ca96fbc828635609ff992e7
+SIZE (bophook.zip) = 50289
diff --git a/print/bophook/pkg-descr b/print/bophook/pkg-descr
new file mode 100644
index 000000000000..1dc49992be8f
--- /dev/null
+++ b/print/bophook/pkg-descr
@@ -0,0 +1,6 @@
+This is a beginning-of-page hook for LaTeX.
+
+Using the \AtBeginPage hook, you can add material in the background
+of each page.
+
+WWW: http://www.ctan.org/tex-archive/macros/latex/contrib/bophook