aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2017-09-17 18:38:38 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2017-09-17 18:38:38 +0000
commite89db29d408adad91a3cc95cf7392a6f6ba66e0a (patch)
tree9b3101353b97d6fc38566e05bad05320f485453a /print
parent069c031f08767b15b987e7a4063df774bca0b2c0 (diff)
downloadports-e89db29d408adad91a3cc95cf7392a6f6ba66e0a.tar.gz
ports-e89db29d408adad91a3cc95cf7392a6f6ba66e0a.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/epson-inkjet-printer-201601w/Makefile53
-rw-r--r--print/epson-inkjet-printer-201601w/distinfo5
-rw-r--r--print/epson-inkjet-printer-201601w/pkg-descr9
-rw-r--r--print/epson-inkjet-printer-201601w/pkg-plist39
5 files changed, 107 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index 98e1f0960b0f..f402496f5232 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -43,6 +43,7 @@
SUBDIR += enscript-letter
SUBDIR += enscript-letterdj
SUBDIR += epson-inkjet-printer-201401w
+ SUBDIR += epson-inkjet-printer-201601w
SUBDIR += epson-inkjet-printer-escpr
SUBDIR += epsonepl
SUBDIR += fig2dev
diff --git a/print/epson-inkjet-printer-201601w/Makefile b/print/epson-inkjet-printer-201601w/Makefile
new file mode 100644
index 000000000000..2ee6aa38cef6
--- /dev/null
+++ b/print/epson-inkjet-printer-201601w/Makefile
@@ -0,0 +1,53 @@
+# $FreeBSD$
+
+PORTNAME= epson-inkjet-printer-201601w
+PORTVERSION= 1.0.0
+CATEGORIES= print
+MASTER_SITES= https://download3.ebz.epson.net/dsc/f/03/00/05/62/39/770f0f7c12a304ceaec1ce13e5b5740a71522b68/:amd64 \
+ https://download3.ebz.epson.net/dsc/f/03/00/05/62/39/f1fd78aacb85fff1a3c59a80dae5a5ac25e33992/:i386
+DISTFILES_amd64=${DISTNAME}-1lsb3.2.x86_64.rpm:amd64
+DISTFILES_i386= ${DISTNAME}-1lsb3.2.i486.rpm:i386
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= CUPS filter for Seiko Epson Color Ink Jet Printers
+
+LICENSE= EPSON LGPL21
+LICENSE_COMB= multi
+LICENSE_NAME_EPSON= SEIKO EPSON CORPORATION SOFTWARE LICENSE AGREEMENT
+LICENSE_FILE_EPSON= ${WRKSRC}/opt/${PORTNAME}/doc/COPYING.EPSON
+LICENSE_FILE_LGPL21= ${WRKSRC}/opt/${PORTNAME}/doc/COPYING.LIB
+LICENSE_PERMS_EPSON= none
+
+RUN_DEPENDS= ${LOCALBASE}/libexec/cups/filter/gstoraster:print/cups-filters
+
+RESTRICTED= License does not allow redistribution
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+PLIST_SUB= LINUXBASE=${LINUXBASE} \
+ PORTNAME=${PORTNAME}
+USES= linux
+USE_LINUX= cups-libs jpeg
+
+.include <bsd.port.pre.mk>
+
+.if ${LINUX_ARCH} == i386
+PLIST_SUB+= LIBDIR=lib
+.elif ${LINUX_ARCH} == x86_64
+PLIST_SUB+= LIBDIR=lib64
+.endif
+
+post-extract:
+ @${GUNZIP_CMD} ${WRKSRC}/opt/${PORTNAME}/ppds/Epson/*.ppd.gz
+
+post-patch:
+ @${SED} -i '' '/^\*cupsFilter:/s,/opt/,${LINUXBASE}&,' \
+ ${WRKSRC}/opt/${PORTNAME}/ppds/Epson/*.ppd
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${LINUXBASE}
+ ${CP} -Rp ${WRKSRC}/opt ${STAGEDIR}${LINUXBASE}
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/cups/model/
+ ${LN} -sf ${LINUXBASE}/opt/${PORTNAME}/ppds/Epson ${STAGEDIR}${PREFIX}/share/cups/model/Epson-201601w
+
+.include <bsd.port.post.mk>
diff --git a/print/epson-inkjet-printer-201601w/distinfo b/print/epson-inkjet-printer-201601w/distinfo
new file mode 100644
index 000000000000..0a130b43d7bb
--- /dev/null
+++ b/print/epson-inkjet-printer-201601w/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1505672178
+SHA256 (epson-inkjet-printer-201601w-1.0.0-1lsb3.2.i486.rpm) = ce1bf17adbfcdf6d111745f89866c00c5272d1f8a132a7b525a8a8a75daa5fe2
+SIZE (epson-inkjet-printer-201601w-1.0.0-1lsb3.2.i486.rpm) = 1693428
+SHA256 (epson-inkjet-printer-201601w-1.0.0-1lsb3.2.x86_64.rpm) = 8a4dad7ba43fb83f454e6315c2fa46c926f24325524225b91983156f3d62c7bd
+SIZE (epson-inkjet-printer-201601w-1.0.0-1lsb3.2.x86_64.rpm) = 1717116
diff --git a/print/epson-inkjet-printer-201601w/pkg-descr b/print/epson-inkjet-printer-201601w/pkg-descr
new file mode 100644
index 000000000000..07f9128ea9c6
--- /dev/null
+++ b/print/epson-inkjet-printer-201601w/pkg-descr
@@ -0,0 +1,9 @@
+This software is a filter program used with Common UNIX Printing
+System (CUPS) from the Linux. This can supply the high quality print
+with Seiko Epson Color Ink Jet Printers.
+
+This printer driver is supporting the following printers.
+L380
+L382
+
+WWW: http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX
diff --git a/print/epson-inkjet-printer-201601w/pkg-plist b/print/epson-inkjet-printer-201601w/pkg-plist
new file mode 100644
index 000000000000..b6277fe476df
--- /dev/null
+++ b/print/epson-inkjet-printer-201601w/pkg-plist
@@ -0,0 +1,39 @@
+%%LINUXBASE%%/opt/%%PORTNAME%%/cups/lib/filter/epson_inkjet_printer_filter
+%%LINUXBASE%%/opt/%%PORTNAME%%/doc/AUTHORS
+%%LINUXBASE%%/opt/%%PORTNAME%%/doc/COPYING
+%%LINUXBASE%%/opt/%%PORTNAME%%/doc/COPYING.EPSON
+%%LINUXBASE%%/opt/%%PORTNAME%%/doc/COPYING.LIB
+%%LINUXBASE%%/opt/%%PORTNAME%%/doc/Manual.txt
+%%LINUXBASE%%/opt/%%PORTNAME%%/doc/README
+%%LINUXBASE%%/opt/%%PORTNAME%%/%%LIBDIR%%/libEpson_201601w.MT.so.1.0.0
+%%LINUXBASE%%/opt/%%PORTNAME%%/%%LIBDIR%%/libEpson_201601w.so.1.0.0
+%%LINUXBASE%%/opt/%%PORTNAME%%/ppds/Epson/Epson-L380_Series-epson-driver.ppd
+%%LINUXBASE%%/opt/%%PORTNAME%%/ppds/Epson/Epson-L382_Series-epson-driver.ppd
+%%LINUXBASE%%/opt/%%PORTNAME%%/resource/Epson_201601w.1.data
+%%LINUXBASE%%/opt/%%PORTNAME%%/resource/Epson_201601w.MT.1.data
+%%LINUXBASE%%/opt/%%PORTNAME%%/resource/Epson_201601w.MT.2.data
+%%LINUXBASE%%/opt/%%PORTNAME%%/resource/Epson_201601w.MT.3.data
+%%LINUXBASE%%/opt/%%PORTNAME%%/resource/Epson_201601w.MT.4.data
+%%LINUXBASE%%/opt/%%PORTNAME%%/watermark/WEPCG00.EID
+%%LINUXBASE%%/opt/%%PORTNAME%%/watermark/WEPCG01.EID
+%%LINUXBASE%%/opt/%%PORTNAME%%/watermark/WEPCG02.EID
+%%LINUXBASE%%/opt/%%PORTNAME%%/watermark/WEPCG03.EID
+%%LINUXBASE%%/opt/%%PORTNAME%%/watermark/WEPCG04.EID
+%%LINUXBASE%%/opt/%%PORTNAME%%/watermark/WEPCG05.EID
+%%LINUXBASE%%/opt/%%PORTNAME%%/watermark/WEPCG06.EID
+%%LINUXBASE%%/opt/%%PORTNAME%%/watermark/WEPCG07.EID
+%%LINUXBASE%%/opt/%%PORTNAME%%/watermark/WEPCG08.EID
+%%LINUXBASE%%/opt/%%PORTNAME%%/watermark/WEPCG09.EID
+share/cups/model/Epson-201601w
+@dir %%LINUXBASE%%/opt/%%PORTNAME%%/cups/lib/filter
+@dir %%LINUXBASE%%/opt/%%PORTNAME%%/cups/lib
+@dir %%LINUXBASE%%/opt/%%PORTNAME%%/cups
+@dir %%LINUXBASE%%/opt/%%PORTNAME%%/doc
+@dir %%LINUXBASE%%/opt/%%PORTNAME%%/%%LIBDIR%%
+@dir %%LINUXBASE%%/opt/%%PORTNAME%%/ppds/Epson
+@dir %%LINUXBASE%%/opt/%%PORTNAME%%/ppds
+@dir %%LINUXBASE%%/opt/%%PORTNAME%%/resource
+@dir %%LINUXBASE%%/opt/%%PORTNAME%%/watermark
+@dir %%LINUXBASE%%/opt/%%PORTNAME%%
+@dir %%LINUXBASE%%/opt
+@dir %%LINUXBASE%%