aboutsummaryrefslogtreecommitdiff
path: root/russian/emkatic
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2015-08-26 10:42:29 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2015-08-26 10:42:29 +0000
commit145b561a8ede4e46fa449bf679c21f44d150d711 (patch)
tree5597c82d8c1dc327512bdac9c48f77d2768c9629 /russian/emkatic
parent287600ff5a7f3292a609af09a5e11d062e008a0d (diff)
downloadports-145b561a8ede4e46fa449bf679c21f44d150d711.tar.gz
ports-145b561a8ede4e46fa449bf679c21f44d150d711.zip
- Update to version 0.25, which now features localization support
- Use OPTIONS helpers more widely (this also allows to GC WANT_GNOME) - Add `pkg-message' on how to enable PC speaker sound output support - Convert .include <bsd.port.pre.mk>/<bsd.port.post.mk> into <bsd.port.options.mk>/<bsd.port.mk> and wrap one overly long line while here PR: 200808 (modified)
Notes
Notes: svn path=/head/; revision=395360
Diffstat (limited to 'russian/emkatic')
-rw-r--r--russian/emkatic/Makefile25
-rw-r--r--russian/emkatic/distinfo4
-rw-r--r--russian/emkatic/pkg-descr3
-rw-r--r--russian/emkatic/pkg-message2
4 files changed, 19 insertions, 15 deletions
diff --git a/russian/emkatic/Makefile b/russian/emkatic/Makefile
index d57be511db9d..7ffa0d08be79 100644
--- a/russian/emkatic/Makefile
+++ b/russian/emkatic/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= emkatic
-PORTVERSION= 0.20
-PORTREVISION= 4
+PORTVERSION= 0.25
CATEGORIES= russian emulators
MASTER_SITES= SF/${PORTNAME}/eMKatic%20Source
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
@@ -19,7 +18,6 @@ BUILD_DEPENDS= lazbuild:${PORTSDIR}/editors/lazarus \
USE_FPC= cairo fcl-base fcl-image fcl-json fcl-process fcl-xml hash \
pasjpeg paszlib x11
-WANT_GNOME= yes
PROJECT_FILE= emkatic.lpi
LAZARUS_VER= 1.4.2
@@ -28,7 +26,8 @@ LAZARUS_DIR= ${LOCALBASE}/share/lazarus-${LAZARUS_VER}
LCL_UNITS_DIR= ${LAZARUS_DIR}/lcl/units/${BUILDNAME}
PLIST_FILES= bin/${PORTNAME}
-PORTDOCS= CHANGELOG.txt
+PORTDATA= *
+PORTDOCS= CHANGELOG.*.txt README.*.txt
OPTIONS_DEFINE= DOCS PORTAUDIO
OPTIONS_SINGLE= GUI
@@ -38,30 +37,32 @@ OPTIONS_DEFAULT= GTK2 PORTAUDIO
GTK2_DESC= Build with GTK+ 2 interface
QT4_DESC= Build with Qt 4 interface
+GTK2_BUILD_DEPENDS= ${LCL_UNITS_DIR}/${LCL_PLATFORM}/interfaces.ppu:${PORTSDIR}/editors/lazarus-lcl-gtk2
+GTK2_USE= GNOME=gtk20 FPC=gtk2
+
+QT4_BUILD_DEPENDS= ${LCL_UNITS_DIR}/${LCL_PLATFORM}/interfaces.ppu:${PORTSDIR}/editors/lazarus-lcl-qt
+QT4_LIB_DEPENDS= libQt4Pas.so:${PORTSDIR}/x11-toolkits/qt4pas
+
PORTAUDIO_LIB_DEPENDS= libportaudio.so:${PORTSDIR}/audio/portaudio
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGTK2}
-USE_FPC+= gtk2
-USE_GNOME= gtk20
LCL_PLATFORM= gtk2
-BUILD_DEPENDS+= ${LCL_UNITS_DIR}/${LCL_PLATFORM}/interfaces.ppu:${PORTSDIR}/editors/lazarus-lcl-gtk2
.endif
.if ${PORT_OPTIONS:MQT4}
-LIB_DEPENDS+= libQt4Pas.so:${PORTSDIR}/x11-toolkits/qt4pas
LCL_PLATFORM= qt
-BUILD_DEPENDS+= ${LCL_UNITS_DIR}/${LCL_PLATFORM}/interfaces.ppu:${PORTSDIR}/editors/lazarus-lcl-qt
.endif
do-build:
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} \
- ${LAZBUILD_CMD} --ws="${LCL_PLATFORM}" --lazarusdir=${LAZARUS_DIR} ${PROJECT_FILE}
+ ${LAZBUILD_CMD} --ws="${LCL_PLATFORM}" \
+ --lazarusdir=${LAZARUS_DIR} ${PROJECT_FILE}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/russian/emkatic/distinfo b/russian/emkatic/distinfo
index f1804436801d..7acf9281c37e 100644
--- a/russian/emkatic/distinfo
+++ b/russian/emkatic/distinfo
@@ -1,2 +1,2 @@
-SHA256 (emkatic-0.20-src.tar.gz) = c2a73130d13eaeaf3f60b54dff8d0f24259a7099246a03f454101994f5bfbab2
-SIZE (emkatic-0.20-src.tar.gz) = 388569
+SHA256 (emkatic-0.25-src.tar.gz) = 7726f257a8e2bd37e3731d8131590ff3c0429d8b192baadd28a052177f7839d8
+SIZE (emkatic-0.25-src.tar.gz) = 557895
diff --git a/russian/emkatic/pkg-descr b/russian/emkatic/pkg-descr
index a39ec800e321..2f2fbb1d65bf 100644
--- a/russian/emkatic/pkg-descr
+++ b/russian/emkatic/pkg-descr
@@ -1,6 +1,7 @@
eMKatic is a cross-platform emulator of Elektronika RPN programmable
calculator series (MK-152, MK-152M, MK-1152, MK-161).
-Only Cyrillic user interface is supported.
+Cyrillic user interface is enabled by default. English available with
+localization (-i command line switch or via the context menu).
WWW: http://sourceforge.net/projects/emkatic/
diff --git a/russian/emkatic/pkg-message b/russian/emkatic/pkg-message
new file mode 100644
index 000000000000..bda7a994fa90
--- /dev/null
+++ b/russian/emkatic/pkg-message
@@ -0,0 +1,2 @@
+To enable PC speaker sound output support, install `audio/beep' package or
+from the ports. Frequency and duration can be specified in the settings.