aboutsummaryrefslogtreecommitdiff
path: root/russian/gd
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2000-05-28 03:52:44 +0000
committerSteve Price <steve@FreeBSD.org>2000-05-28 03:52:44 +0000
commitd3b9c3bb4cecab8bc6403e193376b8e25d05a9e3 (patch)
treee394275e9511a40e61da370d3f96e28e62f1af80 /russian/gd
parent7e7b28d09f63d6ec1636df42856a9c518e2f7323 (diff)
downloadports-d3b9c3bb4cecab8bc6403e193376b8e25d05a9e3.tar.gz
ports-d3b9c3bb4cecab8bc6403e193376b8e25d05a9e3.zip
Update to version 1.8.2.
Notes
Notes: svn path=/head/; revision=28815
Diffstat (limited to 'russian/gd')
-rw-r--r--russian/gd/Makefile12
-rw-r--r--russian/gd/distinfo2
-rw-r--r--russian/gd/files/patch-aa165
-rw-r--r--russian/gd/pkg-comment2
-rw-r--r--russian/gd/pkg-descr11
-rw-r--r--russian/gd/pkg-plist20
6 files changed, 169 insertions, 43 deletions
diff --git a/russian/gd/Makefile b/russian/gd/Makefile
index d75ffbebd049..dc24641a8de6 100644
--- a/russian/gd/Makefile
+++ b/russian/gd/Makefile
@@ -6,20 +6,20 @@
#
PORTNAME= gd
-PORTVERSION= 1.3
+PORTVERSION= 1.8.2
CATEGORIES= russian graphics
MASTER_SITES= http://www.boutell.com/gd/http/ \
ftp://ftp.boutell.com/pub/boutell/gd/
-DISTNAME= gd${PORTVERSION}
MAINTAINER= gsm@infosite.ru
-RESTRICTED= unavailable from master site due to legal problems
-
-FETCH_BEFORE_ARGS= -b
+LIB_DEPENDS= png.3:${PORTSDIR}/graphics/png \
+ jpeg.9:${PORTSDIR}/graphics/jpeg
pre-install:
${MKDIR} ${PREFIX}/include/gd
- ${MKDIR} ${PREFIX}/share/examples/gd
+
+post-install:
+ ${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
.include <bsd.port.mk>
diff --git a/russian/gd/distinfo b/russian/gd/distinfo
index ebee24c7e5a3..7cd70fe502d6 100644
--- a/russian/gd/distinfo
+++ b/russian/gd/distinfo
@@ -1 +1 @@
-MD5 (gd1.3.tar.gz) = ff3de2c851c4b1fc6af6f14dcfbc6532
+MD5 (gd-1.8.2.tar.gz) = 92d69d3d70d9b29da74dd79f9c7e10ff
diff --git a/russian/gd/files/patch-aa b/russian/gd/files/patch-aa
index 2ea8dcf967bb..824f82b59254 100644
--- a/russian/gd/files/patch-aa
+++ b/russian/gd/files/patch-aa
@@ -1,27 +1,146 @@
---- Makefile.orig Tue Aug 8 14:28:27 1995
-+++ Makefile Sat Jun 14 18:19:04 1997
-@@ -7,9 +7,9 @@
- #If the ar command fails on your system, consult the ar manpage
- #for your system.
+--- Makefile.orig Thu May 18 13:39:18 2000
++++ Makefile Sun May 21 00:55:38 2000
+@@ -5,3 +5,3 @@
+ #compiler; get gcc if you are still using it).
+-COMPILER=gcc
++COMPILER=${CC}
--CC=gcc
+@@ -9,3 +9,3 @@
+ #for your system.
-AR=ar
--CFLAGS=-O
-+#CC=gcc
+#AR=ar
+
+@@ -13,6 +13,10 @@
+ #header files, uncomment this (default).
+-CFLAGS=-O
+#CFLAGS=-O
- LIBS=-L./ -lgd -lm
-
- all: libgd.a gddemo giftogd webgif
-@@ -32,3 +32,11 @@
- clean:
- rm -f *.o *.a gddemo giftogd
-
-+install:
-+ install -cs -o bin -g bin gddemo giftogd webgif ${PREFIX}/bin
-+ install -c -o bin -g bin libgd.a ${PREFIX}/lib
-+ install -c -o bin -g bin gd.h gdfonts.h ${PREFIX}/include/gd
-+ install -c -o bin -g bin gdfontt.h gdfontmb.h ${PREFIX}/include/gd
-+ install -c -o bin -g bin gdfontl.h gdfontg.h ${PREFIX}/include/gd
-+ install -c -o bin -g bin index.html ${PREFIX}/share/examples/gd
-+ install -c -o bin -g bin demoin.gif ${PREFIX}/share/examples/gd
+ #If you do have FreeType, libjpeg and/or Xpm fully installed, uncomment a
+ #variation of this and comment out the line above. See also LIBS below.
+-#CFLAGS=-O -DHAVE_XPM -DHAVE_JPEG -DHAVE_LIBTTF
++.if defined(WITH_X11)
++CFLAGS+=-DHAVE_XPM -DHAVE_JPEG -DHAVE_LIBTTF
++.else
++CFLAGS+=-DHAVE_JPEG
++.endif
+
+@@ -25,3 +29,3 @@
+
+-LIBS=-lm -lgd -lpng -lz
++LIBS=-lm -lgd -lpng -lz -ljpeg
+
+@@ -35,3 +39,5 @@
+
+-#LIBS=-lm -lgd -lpng -lz -ljpeg -lttf -lXpm -lX11
++.if defined(WITH_X11)
++LIBS+= -lttf -lXpm -lX11
++.endif
+
+@@ -42,3 +48,6 @@
+
+-INCLUDEDIRS=-I. -I/usr/local/include -I/usr/include/X11 -I/usr/X11R6/include/X11
++INCLUDEDIRS=-I. -I${LOCALBASE}/include
++.if defined(WITH_X11)
++INCLUDEDIRS+=-I{LOCALBASE}/include/freetype -I${X11BASE}/include/X11 -I${X11BASE}/include
++.endif
+
+@@ -50,12 +59,15 @@
+ #on your system can't cause conflicts while building a new one.
+-LIBDIRS=-L. -L/usr/local/lib -L/usr/lib/X11 -L/usr/X11R6/lib
++LIBDIRS=-L. -L$(LOCALBASE)/lib
++.if defined(WITH_X11)
++LIBDIRS+=-L$(X11BASE)/lib
++.endif
+
+ #Location where libgd.a should be installed by "make install".
+-INSTALL_LIB=/usr/local/lib
++INSTALL_LIB=$(PREFIX)/lib
+
+ #Location where .h files should be installed by "make install".
+-INSTALL_INCLUDE=/usr/local/include
++INSTALL_INCLUDE=$(PREFIX)/include/gd
+
+ #Location where useful non-test programs should be installed by "make install".
+-INSTALL_BIN=/usr/local/bin
++INSTALL_BIN=$(PREFIX)/bin
+
+@@ -67,6 +79,6 @@
+
+-VERSION=1.8.1
++VERSION=1.8.2
+
+-CC=$(COMPILER) $(INCLUDEDIRS)
+-LINK=$(CC) $(LIBDIRS) $(LIBS)
++CC+= $(INCLUDEDIRS)
++#LINK=$(CC) $(LIBDIRS) $(LIBS)
+
+@@ -77,22 +89,29 @@
+
+-all: libgd.a $(PROGRAMS)
++.SUFFIXES: .c .so .o
++
++.c.so:
++ ${CC} -fpic -DPIC ${CFLAGS} -c ${.IMPSRC} -o ${.TARGET}
++
++all: libgd.a libgd.so.0 $(PROGRAMS)
+
+ install: libgd.a $(BIN_PROGRAMS)
+- sh ./install-item 644 libgd.a $(INSTALL_LIB)/libgd.a
+- sh ./install-item 755 pngtogd $(INSTALL_BIN)/pngtogd
+- sh ./install-item 755 pngtogd2 $(INSTALL_BIN)/pngtogd2
+- sh ./install-item 755 gdtopng $(INSTALL_BIN)/gdtopng
+- sh ./install-item 755 gd2topng $(INSTALL_BIN)/gd2topng
+- sh ./install-item 755 gd2copypal $(INSTALL_BIN)/gd2copypal
+- sh ./install-item 755 gdparttopng $(INSTALL_BIN)/gdparttopng
+- sh ./install-item 755 webpng $(INSTALL_BIN)/webpng
+- sh ./install-item 755 bdftogd $(INSTALL_BIN)/bdftogd
+- sh ./install-item 644 gd.h $(INSTALL_INCLUDE)/gd.h
+- sh ./install-item 644 gdcache.h $(INSTALL_INCLUDE)/gdcache.h
+- sh ./install-item 644 gd_io.h $(INSTALL_INCLUDE)/gd_io.h
+- sh ./install-item 644 gdfontg.h $(INSTALL_INCLUDE)/gdfontg.h
+- sh ./install-item 644 gdfontl.h $(INSTALL_INCLUDE)/gdfontl.h
+- sh ./install-item 644 gdfontmb.h $(INSTALL_INCLUDE)/gdfontmb.h
+- sh ./install-item 644 gdfonts.h $(INSTALL_INCLUDE)/gdfonts.h
+- sh ./install-item 644 gdfontt.h $(INSTALL_INCLUDE)/gdfontt.h
++ $(INSTALL) -c -m 644 libgd.a $(INSTALL_LIB)/libgd.a
++ $(INSTALL) -c -m 755 pngtogd $(INSTALL_BIN)/pngtogd
++ $(INSTALL) -c -m 755 libgd.so.0 $(INSTALL_LIB)/libgd.so.0
++ ln -sf libgd.so.0 $(INSTALL_LIB)/libgd.so
++ $(INSTALL) -c -m 755 pngtogd2 $(INSTALL_BIN)/pngtogd2
++ $(INSTALL) -c -m 755 gdtopng $(INSTALL_BIN)/gdtopng
++ $(INSTALL) -c -m 755 gd2topng $(INSTALL_BIN)/gd2topng
++ $(INSTALL) -c -m 755 gd2copypal $(INSTALL_BIN)/gd2copypal
++ $(INSTALL) -c -m 755 gdparttopng $(INSTALL_BIN)/gdparttopng
++ $(INSTALL) -c -m 755 webpng $(INSTALL_BIN)/webpng
++ $(INSTALL) -c -m 755 bdftogd $(INSTALL_BIN)/bdftogd
++ $(INSTALL) -c -m 644 gd.h $(INSTALL_INCLUDE)/gd.h
++ $(INSTALL) -c -m 644 gdcache.h $(INSTALL_INCLUDE)/gdcache.h
++ $(INSTALL) -c -m 644 gd_io.h $(INSTALL_INCLUDE)/gd_io.h
++ $(INSTALL) -c -m 644 gdfontg.h $(INSTALL_INCLUDE)/gdfontg.h
++ $(INSTALL) -c -m 644 gdfontl.h $(INSTALL_INCLUDE)/gdfontl.h
++ $(INSTALL) -c -m 644 gdfontmb.h $(INSTALL_INCLUDE)/gdfontmb.h
++ $(INSTALL) -c -m 644 gdfonts.h $(INSTALL_INCLUDE)/gdfonts.h
++ $(INSTALL) -c -m 644 gdfontt.h $(INSTALL_INCLUDE)/gdfontt.h
+
+@@ -131,12 +150,15 @@
+
+-libgd.a: gd.o gd_gd.o gd_gd2.o gd_io.o gd_io_dp.o gd_io_file.o gd_ss.o \
++OBJS= gd.o gd_gd.o gd_gd2.o gd_io.o gd_io_dp.o gd_io_file.o gd_ss.o \
+ gd_io_ss.o gd_png.o gd_jpeg.o gdxpm.o gdfontt.o gdfonts.o gdfontmb.o gdfontl.o \
+- gdfontg.o gdtables.o gdttf.o gdcache.o gdkanji.o wbmp.o gd_wbmp.o \
+- gd.h gdfontt.h gdfonts.h gdfontmb.h gdfontl.h gdfontg.h
++ gdfontg.o gdtables.o gdttf.o gdcache.o gdkanji.o wbmp.o gd_wbmp.o
++INCS= gd.h gdfontt.h gdfonts.h gdfontmb.h gdfontl.h gdfontg.h
++
++libgd.a: $(INCS) $(OBJS)
+ rm -f libgd.a
+- $(AR) rc libgd.a gd.o gd_gd.o gd_gd2.o gd_io.o gd_io_dp.o \
+- gd_io_file.o gd_ss.o gd_io_ss.o gd_png.o gd_jpeg.o gdxpm.o \
+- gdfontt.o gdfonts.o gdfontmb.o gdfontl.o gdfontg.o \
+- gdtables.o gdttf.o gdcache.o gdkanji.o wbmp.o gd_wbmp.o
++ $(AR) rc libgd.a $(OBJS)
+ -ranlib libgd.a
++
++libgd.so.0: $(INCS) $(OBJS:S/o$/so/g)
++ $(CC) -shared -Wl,-x -Wl,-assert -Wl,pure-text -Wl,-soname,$@ -o $@ $(OBJS:S/o$/so/g) $(LIBDIRS) $(LIBS)
++ ln -sf libgd.so.0 libgd.so
+
diff --git a/russian/gd/pkg-comment b/russian/gd/pkg-comment
index f666b62a0619..d649dbef0778 100644
--- a/russian/gd/pkg-comment
+++ b/russian/gd/pkg-comment
@@ -1 +1 @@
-Graphics library for fast GIF creation (uses fonts in KOI8-R encoding)
+Graphics library for fast PNG creation (uses fonts in KOI8-R encoding)
diff --git a/russian/gd/pkg-descr b/russian/gd/pkg-descr
index 58726dafe17c..af84716b96b9 100644
--- a/russian/gd/pkg-descr
+++ b/russian/gd/pkg-descr
@@ -2,8 +2,8 @@ DESCRIPTION
gd is a graphics library. It allows your code to quickly draw images
complete with lines, arcs, text, multiple colors, cut and paste from
- other images, and flood fills, and write out the result as a .GIF file.
- This is particularly useful in World Wide Web applications, where .GIF
+ other images, and flood fills, and write out the result as a .PNG file.
+ This is particularly useful in World Wide Web applications, where .PNG
is the format used for inline images.
gd is not a paint program. If you are looking for a paint program, try
@@ -15,14 +15,13 @@ DESCRIPTION
is not necessary or desirable for gd to become a kitchen-sink graphics
package, but version 1.3 incorporates most of the commonly requested
features for an 8-bit 2D package. Support for scalable fonts, and
- truecolor images, JPEG and PNG is planned for version 2.0. Version 1.3
- was released to correct longstanding bugs and provide an LZW-free GIF
- compression routine.
+ truecolor images, JPEG and PNG is planned for version 2.0.
AUTHOR
- gd 1.2 was written by Thomas Boutell and is currently distributed by
+ gd was written by Thomas Boutell and is currently distributed by
boutell.com, Inc.
+WWW: http://www.boutell.com/gd/
This port draws text using fonts in Russian KOI8-R encoding.
--
diff --git a/russian/gd/pkg-plist b/russian/gd/pkg-plist
index 20dd72e9d3f8..c9f2fb09760e 100644
--- a/russian/gd/pkg-plist
+++ b/russian/gd/pkg-plist
@@ -1,14 +1,22 @@
-bin/gddemo
-bin/giftogd
-bin/webgif
+bin/bdftogd
+bin/pngtogd
+bin/pngtogd2
+bin/gdtopng
+bin/gd2topng
+bin/gd2copypal
+bin/gdparttopng
+bin/webpng
include/gd/gd.h
+include/gd/gd_io.h
+include/gd/gdcache.h
include/gd/gdfontg.h
include/gd/gdfontl.h
include/gd/gdfontmb.h
include/gd/gdfonts.h
include/gd/gdfontt.h
lib/libgd.a
-share/examples/gd/demoin.gif
-share/examples/gd/index.html
+lib/libgd.so
+lib/libgd.so.0
+@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
+@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
@dirrm include/gd
-@dirrm share/examples/gd