aboutsummaryrefslogtreecommitdiff
path: root/russian/wordpress
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-01-06 07:32:54 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-01-06 07:32:54 +0000
commit1627402b0bd2a10da5d1c0a95113efc23a2579b7 (patch)
treec867a97aa5e5c4a4786091e0aa95976e0d01e4b4 /russian/wordpress
parent8566977db0aeadd144db773f4da622f3a29679ea (diff)
downloadports-1627402b0bd2a10da5d1c0a95113efc23a2579b7.tar.gz
ports-1627402b0bd2a10da5d1c0a95113efc23a2579b7.zip
Notes
Diffstat (limited to 'russian/wordpress')
-rw-r--r--russian/wordpress/Makefile56
-rw-r--r--russian/wordpress/distinfo2
-rw-r--r--russian/wordpress/files/pkg-message.in6
-rw-r--r--russian/wordpress/pkg-descr7
4 files changed, 71 insertions, 0 deletions
diff --git a/russian/wordpress/Makefile b/russian/wordpress/Makefile
new file mode 100644
index 000000000000..6d78cdeaa0ba
--- /dev/null
+++ b/russian/wordpress/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: wordpress
+# Date created: 2011-12-27
+# Whom: Mihail Timofeev <9267096@gmail.com>
+# (based on wordpress by Elvis Chiang)
+#
+# $FreeBSD$
+#
+
+PORTNAME= wordpress
+PORTVERSION= 3.3.1
+CATEGORIES= russian www
+MASTER_SITES= http://ru.wordpress.org/
+PKGNAMESUFFIX= -ru
+DISTNAME= ${PORTNAME}-${PORTVERSION}${PKGNAMESUFFIX}_RU
+
+MAINTAINER= 9267096@gmail.com
+COMMENT= A state-of-the-art semantic personal publishing platform
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/license.txt
+
+CONFLICTS_INSTALL= wordpress-3.* de-wordpress-de-3.* ja-wordpress-ja-3.*
+
+NO_BUILD= yes
+USE_PHP= curl gd mysql pcre tokenizer xml zip
+WANT_PHP_WEB= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+PLIST= ${WRKDIR}/pkg-plist
+PORTDOCS= license.txt readme.html
+SUB_FILES= pkg-message
+
+pre-everything::
+ @${ECHO_CMD} "If you want to upgrade, you must read upgrade document."
+ @${ECHO_CMD} ""
+ @sleep 1
+
+pre-install:
+ cd ${WRKSRC}/ && \
+ (${FIND} -s * -type f | ${SED} -e 's|^|%%WWWDIR%%/|'; \
+ ${FIND} -d . -type d | ${SED} -e 's|^\.|@dirrm %%WWWDIR%%|') > ${PLIST}
+ if [ ! -f ${WRKSRC}/wp-config-sample.php ]; then ${CP} \
+ ${WRKSRC}/wp-config.php.sample ${WRKSRC}/wp-config.php; fi
+
+do-install:
+ ${INSTALL} -d -g ${WWWGRP} -m 755 -o ${WWWOWN} ${WWWDIR}/
+ ${CP} -R ${WRKSRC}/ ${WWWDIR}/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}/
+ cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/russian/wordpress/distinfo b/russian/wordpress/distinfo
new file mode 100644
index 000000000000..6f7b1d0e7280
--- /dev/null
+++ b/russian/wordpress/distinfo
@@ -0,0 +1,2 @@
+SHA256 (wordpress-3.3.1-ru_RU.tar.gz) = 4c2754ac62e8073ad744a596a7e70b0c4152a2c36fde635092757b65b2da5cf0
+SIZE (wordpress-3.3.1-ru_RU.tar.gz) = 4322059
diff --git a/russian/wordpress/files/pkg-message.in b/russian/wordpress/files/pkg-message.in
new file mode 100644
index 000000000000..a3c01e1be0d6
--- /dev/null
+++ b/russian/wordpress/files/pkg-message.in
@@ -0,0 +1,6 @@
+ **** NOTE ****
+Before the first use of WordPress, copy wp-config-sample.php to wp-config.php
+in %%WWWDIR%% and modify it to fit your MySQL.
+Maybe you need 'mysqladmin create wordpress' first.
+If you are upgrading from 1.x or 2.x to 3.x, please run
+http://your.site/wordpress/wp-admin/upgrade.php to upgrade to WordPress 3.x
diff --git a/russian/wordpress/pkg-descr b/russian/wordpress/pkg-descr
new file mode 100644
index 000000000000..ff4b0c09cfee
--- /dev/null
+++ b/russian/wordpress/pkg-descr
@@ -0,0 +1,7 @@
+WordPress is a state-of-the-art semantic personal publishing platform
+with a focus on aesthetics, web standards, and usability.
+
+More simply, Wordpress is what you use when you want to work
+with your blogging software, not fight it.
+
+WWW: http://ru.wordpress.org/