aboutsummaryrefslogtreecommitdiff
path: root/science/ALPSCore
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-04-27 09:30:30 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-04-27 09:30:30 +0000
commit889392b50eccd82d15af078db6fe5d3e81e0db5f (patch)
treed458cd1744afc20e4f01e45808c1763bd43dc00d /science/ALPSCore
parent22bbff4e59b8c730d2265f8ab606ee04e93dd5e7 (diff)
downloadports-889392b50eccd82d15af078db6fe5d3e81e0db5f.tar.gz
ports-889392b50eccd82d15af078db6fe5d3e81e0db5f.zip
science/ALPSCore: fix build with GCC-based architectures
CMake Error at common/cmake/ALPSCommonModuleDefinitions.cmake:194 (target_compile_features): target_compile_features The compiler feature "cxx_std_11" is not known to CXX compiler "GNU" version 4.2.1. Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D20049
Notes
Notes: svn path=/head/; revision=500205
Diffstat (limited to 'science/ALPSCore')
-rw-r--r--science/ALPSCore/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/science/ALPSCore/Makefile b/science/ALPSCore/Makefile
index a7530f973c92..a52dbdefa1ff 100644
--- a/science/ALPSCore/Makefile
+++ b/science/ALPSCore/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libhdf5.so:science/hdf5 \
libsz.so:science/szip
-USES= cmake eigen:3
+USES= cmake compiler:c++11-lang eigen:3
USE_GITHUB= yes
USE_LDCONFIG= yes
TEST_TARGET= test # 2 to 3 tests fail: https://github.com/ALPSCore/ALPSCore/issues/388