aboutsummaryrefslogtreecommitdiff
path: root/science/ALPSCore
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2019-05-03 12:30:40 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2019-05-03 12:30:40 +0000
commita388e763745fd471503afc08c8776bc2891f67e6 (patch)
treef92b93e32b329552919c185dd8f78d1ec386069f /science/ALPSCore
parentce5b7fea36ec5a18cf33e947013e0edf3ae689cb (diff)
downloadports-a388e763745fd471503afc08c8776bc2891f67e6.tar.gz
ports-a388e763745fd471503afc08c8776bc2891f67e6.zip
compiler.mk is unhappy if CC/CXX is defined before bsd.port.pre.mk
Reported by: Peter Jeremy Submitted by: mat
Notes
Notes: svn path=/head/; revision=500723
Diffstat (limited to 'science/ALPSCore')
-rw-r--r--science/ALPSCore/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/science/ALPSCore/Makefile b/science/ALPSCore/Makefile
index a52dbdefa1ff..f09fd8af7a08 100644
--- a/science/ALPSCore/Makefile
+++ b/science/ALPSCore/Makefile
@@ -38,11 +38,16 @@ DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen
OPENMPI2_CMAKE_BOOL= ENABLE_MPI
OPENMPI2_LIB_DEPENDS= libmpi.so:net/openmpi2
-OPENMPI2_VARS= cc=${LOCALBASE}/mpi/openmpi2/bin/mpicc \
- cxx=${LOCALBASE}/mpi/openmpi2/bin/mpicxx
PORTDOCS= *
+.include <bsd.port.pre.mk>
+
+.if ${PORT_OPTIONS:MOPENMP2}
+CC= ${LOCALBASE}/mpi/openmpi2/bin/mpicc
+CXX= ${LOCALBASE}/mpi/openmpi2/bin/mpicxx
+.endif
+
post-install-DOXYGEN-on:
@${RM} ${STAGEDIR}${DOCSDIR}/.tag
@@ -51,4 +56,4 @@ pre-test:
${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} ${CMAKE_ARGS_TEST} ${CMAKE_SOURCE_PATH} && \
${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>