aboutsummaryrefslogtreecommitdiff
path: root/science/abinit
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-02-27 05:37:33 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-02-27 05:37:33 +0000
commit96709c330465e48e871065d8bed3f2ebee9d9fbd (patch)
treeac0293c517dd7821da4d562994fa9c9582ac434d /science/abinit
parent4715089f05abfe57c702de4b93fc2e8fd76fc6e2 (diff)
Notes
Diffstat (limited to 'science/abinit')
-rw-r--r--science/abinit/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/science/abinit/Makefile b/science/abinit/Makefile
index 812e06e4a2c6..7d56dd27592f 100644
--- a/science/abinit/Makefile
+++ b/science/abinit/Makefile
@@ -3,6 +3,7 @@
PORTNAME= abinit
DISTVERSION= 8.10.3
+PORTREVISION= 1
CATEGORIES= science
MASTER_SITES= https://www.abinit.org/sites/default/files/packages/
@@ -20,8 +21,21 @@ RUN_DEPENDS= atompaw:science/atompaw
USES= fortran gmake localbase:ldflags
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-shared --disable-static
+CONFIGURE_ENV= CC_LDFLAGS="${LDFLAGS}" CXX_LDFLAGS="${LDFLAGS}" FC_LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS= --enable-shared --disable-static
FCFLAGS+= -ffree-line-length-none
+OPTIONS_DEFINE= OPENMP MPI
+OPTIONS_DEFAULT= OPENMP MPI
+
+OPENMP_CONFIGURE_ENABLE= openmp
+OPENMP_LDFLAGS= ${LOCALBASE}/lib/libomp.so
+OPENMP_LIB_DEPENDS= libomp.so:devel/openmp
+
+MPI_CONFIGURE_ENABLE= mpi
+MPI_VARS= FFLAGS+=-I${LOCALBASE}/include FCFLAGS+=-I${LOCALBASE}/include
+MPI_LDFLAGS= ${LOCALBASE}/lib/libmpich.so ${LOCALBASE}/lib/libmpicxx.so ${LOCALBASE}/lib/libmpifort.so
+MPI_LIB_DEPENDS= libmpi.so:net/mpich
+
.include <bsd.port.mk>