aboutsummaryrefslogtreecommitdiff
path: root/science/avogadro/Makefile
diff options
context:
space:
mode:
authorSahil Tandon <sahil@FreeBSD.org>2010-07-16 01:29:59 +0000
committerSahil Tandon <sahil@FreeBSD.org>2010-07-16 01:29:59 +0000
commitf84d275af41d65e181ee91907f04676e5f00c318 (patch)
tree41c9d121111a58ca035cdd44fdb372c80e4d301b /science/avogadro/Makefile
parentc917a9be8bf84e0c9282bb9f5cf21efdbc4ad732 (diff)
downloadports-f84d275af41d65e181ee91907f04676e5f00c318.tar.gz
ports-f84d275af41d65e181ee91907f04676e5f00c318.zip
Notes
Diffstat (limited to 'science/avogadro/Makefile')
-rw-r--r--science/avogadro/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/science/avogadro/Makefile b/science/avogadro/Makefile
index 3cb25981ecb8..80ba882e7eeb 100644
--- a/science/avogadro/Makefile
+++ b/science/avogadro/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= avogadro
-PORTVERSION= 1.0.0
-PORTREVISION= 2
+PORTVERSION= 1.0.1
CATEGORIES= science
MASTER_SITES= SF
@@ -29,12 +28,13 @@ CMAKE_ARGS= -DCMAKE_INSTALL_PREFIX="${PREFIX}" \
USE_GCC= 4.4+
MAKE_JOBS_SAFE= yes
-OPTIONS= PYTHON "Enable python support (broken with sip-4.10)" off
+OPTIONS= PYTHON "Enable python support" off
+
+MAN1= avogadro.1 avopkg.1
.include <bsd.port.options.mk>
.if defined (WITH_PYTHON)
-IGNORE= doesn't compile with devel/py-sip>=4.10
CMAKE_ARGS+= -DENABLE_PYTHON=ON
USE_PYTHON= 2.5+
BUILD_DEPENDS+= ${PYNUMPY} \
@@ -54,4 +54,7 @@ PLIST_SUB+= PYTHON="@comment "
BROKEN= requires posix_memalign
.endif
+post-patch:
+ @${REINPLACE_CMD} 's|share/man|man|' ${WRKSRC}/doc/CMakeLists.txt
+
.include <bsd.port.post.mk>