aboutsummaryrefslogtreecommitdiff
path: root/science/avogadro
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /science/avogadro
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Notes
Notes: svn path=/head/; revision=473503
Diffstat (limited to 'science/avogadro')
-rw-r--r--science/avogadro/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/science/avogadro/Makefile b/science/avogadro/Makefile
index 1b976022a928..8cd864927817 100644
--- a/science/avogadro/Makefile
+++ b/science/avogadro/Makefile
@@ -20,9 +20,9 @@ LIB_DEPENDS= libopenbabel.so:science/openbabel
# We need to add a RUN_DEPENDS on eigen2, as the cmake file shiped with
# avogadro to use it, contains 'find_package(Eigen2 REQUIRED)'.
-USES= cmake desktop-file-utils eigen:2,build,run pkgconfig tar:bzip2
+USES= cmake desktop-file-utils eigen:2,build,run pkgconfig qt:4 tar:bzip2
USE_GL= glu gl
-USE_QT4= gui network opengl \
+USE_QT= gui network opengl \
linguisttools_build moc_build qmake_build rcc_build uic_build
CMAKE_ARGS= -DENABLE_GLSL=OFF \
-DQT_MKSPECS_RELATIVE=share/qt4/mkspecs