aboutsummaryrefslogtreecommitdiff
path: root/science/bagel
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-09-30 21:11:48 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-09-30 21:11:48 +0000
commitb920a8ff50a62ac9e29927a4bf5c26f589a64442 (patch)
tree92d57f9ebff2c40a0827144ad6e561554c23f1f4 /science/bagel
parentd0dd918051bdff001f939ba63f4edca7d6ae01d6 (diff)
downloadports-b920a8ff50a62ac9e29927a4bf5c26f589a64442.tar.gz
ports-b920a8ff50a62ac9e29927a4bf5c26f589a64442.zip
science/bagel: Fix build on 10
Add USES=compiler:c++11-lang and USE_CXXSTD=c++11 Reported by: fallout
Notes
Notes: svn path=/head/; revision=480984
Diffstat (limited to 'science/bagel')
-rw-r--r--science/bagel/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/science/bagel/Makefile b/science/bagel/Makefile
index 2c6f8d044135..7e217ae33465 100644
--- a/science/bagel/Makefile
+++ b/science/bagel/Makefile
@@ -17,11 +17,12 @@ BROKEN_i386= error: static_assert failed "size_t is assumed to be the same size
LIB_DEPENDS= libboost_serialization.so:devel/boost-libs \
libcblas.so:math/cblas
-USES= autoreconf fortran gmake libtool localbase python:build
+USES= autoreconf compiler:c++11-lang fortran gmake libtool localbase python:build
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --datarootdir=${DATADIR}
USE_GITHUB= yes
GH_ACCOUNT= nubakery
+USE_CXXSTD= c++11
USE_LDCONFIG= yes
OPTIONS_DEFINE= MPI LIBXC SCALAPACK SMITH # SLATER (needs a separate lib)