aboutsummaryrefslogtreecommitdiff
path: root/science/cdcl
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-04-07 15:30:00 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-04-07 15:30:00 +0000
commit9edd70ed68863d64e758835ebe678cbc9f4f1af8 (patch)
tree4b0d6575d2c868a4ad917ed0adaf7b146c5233c7 /science/cdcl
parentfbb60c5b938646845a36f9f0c485b1e6dc19d1af (diff)
downloadports-9edd70ed68863d64e758835ebe678cbc9f4f1af8.tar.gz
ports-9edd70ed68863d64e758835ebe678cbc9f4f1af8.zip
Support stage
Notes
Notes: svn path=/head/; revision=350502
Diffstat (limited to 'science/cdcl')
-rw-r--r--science/cdcl/Makefile25
1 files changed, 9 insertions, 16 deletions
diff --git a/science/cdcl/Makefile b/science/cdcl/Makefile
index a7bcdf1a8838..50c8a3635cde 100644
--- a/science/cdcl/Makefile
+++ b/science/cdcl/Makefile
@@ -12,20 +12,17 @@ DISTNAME= dcl-${PORTVERSION}-C
MAINTAINER= murashin@gfd-dennou.org
COMMENT= Scientific graphic library for geoscience
-USES= pkgconfig
-USE_GCC= any
+OPTIONS_DEFINE= DOCS
+USES= desthack pkgconfig
USE_XORG= x11 xext
USE_GNOME= gtk20 gdkpixbuf2
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX} --exec-prefix=${PREFIX} --with-x --enable-shared
+CONFIGURE_ARGS= --with-x --enable-shared
PLIST_SUB= DCL_VERSION=${PORTVERSION:S/.//g}
MAKE_JOBS_UNSAFE= yes
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
BINARIES= cdclcmap cdclclr cdcldate cdcldbs cdclexec cdclfont \
cdclpara cdcltone cdcltrf cdclver
PORTDOCS= CHECK CREDITS HISTORY README
@@ -38,17 +35,13 @@ post-configure:
post-install:
.for i in ${BINARIES}
- ${STRIP_CMD} ${PREFIX}/bin/${i}
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${i}
.endfor
-.if !defined(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}
- (cd ${WRKSRC}/demo/ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
-.endif
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ (cd ${WRKSRC}/demo/ && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}/
.endfor
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>