aboutsummaryrefslogtreecommitdiff
path: root/science/cdk
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-01-09 16:48:21 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-01-09 16:48:21 +0000
commit34506c3888af23944c86ed23b40d1a7be42130f2 (patch)
tree4e936f0dd822fc36e27fa2559cde60f4daac002a /science/cdk
parent333c24d6103cdc88dd8a1448cd769938b846b80d (diff)
downloadports-34506c3888af23944c86ed23b40d1a7be42130f2.tar.gz
ports-34506c3888af23944c86ed23b40d1a7be42130f2.zip
New port: science/cdk: Chemistry Development Kit
Notes
Notes: svn path=/head/; revision=522497
Diffstat (limited to 'science/cdk')
-rw-r--r--science/cdk/Makefile54
-rw-r--r--science/cdk/distinfo5
-rw-r--r--science/cdk/pkg-descr13
3 files changed, 72 insertions, 0 deletions
diff --git a/science/cdk/Makefile b/science/cdk/Makefile
new file mode 100644
index 000000000000..6aa6cdeb61fe
--- /dev/null
+++ b/science/cdk/Makefile
@@ -0,0 +1,54 @@
+# $FreeBSD$
+
+PORTNAME= cdk
+DISTVERSIONPREFIX= cdk-
+DISTVERSION= 2.3
+CATEGORIES= science java
+PKGNAMESUFFIX= -chemistry
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Chemistry Development Kit
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+BUILD_DEPENDS= mvn:devel/maven
+
+USE_JAVA= yes
+USE_GITHUB= yes
+
+NO_ARCH= yes
+
+PLIST_FILES= ${JAVAJARDIR}/${PORTNAME}-${PORTVERSION}.jar
+
+# to rebuild the deps archive:
+# 1. set DEV_UPDATE_MODE=yes
+# 2. make makesum build
+# 3. upload the *-deps archive
+# 4. set DEV_UPDATE_MODE=no
+# 5. make clean makesum
+
+DEV_UPDATE_MODE= no
+
+.if (${DEV_UPDATE_MODE} == "yes")
+post-build:
+ @cd ${WRKDIR} && ${TAR} czf ${DISTDIR}/${PORTNAME}-${DISTVERSION}-deps${EXTRACT_SUFX} .m2
+ @${ECHO} "(!!!) Please upload the deps archive: ${DISTDIR}/${PORTNAME}-${DISTVERSION}-deps${EXTRACT_SUFX}"
+.else
+MASTER_SITES+= LOCAL/yuri/:deps
+DISTFILES+= ${PORTNAME}-${DISTVERSION}-deps${EXTRACT_SUFX}:deps
+MVN_ARGS= --offline
+.endif
+
+do-build:
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} \
+ ${LOCALBASE}/bin/mvn ${MVN_ARGS} \
+ -fae install \
+ -Dmaven.test.skip=true \
+ -Duser.home=${WRKDIR} \
+ install
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/bundle/target/${PORTNAME}-${PORTVERSION}.jar ${STAGEDIR}${JAVAJARDIR}/${PORTNAME}-${PORTVERSION}.jar
+
+.include <bsd.port.mk>
diff --git a/science/cdk/distinfo b/science/cdk/distinfo
new file mode 100644
index 000000000000..0b8d90bb182f
--- /dev/null
+++ b/science/cdk/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1578560238
+SHA256 (cdk-2.3-deps.tar.gz) = d3df87bc95d2302f92b60bc1e6fd5172c341aae2f831f263f6508de2f31bcf99
+SIZE (cdk-2.3-deps.tar.gz) = 63038171
+SHA256 (cdk-cdk-cdk-2.3_GH0.tar.gz) = 169772895f6d49c5a66e32da059e1d63f5cd77aa3ffdeed4942dcd76eb8d399d
+SIZE (cdk-cdk-cdk-2.3_GH0.tar.gz) = 26499872
diff --git a/science/cdk/pkg-descr b/science/cdk/pkg-descr
new file mode 100644
index 000000000000..91b69937c2d0
--- /dev/null
+++ b/science/cdk/pkg-descr
@@ -0,0 +1,13 @@
+The CDK is an open-source Java software for cheminformatics and bioinformatics.
+
+Key Features:
+* Molecule and reaction valence bond representation.
+* Read and write file formats: SMILES, SDF, InChI, Mol2, CML, and others.
+* Efficient molecule processing algorithms: Ring Finding, Kekulisation, Aromaticity.
+* Coordinate generation and rendering.
+* Canonical identifiers for fast exact searching.
+* Substructure and SMARTS pattern searching.
+* ECFP, Daylight, MACCS, and other fingerprint methods for similarity searching.
+* QSAR descriptor calculations
+
+WWW: https://cdk.github.io/