aboutsummaryrefslogtreecommitdiff
path: root/science/cgnslib
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2018-03-22 08:33:19 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2018-03-22 08:33:19 +0000
commit3e49880ca35345db7cc810778ca859f355c0265a (patch)
tree070c622c961e5ac94a059078da82d6dc8cc62de2 /science/cgnslib
parent47f51016930148e46f31a47c108043cf287651d5 (diff)
downloadports-3e49880ca35345db7cc810778ca859f355c0265a.tar.gz
ports-3e49880ca35345db7cc810778ca859f355c0265a.zip
- Add missing depend on libX11
- Switch to new test framework Approved by: portmgr blanket
Notes
Notes: svn path=/head/; revision=465267
Diffstat (limited to 'science/cgnslib')
-rw-r--r--science/cgnslib/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/science/cgnslib/Makefile b/science/cgnslib/Makefile
index d4a79cc9e6c7..2214f573c7a3 100644
--- a/science/cgnslib/Makefile
+++ b/science/cgnslib/Makefile
@@ -52,7 +52,7 @@ TESTSBIN= cgwrite cgread test_partial
.if ${PORT_OPTIONS:MTOOLS}
USES+= tk
USE_GL= gl glu
-USE_XORG= xmu
+USE_XORG= x11 xmu
CMAKE_ARGS+= -DCGNS_BUILD_CGNSTOOLS:BOOL=TRUE \
-DTCL_INCLUDE_PATH:STRING="${TCL_INCLUDEDIR}" \
-DTK_INCLUDE_PATH:STRING="${TK_INCLUDEDIR}"
@@ -63,12 +63,10 @@ PLIST_SUB= TOOLS="@comment "
LIBVER= ${PORTVERSION:R}
-.if ${PORT_OPTIONS:MTESTS}
-regression-test:
-. for pg in ${TESTSBIN}
+do-test-TESTS-on:
+.for pg in ${TESTSBIN}
@(cd ${BUILD_WRKSRC}/src/tests; ./${pg})
-. endfor
-.endif
+.endfor
post-install:
${LN} -sf libcgns.so.${LIBVER} ${STAGEDIR}${PREFIX}/lib/libcgns.so.${LIBVER:R}